[Résolu] Bug sur les fiches de produits variables (Créer un compte)

  • WordPress :6.2
  • Statut : résolu
  • Ce sujet contient 10 réponses, 3 participants et a été mis à jour pour la dernière fois par Broussaille, le il y a 11 mois.
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2456774
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Ma configuration WP actuelle :
    – Version de WordPress : 6.2.2
    – Version de PHP / MySQL : 7.4.33 / 5.5.5
    – Thème utilisé : Blocksy Child (slug : blocksy-child)
    – Thème parent : Blocksy (slug : blocksy)
    – Thème URI : https://creativethemes.com/blocksy/
    – Extensions activées : Advanced Editor Tools (5.9.0), Blocksy Companion (1.8.93), Boxtal Connect (1.2.16), Complianz | GDPR/CCPA Cookie Consent (6.4.7), Email Templates (1.4.2), Enhanced Media Library (2.8.9), everwpvisitcounter (1.2.3), Forminator (1.24.1), Imagify (2.1.1), Infosite (6), Lightbox with PhotoSwipe (5.0.40), Local Google Fonts (0.21.0), MailPoet (4.19.0), Preview E-mails for WooCommerce (2.1.3), Rank Math SEO (1.0.117.1), Rank Math SEO PRO (3.0.38), SecuPress Pro — WordPress Security (2.2.4), WooCommerce (7.8.0), WooCommerce PayPal Payments (2.1.0), WooCommerce Stripe Gateway (7.4.1), WP Mail Logging (1.12.0), WP Mail SMTP (3.8.0), WP Rocket (3.14)
    – Adresse du site : https://broussaillestore.fr
    – Hébergeur : o2switch

    Bonjour à toutes & à tous.

    Problème(s) rencontré(s) : Bon, comme je le relatais dans une demande antérieure, j’ai bien galéré pour passer en php 8. Ce problème est résolu, j’ai changé de thème, etc…

    Mais il restait un truc qui me chiffonnait : un blocage des options d’écran lors de la création d’une fiche de produit variable (plus exactement, une fois celle-ci publiée). Il était impossible de modifier les options d’écrans (catégories, image, etc…) en ajout ou suppression puisqu’il était impossible d’ouvrir ces options. Par ailleurs le texte, une fois la fiche publiée était systématiquement en mode texte (code), la description courte disparaissait, impossible d’avoir accès non plus aux variations… alors que les attributs étaient OK… Bref (sic!)… le bazar…

    J’ai bien tenté, comme d’hab’, la désactivation des extensions, le changement de thème, mais rien à faire. J’ai donc mis en place un site de préproduction, ce qui n’a pas été sans mal car SecuPress, à divers niveaux, bloquait les urls, etc.. J’ai fini par réussir (avec l’aide diligente de o2switch), tout simplement en supprimant SecuPress dans le site de préproduction… Et là, miracle, plus de problème pour les fiches produits variables. En brouillon, en privé, ou publiées, j’ai accès à toutes les fonctionnalités.

    Est-ce que cela vous évoque quelque chose ? J’ai cherché pas mal, sans rien trouvé (sauf quelques vieux trucs datant de la préhistoire de WooCommerce, et pas toujours franchement en rapport…).

    Bon, le tour fait (désactivation, changement de thème… etc…), pas de changement, donc friction SecuPress / WooCommerce, ou entre SecuPress et un autre plugin ? Et dans ce cas, pourquoi la désactivation des extensions (puis réactivation une à une, avec vérification chaque fois), et le changement de thème ne changent rien (même après avoir vidé cache navigateur, cache serveur, etc…).

    (Ouais, c’est un peu long…)

    • Ce sujet a été modifié le il y a 11 mois et 1 semaine par C_Lucien.
    • Ce sujet a été modifié il y a 11 mois et 1 semaine par Flobogo. Raison : déplacé en rubrique "Extensions"
    • Ce sujet a été modifié il y a 11 mois par Flobogo. Raison : modif du titre
    • Ce sujet a été modifié il y a 11 mois par Flobogo. Raison : déplacé en rubrique "Woocommerce"
    #2456782
    C_Lucien
    Modérateur
    Maître WordPress
    5115 contributions

    Bonjour,

    en attendant qu’un éventuel expert simultané de WooCommerce et de Secupress passe par ici, vous pourriez tenter votre chance sur https://secupress.me/support, comme le suggère l’auteur de l’extension lui-même https://wordpress.org/support/topic/woocommerce-and-secupress-checkout-problem/

    #2456793
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Bonsoir C_Lucien (ou bonne nuit !). Oui j’ai effectivement fait un retour à SecuPress. Mais je me suis dit qu’il était possible qu’un utilisateur de l’une ou l’autre extension ait eut quelques soucis du genre et pourquoi pas, une solution. Sur le support de SecuPress c’est le week-end, alors que sur  ce forum il y a toujours une bonne âme qui répond ! Donc merci, ne serait-ce que pour avoir pris le temps de lire cette demande et d’y faire une réponse ????

    #2456794
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Bonsoir C_Lucien (ou bonne nuit !). Oui j’ai effectivement fait un retour à SecuPress. Mais je me suis dit qu’il était possible qu’un utilisateur de l’une ou l’autre extension ait eut quelques soucis du genre et pourquoi pas, une solution. Sur le support de SecuPress c’est le week-end, alors que sur  ce forum il y a toujours une bonne âme qui répond ! Donc merci, ne serait-ce que pour avoir pris le temps de lire cette demande et d’y faire une réponse ????

    #2456796
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Bonsoir C_Lucien (ou bonne nuit !). Oui j’ai effectivement fait un retour à SecuPress. Mais je me suis dit qu’il était possible qu’un utilisateur de l’une ou l’autre extension ait eut quelques soucis du genre et pourquoi pas, une solution. Sur le support de SecuPress c’est le week-end, alors que sur  ce forum il y a toujours une bonne âme qui répond ! Donc merci, ne serait-ce que pour avoir pris le temps de lire cette demande et d’y faire une réponse ????

    #2457102
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Bonjour à toutes et à tous. Bon j’ai trouvé la solution (en fait c’est Valérie de SecuPress qui m’a donné la réponse, car elle a su trouver la bonne page web avec la solution : celle-ci).

    Le problème ne venait donc pas d’une possible friction entre ces deux plugins, mais d’une erreur dans le fichier de traduction (d’origine) de Woocommerce.

    J’ai donc remplacé le fichier woocommerce-fr_FR.mo (dans le dossier wp-content > languages > woocommerce), et j’ai récupéré toutes les options dans les fiches de produits variables.

    Je poste la solution ici, mais le titre du post n’est pas très parlant. Est-ce qu’un(e) administratrice/ administrateur pourrait en changer ? Afin que quelqu’un(e) rencontrant le même problème puisse trouver cette solution ? Merci.

    Je poste aussi le fichier, mais ATTENTION, selon le moment ou vous voudrez l’utiliser il sera certainement préférable d’aller chercher la dernière version stable sur la page en lien.

    #2457103
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Ah, ben non, je ne poste pas le fichier, il est trop lourd… Désolé, mais comme je disais, il vaut mieux aller le télécharger

    #2457237
    Flobogo
    Modérateur
    Maître WordPress
    20131 contributions

    Bonjour,

    Je poste la solution ici, mais le titre du post n’est pas très parlant. Est-ce qu’un(e) administratrice/ administrateur pourrait en changer ?

    Les admin’, non. Les modos, oui. Mais je ne comprends pas bien ce que tu souhaites comme titre.
    Changer le titre quand on connaît la solution, c’est facile … mais ceux qui auront le même problème (les mêmes effets) vont-ils comprendre que c’est pour la même raison ?

    D’ailleurs, je ne comprends pas bien comment une erreur de trad’ peut provoquer autant d’erreurs sur l’affichage … et quel lien avec PHP 8  ?

    #2457245
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Salut Flobogo. C’est bien toute l’ambiguïté du titre. J’ai posté sous celui-ci pensant, à tort après moults tests, que le problème venait d’une ‘friction’…. Ce qui s’est avéré tout à fait faux. À cela s’ajoutait un problème de PHP. Le problème de PHP a été réglé ( un bout de code mal copié). Ce que je souhaiterais c’est un titre faisant uniquement référence au problème des fiches produits variables. C’est un problème rencontré par plusieurs utilisateurs, et qui, lui, est effectivement lié au fichier de traduction de woocommerce. D’où le lien.

    Et, effectivement, la ‘mauvaise’ traduction bloque les options d’écran pour les fiches de produits variables. Un truc du genre s% plutôt que %s. Et moi non plus je ne comprends pas le fond du problème. Mais ça marche. Après ‘rechargement’ du fichier le problème est résolu.

    Bon, ça paraît un peu ésotérique, mais pas du tout. Promis !

    #2457263
    Flobogo
    Modérateur
    Maître WordPress
    20131 contributions

    Bon, j’ai mis un titre très évasif. Et je déplace en sous-forum « Woocommerce », puisque c’est un pb spécifique aux fiches produits de WC

    #2457332
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Merci.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.