Fatal error: Uncaught Error: Class ‘WooCommerce’ not found (Créer un compte)

  • WordPress :5.5
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2365635
    PhilippeHilarion
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.0
    • Thème utilisé : avada
    • Extensions en place : woocommerce
    • Nom de l’hébergeur : ovh
    • Adresse du site : youpitours.fr

    Problème(s) rencontré(s) :

    bonjour à tous…

    suite à la mise à jours de WordPress ce matin j’ai lancé les mises à jours d’extensions…

    le site a planté, message d’erreur, j’ai mis true à debug dans wp-config et voici l’erreur fatale :

    Fatal error:
    Uncaught Error:
    Class ‘WooCommerce’ not found in /home/youpitoupw/www/wp-content/plugins/woocommerce/woocommerce.php:47
    Stack trace:
    #0 /home/youpitoupw/www/wp-content/plugins/woocommerce-gateway-paypal-express-checkout/includes/class-wc-gateway-ppec-plugin.php(278): WC()
    #1 /home/youpitoupw/www/wp-content/plugins/woocommerce-gateway-paypal-express-checkout/includes/class-wc-gateway-ppec-plugin.php(176): WC_Gateway_PPEC_Plugin->_check_dependencies()
    #2 /home/youpitoupw/www/wp-includes/class-wp-hook.php(287): WC_Gateway_PPEC_Plugin->bootstrap(”)
    #3 /home/youpitoupw/www/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #4 /home/youpitoupw/www/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #5 /home/youpitoupw/www/wp-settings.php(420): do_action(‘plugins_loaded’)
    #6 /home/youpitoupw/www/wp-config.php(92): require_once(‘/home/youpitoup…’)
    #7 /home/youpitoupw/www/wp-load.php(37): require_once(‘/home/youpitoup…’)
    #8 /home/youpitoupw/www/wp-blog-header.php(13): require_once(‘/home/y in /home/youpitoupw/www/wp-content/plugins/woocommerce/woocommerce.php on line 47

     

    toujours pas d’accès au tableau de bord du site… comment puis-je désactiver woocommerce, puisque c’est lui a priori qui bloque pour arriver de nouveau à accéder au tableau de bord afin de corriger ce bordel.

    merci d’avance

    Philippe

    • Ce sujet a été modifié le il y a 1 semaine et 3 jours par PhilippeHilarion.
    #2365637
    ferman
    Participant
    Maître WordPress
    3516 contributions

    Bonjour,

    Par FTP, en utilisant Filezilla (ou équivalent), allez dans les dossiers de votre site et renommez le dossier woocommerce  (wp-content/plugins/woocommerce) en woocommerce X. Vous devriez avoir accès au tableau de bord.

    Si vous ne l’avez pas encore, il faut télécharger sur votre PC l’extension “Filezilla”. Vous pouvez le faire à partir d’ici ou bien comme indiqué sur cette vidéo.

    #2365639
    PhilippeHilarion
    Participant
    Initié WordPress
    3 contributions

    merci j’ai de nouveau accès au tableau de bord….

    je vais faire une sauvegarde et ré installer woocommerce, merci

    #2365767
    Flobogo
    Modérateur
    Maître WordPress
    16681 contributions

    Bonjour,

    Il faudrait peut-être une version supérieure de PHP, par ex. PHP 7.2 ou 7.3 pour que tout fonctionne bien.

    #2365781
    PhilippeHilarion
    Participant
    Initié WordPress
    3 contributions

    merci, je vais faire la mise à jour de php…

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.