Fatal error suite à la migration d’un site (Créer un compte)

  • WordPress :5.2
  • Statut : non résolu
  • Ce sujet contient 1 réponse, 2 participants et a été mis à jour pour la dernière fois par ferman, le il y a 4 mois.
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #2296001
    spip93
    Participant
    Padawan WordPress
    55 contributions

    Bonjour à tous et à toutes,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP 7.2/MySql 5.5
    • Thème utilisé : Thème créé par l’ancien prestataire à partir de Sage
    • Extensions en place :

    Advanced Custom Fields PRO
    Classic Editor
    Clean Image Filenames
    Custom Post Type UI
    Duplicator
    Formidable Forms
    Formidable Forms Pro
    Nested Pages
    Popup Builder
    Redirection
    Revisr
    SVG Support
    WP Maintenance Mode
    WP Migrate DB Pro
    WP Migrate DB Pro Media Files
    WP Migrate DB Pro Theme & Plugin Files
    WPML Media
    WPML Multilingual CMS
    WPML String Translation
    WPML Translation Management
    Yoast SEO

    • Nom de l’hébergeur : 1and1 Ionos

    Problème(s) rencontré(s) :

    (Je vais essayer de faire court) J’aide un copain à reprendre en main son site, le temps qu’il trouve quelqu’un d’autre.

    Depuis l’année dernière le copain en question a fait appel à un prestataire pour reprendre son site Internet sous WordPress. Il a plusieurs noms de domaines notamment un en .fr et l’autre en .com

    Le prestataire a :

    • refait le site sur son serveur
    • redirigé le .fr vers le .com
    • fait pointer le .com vers son serveur
    • utilisé (sur le .com) un thème à base de Sage

    Comme le prestataire ne fait plus rien depuis des mois et que l’hébergement arrive à termes dans quelques jours, j’ai repris les choses en main le temps que le copain trouve quelqu’un à temps plein.

    Ainsi j’ai :

    • Demandé (et obtenu) les droits administrateurs
    • Demandé (mais j’attends toujours depuis 1 semaine) par mail et SMS au prestataire d’avoir les identifiants et MDP du FTP et de la BDD
    • (comme je n’avais pas les identifiants et MDP du FTP et de la BDD) installé le plugin Duplicator
    • Fait une copie (grâce à Duplicator) des fichiers et de la BDD
    • Uploadé, sur le serveur FTP de 1and1 Ionos, un fichier Zip contenant les fichiers et une copie de la BDD
    • (sur l’espace client de 1and1 Ionos) Pointé, dans la partie DNS, le .fr vers les serveurs de 1and1 Ionos
    • Ce matin, déployé (non sans mal) les fichiers et la BDD

    Je peux accéder sans problème au B.O du site, en revanche, quand je vais sur le site en lui-même, j’ai les messages d’erreurs suivants :

    Fatal error: Uncaught InvalidArgumentException: View [blocks.] not found. in /wp-content/themes/nom_ancien_prestataire/vendor/illuminate/view/FileViewFinder.php:137
    Stack trace:
    #0 /wp-content/themes/nom_ancien_prestataire/vendor/illuminate/view/FileViewFinder.php(79): IlluminateViewFileViewFinder->findInPaths(‘blocks.’, Array)
    #1 /wp-content/themes/nom_ancien_prestataire/vendor/illuminate/view/Factory.php(128): IlluminateViewFileViewFinder->find(‘blocks.’)
    #2 /wp-content/uploads/cache/9218b1b9010be5119c7f2266b7dea7209c11add0.php(9): IlluminateViewFactory->make(‘blocks.’, Array)
    #3 /wp-content/themes/nom_ancien_prestataire/vendor/illuminate/view/Engines/PhpEngine.php(43): include(‘/homepages/1/d6…’)
    #4 /wp-content/the in /wp-content/themes/nom_ancien_prestataire/vendor/illuminate/view/FileViewFinder.php on line 137

    Avez-vous une idée d’où vien(nen)t le(s) problème(s) et surtout comment le(s) résoudre ?

    D’avance merci pour vos réponses et votre aide 😉

    Bonne journée

    #2296024
    ferman
    Participant
    Maître WordPress
    2516 contributions

    Bonjour,

    Clairement le thème “ancien_prestataire ” pose problème. Il faudra en changer.

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.