Fatal error Slider Revolution (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #2377021
    Insyst
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle

    WordPress version 5.7.1
    Thème actuel : consulting-child (version 1.0)
    Extension actuelle : Slider Revolution (version 6.3.9)
    PHP version 7.3.27

    Problème(s) rencontré(s) :

    J’ai un souci avec l’extension Slider Revolution qui fait planter tout mon site… Voici le message d’erreur que j’ai reçu par mail

    Détails de l’erreur
    ======================
    Une erreur de type E_ERROR a été causée dans la ligne 15 du fichier /home/insystfrky/www/wp-<wbr />content/plugins/revslider/<wbr />admin/views/modals-copyright.<wbr />php. Message d’erreur : Uncaught Error: Call to undefined method RevSliderFunctions::get_<wbr />addition() in /home/insystfrky/www/wp-<wbr />content/plugins/revslider/<wbr />admin/views/modals-copyright.<wbr />php:15
    Stack trace:
    #0 /home/insystfrky/www/wp-<wbr />content/plugins/revslider/<wbr />admin/includes/shortcode_<wbr />generator/shortcode_generator.<wbr />class.php(229): require_once()
    #1 /home/insystfrky/www/wp-<wbr />includes/class-wp-hook.php(<wbr />292): RevSliderShortcodeWizard::<wbr />enqueue_files(”)
    #2 /home/insystfrky/www/wp-<wbr />includes/class-wp-hook.php(<wbr />316): WP_Hook->apply_filters(”, Array)
    #3 /home/insystfrky/www/wp-<wbr />includes/plugin.php(484): WP_Hook->do_action(Array)
    #4 /home/insystfrky/www/wp-admin/<wbr />admin-footer.php(78): do_action(‘admin_footer’, ”)
    #5 /home/insystfrky/www/wp-admin/<wbr />admin.php(297): require_once(‘/home/insystfrk.<wbr />..’)
    #6 /home/insystfrky/www/wp-admin/<wbr />themes.php(10): require_once(‘/home/insystfrk.<wbr />..’)
    #7 {main}
    thrown

     

    Merci d’avance pour votre aide

    #2377025
    ferman
    Participant
    Maître WordPress
    3970 contributions

    Bonjour,

    Si c’est arrivé après une mise à jour de l’extension, la mise à jour s’est peut-être mal passée auquel cas il faut la refaire. Faites une recherche google aveec les termes suivants  “content/plugins/revslider admin/views/modals-copyright”: vous verrez ce qui a été fait pour des cas semblables au vôtre .

    #2377027
    Insyst
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    C’est exactement ce qui s’est passé, effectivement. J’ai mis à jour les extensions et j’ai eu ce soucis.

    Merci pour l’astuce mais j’ai déjà recherché sur Google et je ne trouve pas la solution à ce problème…

    #2377044
    ferman
    Participant
    Maître WordPress
    3970 contributions

    Avez vous essayé de désactiver l’extension depuis le tableau de bord? (ou par FTP si vous n’avez pas accès à l’admin wp). Dans le deuxième cas, savez-vous le faire ou bien avez-vous besoin d’instructions?

    #2377046
    Insyst
    Participant
    Initié WordPress
    5 contributions

    Oui je l’ai désactivé et réactivité, mais rien n’a changé… :/

    #2377048
    ferman
    Participant
    Maître WordPress
    3970 contributions

    Si vous ne l’avez pas déjà fait, essayez en désactivant d’un bloc  toutes les extensions. Si ça ne change rien, passez à un thème par défaut wordpress (twenty-quelque chose). Dès que le problème disparaît, réactivez les extensions en commençant par Slider revolution.

    Au fait, comment Slider Revolution fait-il planter le site? Vous ne voyez plus rien ou bien certaines choses restent accessibles? Je suppose que vous avez accès à votre administration?

    • Cette réponse a été modifiée le il y a 1 jour et 20 heures par ferman.
    #2377050
    Insyst
    Participant
    Initié WordPress
    5 contributions

    Je préférerai garder mes extensions correctement paramétrés. En fait, je pense qu’en ayant mis à jour les extensions et les différents thèmes sur mon wordpress (y compris les thèmes que je n’utilise pas), mon thème consulting-child s’est désactivé… Je dois faire appelle à la personne qui a créé mon site pour qu’elle m’active le thème enfant je pense.

    Oui j’ai accès à l’administration.

    Alors non, je n’ai plus accès à rien sur le site, il y a un message d’erreur (voir pièce jointe).

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2377076
    ferman
    Participant
    Maître WordPress
    3970 contributions

    Vous pourriez au moins essayer d’activer un autre thème et voir si le problème disparaît (si vous voyez votre site, même déformé). J’en doute mais tant mieux si c’est le cas.

    #2377114
    Insyst
    Participant
    Initié WordPress
    5 contributions

    Je vous remercie pour votre aide, j’ai contacté la personne qui avait créé le site et elle a su corriger le problème.

    Merci

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.