[Résolu] Fatal Error Elementor (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2413874
    ISM
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle :
    – Version de WordPress : 5.8.4
    – Version de PHP/MySQL : 7.4.30 / 5.7.38
    – Thème utilisé : Bard
    – Thème URI : https://wp-royal.com/themes/it<wbr />em-bard-free/
    – Extensions en place : Advanced Order Export For WooCommerce (3.3.2), Advanced Shipment Tracking for WooCommerce (3.4.5), BlossomThemes Toolkit (2.2.3), Boxtal Connect (1.2.14), Broken Link Checker (1.11.17), Colissimo shipping methods for WooCommerce (1.7.1), Coupon Affiliates for WooCommerce (5.1.2), Customizer for WooCommerce (2.7.7), Elementor (3.7.0), Elementor Pro (3.4.2), Email Templates (1.3.2.1), Facebook for WooCommerce (2.6.20), Flexible PDF Coupons for WooCommerce (1.5.7), Forum_wordpress_fr (4.2), GA Google Analytics (20220517), Google Ads & Marketing by Kliken (1.0.8), Hide Shipping Method For WooCommerce (1.3.2), Jetpack by WordPress.com (9.5.3), Mailchimp for WooCommerce (2.7.2), Mailjet for WordPress (5.2.23), Max Mega Menu (2.9.7), Plugin for Google Reviews (2.2.1), Site Kit by Google (1.80.0), Smash Balloon Instagram Feed (6.0.6), WooCommerce (6.7.0), WooCommerce PDF Invoices & Packing Slips (3.0.1), WooCommerce Referral System (1.3.9.11), WooCommerce Shipping & Tax (1.26.3), WooCommerce Stripe Gateway (6.5.1), WooCommerce Subscriptions (4.5.0), WPCode – Insert Headers, Footers, and Code Snippets (2.0.1), WPForms Lite (1.7.5.5), WP Maintenance Mode & Coming Soon (2.4.7), WP Rollback (1.7.1), Yoast SEO (17.4)
    – Adresse du site : https://cosymoodbox.fr
    – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    Le site apparait en ligne en version mobile mais pas sur PC.

    Le message d’erreur suivant s’affiche :

    <b>Fatal error</b>: Uncaught ReflectionException: Method get_site_editor_type does not exist in /homepages/15/d848680895/htdocs/clickandbuilds/cosymoodbox/wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php:48 Stack trace: #0 /homepages/15/d848680895/htdocs/clickandbuilds/cosymoodbox/wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php(48): ReflectionClass->getMethod(‘get_site_editor…’) #1 /homepages/15/d848680895/htdocs/clickandbuilds/cosymoodbox/wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php(129): ElementorProModulesThemeBuilderDocumentsTheme_Document::get_site_editor_type_bc() #2 /homepages/15/d848680895/htdocs/clickandbuilds/cosymoodbox/wp-content/plugins/elementor/core/common/modules/finder/categories/create.php(94): ElementorProModulesThemeBuilderDocumentsTheme_Document::get_create_url() #3 /homepages/15/d848680895/htdocs/clickandbuilds/cosymoodbox/wp-content/plugins/elementor/core/common/modules/finder/categories/ in <b>/homepages/15/d848680895/htdocs/clickandbuilds/cosymoodbox/wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php</b> on line <b>48</b>

    je ne peux plus me connecter au tableau de bord qu’en mode de récupération.

    Le plug in elementor dit être e, pause et affiche la même erreur.

    J’ai actualisé le thème et les extensions.

    Avez-vous une idée du problème ? Je n’arrive pas à décrypter le message.

    Merci

    #2413934
    Li-An
    Modérateur
    Maître WordPress
    26651 contributions

    Bonjour, désactivez les autres extensions, mettez un thème par défaut et testez pour voir. Vous pouvez laisser une extension de maintenance pour ne pas effrayer vos visiteurs et utiliser https://www.echodesplugins.li-an.fr/plugins/widget-importer-exporter/ pour sauvegarder le réglage de vos widgets. Vous pouvez aussi regarder dans Outils>Santé du site s’il n’y a pas un problème important.

    Si vous n’avez pas accès à l’admin, allez par FTP au niveau du répertoire wp-content/plugins et changez son nom en pluginsxxx pour désactiver toutes les extensions. Même chose pour le thème dans wp-content/themes/nom-du-theme. Et réessayez.
    Pour retrouver les extensions et le thème, il suffira de remettre les noms par défaut des répertoires.

    #2414008
    ISM
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Merci pour vos conseils.

    J’ai finis par trouver la solution. Cela provenait de la mise à jour du plugin elementor pro.

    j’ai télécharger la dernière version du plugin directement sur le site du fournisseur en zip et basculé sur WP et cela a fonctionné.

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.