Fatal error après mise à jour de Woocommerce

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #547126
    Gilles33980
    Participant
    Initié WordPress
    17 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.1
    – Version de PHP/MySQL :
    – Thème utilisé : Fruitful
    – Extensions en place : NextGen pro, Woocommerce
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.gillesmassicard.fr

    Problème(s) rencontré(s) :

    Après avoir réactivé Woocommerce, une mise à jour était préconisée. Mais une fois celle ci effectuée, voici le message que j’obtiens lorsque je me connecte à mon site (plus aucun accès au tableau de bord WP) :

    Fatal error: Call to undefined method WP_Error::get_message() in /home/gillesmaj/www/wp-content/plugins/woocommerce/includes/class-wc-geolocation.php on line 163.

    Je n’y connait rien mais à force de bidouiller, j’ai trouvé la fameuse ligne 163 (avec NotePad++) qui m’indique :

    $logger->add( ‘geolocation’, ‘Unable to download GeoIP Database: ‘ . $tmp_database->get_message() );

    Est ce que quelqu’un peut m’aider, vu que je n’ai plus aucun accès à mon site …
    merci d’avance

    Gilles

    #994472
    mathieu789
    Participant
    Maître WordPress
    1084 contributions

    quand on va à l’adresse suivante on voit le formulaire de connexion, est ce que tu n’arrives pas à te connecter ?
    http://www.gillesmassicard.fr/wp-login.php

    #994473
    Gilles33980
    Participant
    Initié WordPress
    17 contributions

    J’arrive à me connecter et je tombe sur mon site en mode “visualisation” avec la barre noire de WP mais dés que je veux aller sur le back office, il me met en erreur fatale !

    #994474
    Gilles33980
    Participant
    Initié WordPress
    17 contributions

    En fait, je n’arrive pas à me connecter depuis le lien que tu m’as envoyé mais j’y arrive depuis mon raccourci Firefox …

    #994475
    Gilles33980
    Participant
    Initié WordPress
    17 contributions

    Bon j’ai supprimé Woocommerce en passant par Filezilla et du coup, j’ai à nouveau accès au tableau de bord. Je vais essayer de le réinstaller …
    En tout cas merci pour ta réponse rapide
    a+
    Gilles

    #994476
    Gilles33980
    Participant
    Initié WordPress
    17 contributions

    La nouvelle version mise à jour il y a 2h ne peut pas être activée, elle déclenche l’erreur fatale citée dans mon premier post. Quelqu’un a-t-il eu le même problème ?

    #994477
    ronalddop
    Participant
    Initié WordPress
    14 contributions

    Bonjour,
    Pareil tout marchait bien sur la 2.2.11 et lorsque j’ai mis la 2.3.1 hier, mon backoffice avait disparu…
    J’ai mis 3h à enlever Woocommerce + bdd et dès que je veux le réinstaller et l’activer il me met :
    L’extension n’a pu être activée, car elle a déclenché une erreur fatale.

    #994478
    mathieu789
    Participant
    Maître WordPress
    1084 contributions

    une nouvelle version 2.3.2 est sortie aujourd’hui, c’est la 3me nouvelle version en 2 jours. donc je pense qu’il vaut mieux que vous revenez sur vos sauvegardes avec l’ancienne version et qu’on attende tous quelques jours de plus le temps que ceux qui testent la nouvelle version confirment que tous ces bugs ont disparus

    #994479
    Gilles33980
    Participant
    Initié WordPress
    17 contributions

    A priori, tout fonctionne pour moi depuis ce matin.

    #994480
    yvonne-georgette
    Participant
    Initié WordPress
    35 contributions

    Bonsoir,
    J’ai exactement le meme probleme avec la mise à jour de woocommerce
    Par contre le probleme persiste avec la version 2.3.3
    J’essaie de suivre les conseils donnés sur le forum mais je suis assez novice 😕
    Je n’ai pas voulu me lancer dans l’installation de WPML, pensez vous que l’on va voir apparaitre, ces jours-ci, une nouvelle version va régler le problème?
    Merci!!!

    #994481
    mathieu789
    Participant
    Maître WordPress
    1084 contributions

    la version de 2.3.3 date de hier donc comme je disais dans mon précédant message, il vaut mieux qu’on attende quelques jours le temps que ceux qui testent la nouvelle version confirment que tous ces bugs ont disparus
    si on rajoute le week-end là dedans, je dirais que s’il n’y a pas de version 2.3.4 qui sort d’ici lundi soir, on va pouvoir se pencher sur le problème à ce moment

    #994482
    yvonne-georgette
    Participant
    Initié WordPress
    35 contributions

    Ha okok @mathieu9512, j’avais mal compris.
    Comment dire, si j’attends jusque lundi soir il ne va plus me rester de cheveux!
    Du coup j’ai trouvé les anciennes version de woocommerce, ici:
    https://wordpress.org/plugins/woocommerce/developers/
    Le seul soucis c’est que je ne sais pas comment l’installer car jusqu’à présent j’installais et mettais à jour le plug via “extensions”.
    Donc j’aimerais savoir s’il est possible de neutraliser 2.3.3 pour repasser admettons sur 2.2.11 ?
    Merci!!!

    #994483
    mathieu789
    Participant
    Maître WordPress
    1084 contributions

    il y a des grandes chances que la mise à modifié la base de donnée donc ne retourne pas en arrière à partir d’anciennes sources, tu risque de faire plus de mal que de bien
    pour revenir en arrière, remets une ancienne sauvegarde des fichiers et de la base de données. si tu n’en as pas fait, il reste les sauvegardes d’OVH mais c’est quand même mieux d’en faire soi même :
    http://guides.ovh.com/BackupsSurPlan

    #994484
    mathieu789
    Participant
    Maître WordPress
    1084 contributions

    yvonne-georgette, je ne suis pas sur que le problème soit le même que celui traité dans cette discussion
    commence une nouvelle discussion parce que par exemple j’ai vu une erreur sur cette page :
    http://yvonne-georgette.com/boutique-2/

    c’est une erreur du thème qui n’est plus à jour, par exemple pour l’erreur de cette page, il faut aller dans le fichier indiqué et remplacer “WooCommerce::get_image_size” par “get_image_size”

    #994485
    yvonne-georgette
    Participant
    Initié WordPress
    35 contributions

    Je te remercie @mathieu9512… en effet j’ai fait ma blonde sur ce coup!
    Je laissais trainer une maj de mon theme, je n’avais même pas pensé que ça puisse venir de ça.
    Merci de m’y avoir fait repenser 😉

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.