Fatal error: Allowed memory (Créer un compte)

  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #447211
    joetex
    Membre
    Initié WordPress
    3 contributions

    Hello

    Premier post, pour une premiere emmerde ……:lol: Pour l’instant tout etait nickel

    J’ai depuis hier procédé à la mise à jour de mon wp 2.0.1 vers 2.0.2

    J’ai fait les modifications à la main , comme indiqué sur le site officiel .

    Les explications etant clairs je pensais m’en sortir .

    Une fois les opérations effectuées je me retrouve avec ce message d’erreur :

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 116461 bytes) in /home/blogjeu/public_html/wp-includes/streams.php on line 58

    Ok =) j’ai donc édité le fichier streams , mais je n’y trouve rien en rapport avec cette erreur .

    Ok j’ai donc essayé d’isoler la source de l’erreur . Il se trouve que lorsque je replace le fichier language l’erreur apparait . Mais quand je supprime ce dernier je n’ai plus de problemes .

    Enfin , disons que mon blog fonctionne mais pas l’affichage des themes ( normal)

    Je pense aussi que le passage de la 2.0.1 vers 2.0.2 doit entrainer une modification du fichier de traduction . N’y connaissant rien , je voulais donc savoir si c’etait une erreur connue ou un probleme dans le fichier de traduction .

    Spe de mon serveur .

    PHP4 (with GD)
    MySQL 4.x

    Voilà si quelqu’un pouvait me mettre sur la voie ca serait sympa ……

    #571565
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Hummmm
    Bon j’ai regardé sur le forum allemand..
    Et si j’ai bien compri…

    Il faut desactiver les plugins avant la mise à jour
    http://forum.wordpress.de/showthread.php?t=364
    http://forum.wordpress.de/showthread.php?t=2461
    http://forum.wordpress.de/archive/index.php?t-4292.html

    Si tu lis un peu l’allemand, jpense que tu trouveras des éléments de réponse…

    #571566
    codfingers
    Participant
    Maître WordPress
    541 contributions

    Quelqu’un peu me dire comment faire la mise à jour vers2> 2,02

    y a–til un risque ( chez free?)?
    un tuto mise ajour serait bienvenu.

    merci,

    Edit de AmO : La question n’ayant rien à voir ni avec le forum, ni avec le sujet…
    Merci de créer un sujet pour ton problème 🙂
    http://codex.wordpress.org/Upgrading_WordPress#Detailed_Instructions
    En attendant la VF… que je fais NOW 😋

    #571567
    joetex
    Membre
    Initié WordPress
    3 contributions

    Hello et merci pour vos réponses

    Alors j’ai donc desactivé mes plug-in et refait la reinstallation

    J’avance car le message est presque le meme :

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 131344 bytes) in /home/blogjeu/public_html/wp-includes/gettext.php on line 159

    Avec gettext

    J’ai trouvé un truc qui avait un rapport lointain sur le forum :

    // $MAGIC1 = (int)0x950412de; //bug in PHP 5
    $MAGIC1 = (int) – 1794895138;
    // $MAGIC2 = (int)0xde120495; //bug
    $MAGIC2 = (int) – 569244523;

    J’ai modifié

    Par : $MAGIC1 = (int)0x950412de; //bug in PHP 5
    //$MAGIC1 = (int) – 1794895138;
    $MAGIC2 = (int)0xde120495; //bug
    //$MAGIC2 = (int) – 569244523;

    Sans changement aucun

    Tout refonctionne quand j’enleve le patch de traduction , sauf les themes et images qui ne s’affichent plus

    Quelqu’un aurait il une idée a me balancer ?

    Merci

    #571568
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Remplace dans gettext.php

    // Caching can be turned off
        $this->enable_cache = $enable_cache;
    
        // $MAGIC1 = (int)0x950412de; //bug in PHP 5
        $MAGIC1 = (int) – 1794895138;
        // $MAGIC2 = (int)0xde120495; //bug
        $MAGIC2 = (int) – 569244523;
    
        $this->STREAM = $Reader;
        $magic = $this->readint();
        if ($magic == $MAGIC1) {
          $this->BYTEORDER = 0;
        } elseif ($magic == $MAGIC2) {
          $this->BYTEORDER = 1;
        } else {
          $this->error = 1; // not MO file
          return false;
        }

    par

    // Caching can be turned off
        $this->enable_cache = $enable_cache;
    
        // $MAGIC1 = (int)0x950412de; //bug in PHP 5
        $MAGIC1 = (int) – 1794895138;
        // $MAGIC2 = (int)0xde120495; //bug
        $MAGIC2 = (int) – 569244523;
        $MAGIC3 = (int)  2500072158; // ÄNDERUNG 64 BIT
        
        $this->STREAM = $Reader;
        $magic = $this->readint();
        if ($magic == $MAGIC1 || $magic == $MAGIC3) { // ÄNDERUNG 64 BIT
          $this->BYTEORDER = 0;
        } elseif ($magic == $MAGIC2) {
          $this->BYTEORDER = 1;
        } else {
          $this->error = 1; // not MO file
          return false;
        }

    Réupload ton fichier .mo de traduction, prend un version depuis un pack par exemple
    je vois pas d’autres trucs pour le moment 😉

    #571569
    joetex
    Membre
    Initié WordPress
    3 contributions

    Hello merci amo pour ton aide

    J’ai testé ta soluce mais ca ne marche pas

    Aprés avoir fait tes modifs je me retrouve avec :

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 116461 bytes) in /home/blogjeu/public_html/wp-includes/streams.php on line 58

    🙂 Retour à la case départ

    J’ai l’impression que j’ai plus que me yeux pour pleurer mon blog

    En gros la , j’ai plus qu’a tout reinstallé en priant pour que ma base se reinstalle correctement .

    Merci quand meme

    #571570
    z720
    Membre
    Maître WordPress
    579 contributions

    Je ne sais pas si le problème a “réellement” un rapport avec la traduction.
    Le problème c’est surtout que depouis la mise à jour ton WP semble beaucoup plus gourmand en mémoire et atteint la mémoire limite de ton hébergeur…

    Peut-être que le chargement de la traduction fait simplement déborder le vase.

    #571571
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Pourtant WordPress n’est pas réputé pour etre un script loud en mémoire :s
    Bizarre, bizarre…

    Essai avec une installation “fraiche”

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.