fatal error (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2386766
    artisanat
    Participant
    Chevalier WordPress
    111 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8.0.11
    • Thème utilisé : generatepress
    • Extensions en place : dont woocommerce
    • Nom de l’hébergeur : Infomaniak
    • Adresse du site : https://www.artisanathai.com/

    Problème(s) rencontré(s) : depuis plusieurs semaines mais j’en ai assez je voudrais une solution, j’ai essayé par exemple de rechargé le fichier incriminé par ftp plusieurs fois sans aucun succès !

    <b>Fatal error</b>: Uncaught Error: Call to undefined function set_time_limit() in /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-admin/includes/class-wp-upgrader.php:471 Stack trace: #0 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-admin/includes/class-wp-upgrader.php(797): WP_Upgrader->install_package(Array) #1 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-admin/includes/class-language-pack-upgrader.php(256): WP_Upgrader->run(Array) #2 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-admin/update-core.php(1216): Language_Pack_Upgrader->bulk_upgrade() #3 {main} thrown in <b>/home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-admin/includes/class-wp-upgrader.php</b> on line <b>471</b>

    • Ce sujet a été modifié le il y a 2 années et 6 mois par artisanat.
    #2386771
    ferman
    Participant
    Maître WordPress
    6924 contributions

    Bonjour,

    C’est apparemment dû à votre version php (8). Cela vous gêne pour  faire des choses? Je vois trois solutions possibles; vous repassez en 7.4  ou vous modifiez une ligne du code wp (en principe à éviter), ou vous regardez dans votre hébergement.

    #2386772
    artisanat
    Participant
    Chevalier WordPress
    111 contributions

    non je veux bien faire tout ce qui peut être indispensable !

    pour info j’ai changé pour 8.0 avant hier, et j’avais déjà cette erreur

    je viens de revenir à 7.4 et je vais voir… !

    #2386773
    artisanat
    Participant
    Chevalier WordPress
    111 contributions

    réponse dans mon tableau de bord

     
    <div class= »update-messages lp-show-latest »>
    <h2>Mise à jour de la traduction de WordPress (fr_FR)…</h2>
    <b>Warning</b>: set_time_limit() has been disabled for security reasons in <b>/home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-admin/includes/class-wp-upgrader.php</b> on line <b>471</b>
    La traduction a bien été mise à jour.

    </div>
    <div class= »update-messages lp-show-latest »>
    <h2>Mise à jour de la traduction de Neve (fr_FR)…</h2>
    <b>Warning</b>: set_time_limit() has been disabled for security reasons in <b>/home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-admin/includes/class-wp-upgrader.php</b> on line <b>471</b>
    La traduction a bien été mise à jour.

    </div>

    #2386775
    artisanat
    Participant
    Chevalier WordPress
    111 contributions

    suite

    j’ai cliqué sous l’onglet php set time limit qui était en gris je l’ai mis en bleu (mais il n’est pas dit si ça active ou désactive set time limit !)

    comme essai je mets à jour les extensions, pour l’instant ça à l’air de fonctionner, mais c’est à confirmer !

     

    #2386776
    ferman
    Participant
    Maître WordPress
    6924 contributions

    j’ai cliqué sous l’onglet php set time limit qui était en gris je l’ai mis en bleu (mais il n’est pas dit si ça active ou désactive set time limit !)

    Pour ça il faut demander à l’hébergeur.

    Autrement les mises à jour sont faites et vous n’avez plus de message d’erreur ou d’avertissement?

    • Cette réponse a été modifiée le il y a 2 années et 6 mois par ferman.
    #2386779
    artisanat
    Participant
    Chevalier WordPress
    111 contributions

    j’en avais beaucoup de retards parce que j’ai tout réinstallé ce matin, à cause d’un plugin de cache qui m’em… wp optimize en payant

    c’est la dernière chose que je vais faire maintenant, parce en autre il me demande de revenir à 7. lui aussi, mais j’avais déjà des problème avec lui avec… p’t que maintenant ça va aller ???

     

    en tout cas merci pour tout.

    #2386781
    artisanat
    Participant
    Chevalier WordPress
    111 contributions

    maintenant j’ai ça

    cURL error 60: SSL certificate problem: certificate has expired

    #2386784
    Li-An
    Participant
    Maître WordPress
    28357 contributions

    Bonjour, pour cette erreur, il faut voir avec votre hébergeur. C’est peut-être lié au cache, attendez un peu et vérifiez que vous avez bien tout nettoyé (notamment si votre hébergeur gère un cache lui-même).

    #2386785
    ferman
    Participant
    Maître WordPress
    6924 contributions

    Vous avez  ça quand vous faites la mise à jour d’une extension? Si oui laquelle?

    #2386788
    artisanat
    Participant
    Chevalier WordPress
    111 contributions

    je suis en conversation avec eux actuellement

    wp-optimize payant

    ils viennent de changer de version, et maintenant j’ai une erreur dans compression Gzip qui est de leur fait, je viens de les informer par mail,

    <b>Fatal error</b>: Uncaught Error: Cannot use object of type WP_Error as array in /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-content/plugins/wp-optimize-premium/wp-optimize.php:1064 Stack trace: #0 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-includes/class-wp-hook.php(303): WP_Optimize->output_cache_gzip_tab( ») #1 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters( », Array) #2 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-includes/plugin.php(470): WP_Hook->do_action(Array) #3 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-content/plugins/wp-optimize-premium/wp-optimize.php(871): do_action(‘wp_optimize_adm…’) #4 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-content/plugins/wp-optimize-premium/wp-optimize.php(820): WP_Optimize->display_admin_page(‘wpo_cache’) #5 /home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-includes/class-wp-hook.php(303): WP_Optimize->display_admin( ») #6 /home/clients/3a99b5833020ba5067a61ff4c6fbd9 in <b>/home/clients/3a99b5833020ba5067a61ff4c6fbd9e1/web/wp-content/plugins/wp-optimize-premium/wp-optimize.php</b> on line <b>1064</b>

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.