[Résolu] faire une FAQ sans plugin (Créer un compte)

  • WordPress :6.1
  • Statut : résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2445822
    jb44
    Participant
    Initié WordPress
    46 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé :
    • Extensions en place :
    • Nom de l’hébergeur :
    • Adresse du site :

    Problème(s) rencontré(s) :

    bonjour je souhaite faire plusieurs page FAQ de différent sujet sans plugin
    j’ai trouver ça https://hallanalysis.com/json-ld-generator/

    mais je n’arrive pas a voir se que ça donne même en collent le code dans la page en ouvrant l’éditeur de code je vois seulement le code rien d’autre

    j’ai essayer le bloc FAQ de Yoast mais apparemment il faut faire une seule question réponse par page hors moi ça serai beaucoup de question réponse et si possible référencé sur google

    est ce que quelqu’un aurai un code a proposer pour faire une FAQ avec la question visible et la réponse caché ou l’on doit cliquez sur un + ou un code similaire ?

     

    d’avance merci

    #2445839
    Li-An
    Participant
    Maître WordPress
    28491 contributions

    Bonjour, franchement ? Prenez une extension. Si vous utilisez Gutenberg, il y a des extensions de blocs qui proposent ce genre de bloc en accordéon.

    #2448164
    jb44
    Participant
    Initié WordPress
    46 contributions

    bonjour j’ai trouver un code que j’ai mis dans le bloc html

    voici le code en question

    <div class="faq-container">
    <div itemscope="" itemtype="https://schema.org/FAQPage" id="faq-page-1">
    <h4 itemprop="mainEntity" itemscope="" itemtype="https://schema.org/Question">
    <span itemprop="name">QUESTION 1</span>
    </h4>
    <div itemscope="" itemprop="acceptedAnswer" itemtype="https://schema.org/Answer">
    <details>
    <summary></summary>
    <p itemprop="text">Réponse à la question 1</p>
    </details>
    <br>
    </div>

    <h4 itemprop="mainEntity" itemscope="" itemtype="https://schema.org/Question">
    <span itemprop="name">QUESTION 2</span>
    </h4>
    <div itemscope="" itemprop="acceptedAnswer" itemtype="https://schema.org/Answer">
    <details>
    <summary></summary>
    <p itemprop="text">Réponse à la question 2</p>
    </details>
    <br>
    </div>
    </div>
    </div>

    le résulta est assez simple mais sympas

    juste un problème pur google search console ne veux pas référencé ma page FAQ

    pour lui voici le problème
    Champ « acceptedAnswer » manquant (dans « mainEntity »)

    quelqu’un aurai une petite idée du problème ?

    merci d’avance pour vos réponse

    • Cette réponse a été modifiée le il y a 1 année et 3 mois par jb44.
    #2448173
    C_Lucien
    Modérateur
    Maître WordPress
    5115 contributions

    Bonjour,

    juste un problème pur google search console

    est-on encore dans du WordPress ? Analyser du code hors de tout contexte, sans vision globale et cohérente du système hôte, il est possible que ce forum ne soit pas le meilleur endroit.

    Pour rester dans le giron de WordPress, la suggestion de @Li-An me semble la plus pertinente.

     

    #2448175
    Li-An
    Participant
    Maître WordPress
    28491 contributions

    Le mieux c’est de demander à la personne qui a développé le code en question si elle a une solution.

    #2448183
    jb44
    Participant
    Initié WordPress
    46 contributions

    il fallait mettre
    <div itemscope itemprop= »mainEntity » itemtype= »https://schema.org/Question »>
    <h4>

    et non

    <h4 itemprop= »mainEntity » itemscope= » » itemtype= »https://schema.org/Question »>
    <span itemprop= »name »>QUESTION 1</span>
    </h4>

    • Cette réponse a été modifiée le il y a 1 année et 3 mois par jb44.
6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.