[Résolu] Faire en sorte que les liens ne soient pas souligné (Créer un compte)

  • WordPress :6.4
  • Statut : résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #2471576
    design122
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    Actuellement en cours de construction d’un site web WordPress avec Elementor, je cherche à savoir comment faire pour que les liens ne soient pas soulignés.

    J’ai mis un lien sur un titre et celui-ci est souligné depuis, j’ai également mis « aucun » pour les décorations de texte mais le soulignement ne s’enlève pas.

    Merci d’avance pour vos réponses

     

    • Ce sujet a été modifié le il y a 4 semaines par design122.
    #2471736
    momofr@free.fr
    Modérateur
    Maître WordPress
    7010 contributions

    Salut, tu as oublié de nous donner les informations sur ton hébergement, le thème et les extensions utilisées.

    Impossible de te répondre sans ça.

    Installe cette extension pour obtenir toutes les informations à nous donner.

    #2471767
    design122
    Participant
    Initié WordPress
    6 contributions
    • Version de PHP/MySQL : 7.4.33
    • Thème utilisé : Thème personnalisé enfant, avec Hello Elementor en thème parent
    • Extensions en place : Royal Elementor Addons, Essential Addons, ElementsKit Lite, Yoast SEO, CookieYes | GDPR Cookie Consent, Contact Form 7, WP Maintenance
    • Nom de l’hébergeur : Phpnet France Sarl

     

    Pour revenir sur mon problème :

    Une fois sur Elementor, j’ai été dans les réglages du site dans la section « Typographie », une fois dans la section « Liens » j’ai mis « Aucun » pour la décoration et le soulignement de mes liens s’est enlevé. Mais quand je vois ma page sur Elementor le soulignement des liens est toujours présent, il l’est également sur le site en ligne, mais le soulignement n’est plus présent quand je vois ma page dans « Réglage du site ». Je ne sais plus comment faire..

    J’ai également un deuxième souci, les numéros de téléphone que je mets sur le site se mettent en rouge et deviennent des liens, je n’ai rien contre le fait que ce sois des liens, c’est plutôt bien quand les visiteurs ont juste à cliquer sur le numéro pour l’appeler, mais la couleur rouge je n’arrive pas à l’enlever, pourtant dans les réglages du site, dans la section « liens » il n’y a aucune couleur de validé, le carré de couleur est bien barré mais j’ai quand même cette couleur rouge, j’ai essayer de changer cette couleur en noir, mais malheureusement ca me change la couleur de la typographie sur certains boutons (qui eux pourtant n’étais pas rouge avant). J’aimerais donc savoir si il est possible de personnaliser pour chaque liens la couleurs souhaité et de me débarasser de cette couleurs rouge

    Merci d’avances pour votre temp et vos réponses

    #2471775
    momofr@free.fr
    Modérateur
    Maître WordPress
    7010 contributions

    Salut, quand tu fais des réglages CSS il faut vider le cache de ton navigateur.

    Tu peux aussi régénérer les CSS dans les outils d’Elementor.

    #2471781
    design122
    Participant
    Initié WordPress
    6 contributions

    Salut, même après avoir fait ça j’ai toujours les mêmes problèmes..

    #2471798
    momofr@free.fr
    Modérateur
    Maître WordPress
    7010 contributions

    Salut, j’ai installé la même configuration en local, je n’ai pas les liens soulignés, dans n’importe quel widget.

    Tu as des CSS personnalisés quelque part ?

    Si tu as importé des templates il y a peut-être quelque part une règle CSS qui souligne les liens (c’est le problème des templates).

    Il faut ajouter une règle globale qui supprime le soulignement (tu ne pourras pas utiliser les fonctions de style d’Elementor) :

    a {text-decoration: none !important;}

    Règle à copier/coller dans : Apparence -> Personnaliser -> CSS additionnel

    #2471825
    design122
    Participant
    Initié WordPress
    6 contributions

    Merci beaucoup pour votre réponse, ça marche maintenant !

    J’ai utilisé un template pour le header et le footer, ça devait surement être ça.

    Savez-vous comment peut-on voir qu’un template à bouger ou à ajouter du CSS ?

    Et je ne comprends pas pourquoi avec une règle globale je ne pourrais pas utiliser les fonctions de style d’Elementor, pouvez-vous m’en dire plus s’il vous plaît ? 🙂

    Merci pour votre temps et vos réponses

    #2471837
    momofr@free.fr
    Modérateur
    Maître WordPress
    7010 contributions

    Salut, le problèmes des templates c’est que si ils sont prévus pour Elementor PRO ils peuvent embarquer du styles « en ligne » (dans le code général de la page).

    Ces règles CSS dans le code sont les dernières lues par le navigateur, toutes les règles précédentes sont écrasées par ces attributs CSS.

    Par contre les CSS dans Apparence -> Personnaliser sont chargés en dernier.

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.