[Résolu] Faire apparaitre un plus et un moins sur une carte Osm (Créer un compte)

  • WordPress :5.7
  • Statut : résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2383681
    ungars
    Participant
    Chevalier WordPress
    260 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8.0.0 / 8.0.22
    • Thème utilisé : One Press
    • Extensions en place : Multivendeurs Market Place Solutions, Woocommerce,
    • Nom de l’hébergeur : Localhost
    • Adresse du site : localhost

    Problème(s) rencontré(s) :

     

     

    Bonjour, je développe un site actuellement, sous WordPress. Je me sers de Mapbox pour faire apparaitre une carte Osm.

    Tout fonctionne bien, mais je suis embêté pour zoomer et dézoomer.

    Pour zoomer cela passe, pour dézoomer suivant les claviers (comme sur mon pc portable) la touche « – » n’ existe pas. En fait c’ est un tiret, et pas la touche moins.

    On peut tenter quelques manips, qui fonctionnent chez certains mais pas chez moi. Ou alors quelques acrobaties avec le touchpad, mais ce n’ est pas top.

    Il me faudrait les touches « – » et « + » sur la carte, comme sur les cartes Google Map. Mais sur ma carte Osm, elles n’ apparaissent pas.

    Je travaille actuellement en local, mais j’ ai mis pour test une carte ici

    On voit bien que les signes n’ apparaissent pas. Sur Strava, qui utilise aussi Osm, la, les signes apparaissent : strava-osm.PNG*

    Sur la doc de Mapbox, sur certains exemples, les plus et moins apparaissent .

    J’ ai peut etre oublié un truc quelque part, j’ ai regardé la page ou l’ on créé son accès : Account | Mapbox, je ne vois pas quelque chose qui s’ y rapporte.

    J’ ai pris contact avec mapbox, sans réponse à mes deux mails.

    J’ ai contacté aussi la société qui gère le plugin sous mapbox, ils cherchent.

    J’ ai fait une recherche, j’ ai trouvé cette doc, mais je ne vois pas quoi faire de cette ligne de code.

    J’ ai tenté de rajouter un bloc html sur la page ou se situe le shortcode qui affiche la carte, mis le code directement à la suite du shortcode, cela n’ a rien fait, ce n’ est surement pas comme ça qu’ il faut que je fasse.

    Je vous remercie pour votre aide, si vous avez des idées…

    • Ce sujet a été modifié le il y a 3 semaines et 3 jours par ungars.
    #2383687
    Lumiere de Lune
    Participant
    Maître WordPress
    19538 contributions

    Shortcode -> plugin 🙂

    Quel plugin utilises tu ?

    Et dans la doc du plugin, quels sont les paramètres du shortcode ? Normalement ça doit être là

    #2383693
    ungars
    Participant
    Chevalier WordPress
    260 contributions

    Merci pour ta réponse.

    Le plugin : Multivendor Marketplace Solution for WooCommerce

    Il faut mettre le shortcode dans un block html.

    J’ avais donné un accès admin à ceux qui gèrent le plugin, je ne pense pas que cela soit un problème de shortcode.

    La carte fonctionne très bien, j’ ai mis deux boutiques fictives, on  les retrouve sans problème sur la carte… C’ est juste cette histoire de zoom et de dézoom… Quand on regarde les cartes qu’ il y a en exemple sur le site de Mapbox, les signes apparaissent parfois. Peut etre que c’ est une option, que je ne trouve pas.

    Bonne soirée.

    #2383694
    mathieu42
    Participant
    Maître WordPress
    850 contributions

    dans l’extension wcmp, à quel endroit vous indiquez la localisation d’une boutique ?

    et comment avez vous mis en place la page qui affiche le plan ?

    #2383701
    ungars
    Participant
    Chevalier WordPress
    260 contributions

    Il faut que le vendeur saisisse son adresse dans son panneau, et comme dit dans mon précédent message, c’ est un shortcode sur la page qui affiche le plan.

    #2383702
    mathieu42
    Participant
    Maître WordPress
    850 contributions

    je n’ai pas trouvé ce shortcode c’est pour cela que je vous demande, pour pouvoir tester.

    #2383703
    ungars
    Participant
    Chevalier WordPress
    260 contributions

    C’ est ce shortcode là :

    [wcmp_vendorslist]

    Merci du coup de main.

    • Cette réponse a été modifiée le il y a 3 semaines et 2 jours par ungars.
    #2383707
    mathieu42
    Participant
    Maître WordPress
    850 contributions

    j’ai trouvé le fichier qui gère le plan :

    .https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/trunk/assets/frontend/js/vendor-list.js

    le souci c’est que la variable “map” n’est pas accessible en dehors de ce script. donc une solution serait de redéfinir tout ce fichier mais je trouve que ça fait un peu beaucoup et c’est gênant s’il y a beaucoup de modifications dans les prochaines versions. est ce que quelqu’un a une autre idée ?

    #2383715
    ungars
    Participant
    Chevalier WordPress
    260 contributions

    Merci pour la peine que tu te donnes pour m’aider.

    Je pense qu’ il doit y avoir une solution plus simple, certaines fois on voit ces cartes sur le site de Mapbox avec des plus et des moin.

    Pourquoi des fois ils apparaissent, pourquoi des fois non…

    Bon après midi.

    #2384083
    mathieu42
    Participant
    Maître WordPress
    850 contributions

    puisque personne d’autre n’a d’idée, j’ai fait une extension en pièce jointe qui redéfinit le fichier complet.

    cela veut dire que lors des mises à jour de l’extension Multivendor Marketplace Solution for WooCommerce, vous devrez vérifier que le plan s’affiche toujours bien et si ce n’est pas le cas, vous désactivez mon extension.

     

    petite parenthèse au sujet de “J’ ai contacté aussi la société qui gère le plugin sous mapbox, ils cherchent.” : vous avez trouvé la ligne de code à ajouter pour faire cela donc la seule chose qu’ils cherchent, c’est du temps pour rajouter cette possibilité dans leur extension.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2384089
    ungars
    Participant
    Chevalier WordPress
    260 contributions

    Bonjour,

    Tout d’ abord je vous remercie du temps que vous m’ avez consacré, vous m’ avez rendu un grand service, je vous exprime toute ma gratitude.

    Votre extension fonctionne parfaitement, en local les plus ou moins apparaissent bien : https://www.cjoint.com/c/KHCpm1tcIud

    Oui j’ ai bien compris qu’ il leur fallait du temps. Je vais leur envoyer votre plugin, peut etre que cela va les aider.

    Pour mapbox,  si on va sur leur documentation, parfois les signes apparaissent, parfois non dans leurs exemples. Il y a peut etre quelque chose que j’ ai oublié de faire, mais je ne vois pas quoi.

    Je laisse le post ouvert, quand j’ aurais du neuf j’ en ferai part. Encore merci.

     

     

     

     

    #2384379
    ungars
    Participant
    Chevalier WordPress
    260 contributions

    Bonjour, bonne nouvelle le plugin a été mis à jour, et propose maintenant les signes + et – . La deuxième bonne nouvelle, c’est que j’ ai eu la réponse de mapbox, ils m’ ont demandé quelques renseignements. Je voudrais savoir pourquoi les signes apparaissent parfois sur leurs exemples dans la doc, et si c’ est normal qu’ ils n’ avaient pas apparu chez moi avant la mise à jour du plugin.

    Quand j’ aurais leurs réponses, je rendrais compte ici, histoire que le prochain coup que cela arrive, on puisse savoir quoi faire.

     

    Bonne soirée.

    #2385064
    ungars
    Participant
    Chevalier WordPress
    260 contributions

    Bonsoir,

    J’ ai eu la réponse de Mapbox.

    Selon eux, c’ était un conflit avec le plugin de market place que j’avais. Les + et – apparaissent tout le temps, sur la photo de leur doc ou cela n’ apparaissait pas, c’ est qu’ en fait le printscreen n’ était pas assez grand.

    Je remercie encore une fois tout le monde pour m’ avoir aidé, en particulier mathieu avec son extension.

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.