[Résolu] Extensions : je n’ai plus “Ajouter” ??!! (Créer un compte)

  • WordPress :5.2
  • Statut : résolu
10 sujets de 16 à 25 (sur un total de 25)
  • Auteur
    Messages
  • #2289064
    toto92
    Participant
    Initié WordPress
    15 contributions

    Ca commence par “a:6:{s:13:”administrator”; etc…. il me suffit de remplacer a:6 par a:5 ????

    #2289065
    toto92
    Participant
    Initié WordPress
    15 contributions

    Bonsoir Fermen !

    Eh bien ca commence par :

    a:6:{s:13:”administrator”;a:2:{s:4:”name”;s:13:”Administrator”;s:12:”capabilities”;a:88:{s:13:”switch_themes”;b:1;s:11:”edit_themes”;b:1;s:16:”activate_plugins”;b:1;s:12:”edit_plugins”;b:1;s:10:”edit_users”;b:1;s:10:”edit_files”;b:1;s:14:”manage_options”;b:1;s:17:”…..

    alors je dois desactiver toules les extensions puis je copie/colle dans mon option_value à partir du lien

    et ca reglera mon probleme ???

    Bonne soirée

     

     

    #2289069
    ferman
    Participant
    Maître WordPress
    2700 contributions

    Bonjour,

    Les valeurs que vous donnez (a:6:{s:13:”administrator”…etc) semblent  normales. Ne changez rien à ce niveau. Le problème ne vient pas de là. Dommage ça aurait été facile à régler.

    Par contre, comme vous ne l’avez pas encore fait, vous pouvez désactiver tous vos plugins. Si le problème disparaît, réactivez-les les uns après les autres en regardant quand le problème réapparaît. Si le problème existe toujours, activez un thème par défaut. Et si rien n’est arrangé ça devient compliqué.

    • Cette réponse a été modifiée le il y a 8 mois par ferman.
    #2289097
    toto92
    Participant
    Initié WordPress
    15 contributions

    Ben  Non …

    j’ai bien desactivé une par une toutes  les extensions  activées

    j’ai changé de theme ( je suis ^passé de Sydney à Twenty Fifteen puis à Twenty Nineteen : Toujours pas de bouton “Ajouter” !

    Bon je cherche …

    Bonne nuit

    #2289098
    toto92
    Participant
    Initié WordPress
    15 contributions

    Il me reste une autre piste : ecraser par FTP

     

    #2289142
    ferman
    Participant
    Maître WordPress
    2700 contributions

    Bonjour,

    Oui, ce problème est embêtant et dans ce cas, la méthodepour réparer  a été de refaire la mise à jour  de wordpress (2 fois!) et la méthode recommandée par le modérateur était carrément de réinstaller wordpress. Regardez aussi cet article et la vidéo qu’il contient où une autre solution est proposée.

    #2289581
    toto92
    Participant
    Initié WordPress
    15 contributions

    Bonsoir !

    les MAJ dans wp-config.php n’ont pas resolu mon probleme …

    Avant de passer à l’écrasement par FTP : Pensez-vous qu’il y a un probleme dans .htaccess  ??

    et dans quel sous-dossier ?

    Ce que j’ai trouvé dans mon site :

    1. \public_html\wp-content\uploads  ( qui est vide)
    2. \public_html\wp-content\plugins\wp-simple-booking-calendar\views
    3. \public_html\wp-content\plugins\wp-simple-booking-calendar\library
    4. \public_html\wp-content\plugins\wp-simple-booking-calendar\languages
    5. \public_html\wp-content\plugins\akismet
    6. \public_html\wp-admin
    7. \public_html\maintl
    8. \public_html

    le 1er , 6°  sont vides

    Les 2° , 3° , 4° contiennent :

    Order deny,allow

    Deny from all

     

    Le 7° contient :

    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine on
    RewriteBase /maintl
    RewriteRule ^.*[-](\d+)/$ index\.php?id=$1&%{QUERY_STRING} [L]
    RewriteRule ^.*i/(.*)/$ index\.php?cat=$1&%{QUERY_STRING} [L]

    RewriteRule ^.*[-](\d+)/$ index\.php?id=$1&%{QUERY_STRING} [L]
    RewriteRule ^.*i/(.*)/$ index\.php?cat=$1&%{QUERY_STRING} [L]

    </IfModule>

    Le 8° contient :

    # Spécification des jeux de caractères des documents (ajoutez les extensions que vous utilisez)
    AddCharset utf-8 .css .xml .po .php .js

    # activation php5 (free.fr)
    <ifDefine Free>
    PHP56 1
    </ifDefine>

    # Protection du fichier .htaccess
    <Files .htaccess>
    Order Deny,Allow
    Deny from all
    </Files>

    # Protection du fichier wp-config.php
    <files wp-config.php>
    order Deny,Allow
    deny from all
    </files>

    # Désactivation de l’affichage des répertoires
    Options All -Indexes

    # Inactivation des rewrite rule de WordPress sur FREE.
    <IfDefine !Free>
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    </IfDefine>

    le 5° contient des lignes pour Akismet

    Il faut corriger quelque chose ???

    Merci et bonne nuit

     

     

     

    #2289585
    ferman
    Participant
    Maître WordPress
    2700 contributions

    Bonjour,

    Il faut corriger quelque chose ???

    Merci et bonne nuit

    Totalement incapable de vous répondre. La seule chose que je peux dire est que ça ne ressemble pas du tout à mon .htaccess,  qu’il y a des lignes en double : RewriteRule ^.*[-](\d+)/$ index\.php?id=$1&%{QUERY_STRING} [L], RewriteRule ^.*i/(.*)/$ index\.php?cat=$1&%{QUERY_STRING} [L], et qu’il y a des reférences à “free” dont je ne vois pas ce qu’elles viennent faire ici. A part ça ??? désolé.

    Bonne nuit à vous également.

     

     

    #2289589
    toto92
    Participant
    Initié WordPress
    15 contributions

    Tu m’avais vraiment mis la puce à l’oreille !!

    Je viens de me souvenir que j’avais d’abord installé WP chez  de Free

    et ensuite j’ai fait transferer par O2Switch  d’ou quelques references à Free

    donc j’ai enlevé dans  .htaccess  : ce qui fait me reference à Free

    je suis retourné corriger wp-config.php ( j’ai remplacé  TRUE par FALSE sur les 2 dernieres lignes ..

    Merci ! J’ai , enfin , le bouton “Ajouter”  dans Extensions .. !

    Bonne nuit  ( je crois que je vais mieux dormir !! )

     

     

    #2289591
    ferman
    Participant
    Maître WordPress
    2700 contributions

    Tout est bien qui finit bien et donc la solution wp-config était valable. Bon à savoir. Mais là, combiné au .htaccess pollué c’était vraiment tordu et je crois qu’il fallait de la chancepour trouver la solution.

    A l’occasion passez en résolu, ça pourra servir à d’autres, encore que je ne pense pas que l’on voie souvent de cas où il faut à la fois modifier wp-config ET corriger un .htaccess contenant des restes de l’ancien hébergeur!

10 sujets de 16 à 25 (sur un total de 25)
  • Vous devez être connecté pour répondre à ce sujet.