Extension Newsletter : Tests ok mais envoi réel ne fonctionne pas

  • WordPress :4.7
  • Statut : non résolu
  • Ce sujet a 1 participant et 0 réponse.
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #1637380

    Alexina
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    [b]Ma configuration WP actuelle :[/b] [b]- Version de WordPress :[/b] 4.7.5 [b]- Version de PHP/MySQL :[/b] 5.4.45 / 5.5.55 [b]- Thème utilisé :[/b] Twenty Eleven AAE Maule [b]- Extensions en place :[/b] Akismet Anti-Spam (3.3.2), BackWPup (3.3.7), Contact Form 7 (4.7), DB Cache Reloaded Fix (2.3), FeedBurner Form (1.4.2), Forum_wordpress_fr (4.1), Google Analytics for WordPress by MonsterInsights (6.1.9), Newsletter (4.9.3), NextGEN Gallery (2.2.3), NextGEN Gallery Optimizer (2.1.5), WP Super Cache (1.4.9) [b]- Adresse du site :[/b] http://aaemaule.fr/prod [b]- Nom de l’hébergeur :[/b] Apache

    Problème(s) rencontré(s) :

    J’ai l’extension Newsletter installée depuis 4 ans et tout fonctionnait bien.

    Mais aujourd’hui, impossible d’envoyer la newsletter préparée.

    Il y a bien une notification à propos d’un éventuel problème au niveau du système de délivrance mais je ne comprends pas tout et surtout, je ne vois pas comment faire pour modifier quoi que ce soit.

    Le message que j’ai est le suivant :

    The WordPress internal schedule is not triggered enough often. See this page for more information.

    La page à voir pour plus d’information est la suivante : https://www.thenewsletterplugin.com/documentation/the-wordpress-scheduler

    J’ai tout lu mais l’incompréhension reste : je ne sais pas quoi ni où modifier.

    Et quand je regarde les statuts de l’extension j’ai la liste suivante :
    <h3>General checks</h3>
    <table id= »tnp-status-table » class= »widefat »>
    <thead>
    <tr>
    <th>Parameter</th>
    <th>Status</th>
    <th>Action</th>
    </tr>
    </thead>
    <tbody>
    <tr>
    <td>Mailing</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Last test was successful. If you didn’t receive the test email:

    1. If you set the Newsletter SMTP, do a test from that panel
    2. If you’re using a integration extension do a test from its configuration panel
    3. If previous points do not apply to you, ask for support to your provider reporting the emails from your blog are not delivered

    Read more to solve your issues, if any.
    Email: <input name= »options[test_email] » size= »40″ type= »email » value= » » placeholder= »Valid email address » /> <input class= »button-secondary » type= »submit » value= »Send a test message » /></td>
    </tr>
    <tr>
    <td>Return path</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Some providers require the return path domain aaemaule.fr to be identical to the sender domain aaemaule.fr. See the main settings.</td>
    </tr>
    <tr>
    <td>Blog Charset</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Charset: UTF-8</td>
    </tr>
    <tr>
    <td>PHP version</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Your PHP version is 5.4.45</td>
    </tr>
    <tr>
    <td>Curl version</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Version: 7.21.0
    SSL Version: OpenSSL/0.9.8o</td>
    </tr>
    <tr>
    <td>PHP execution time limit</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Your PHP execution time limit is 300 seconds and can be eventually changed by Newsletter</td>
    </tr>
    <tr>
    <td>Database Charset</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Charset: utf8</td>
    </tr>
    <tr>
    <td>Database wait timeout</td>
    <td><span class= »tnp-ko »>KO</span></td>
    <td>Your database wait timeout is 60 seconds
    That value is low and could produce database connection errors while sending emails. Ask the provider to raise it at least to 300 seconds.</td>
    </tr>
    <tr>
    <td>Database table creation</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td></td>
    </tr>
    <tr>
    <td>Database table change</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td></td>
    </tr>
    <tr>
    <td>WordPress transients</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td></td>
    </tr>
    <tr>
    <td>Newsletter schedule timing</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Next execution is planned in 243 seconds (negative values are ok).</td>
    </tr>
    <tr>
    <td>Newsletter schedule</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>WordPress registered schedules:
    ngg_custom – 900 seconds
    weekly – 604800 seconds
    newsletter – 300 seconds
    newsletter_weekly – 604800 seconds
    hourly – 3600 seconds
    twicedaily – 43200 seconds
    daily – 86400 seconds</td>
    </tr>
    <tr>
    <td>WordPress scheduler auto trigger</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td></td>
    </tr>
    <tr>
    <td>Cron calls</td>
    <td><span class= »tnp-ko »>KO</span></td>
    <td>The blog cron system is NOT triggere enough often.
    Trigger interval: average 1220 s, max 21096 s, min 27 s</td>
    </tr>
    <tr>
    <td>Action call</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Url: http://aaemaule.fr/?na=test</td&gt;
    </tr>
    <tr>
    <td>WordPress scheduler auto trigger call</td>
    <td><span class= »tnp-ok »>OK</span></td>
    <td>Url: http://aaemaule.fr/prod/wp-cron.php</td&gt;
    </tr>
    </tbody>
    </table>
    Je vois donc qu’il y a potentiellement 2 soucis mais je ne sais pas comment les résoudre.

    J’ai fait les tests et cela fonctionne par contre, quand je fais l’envoi réel, rien ne se passe…

    J’ai également mis un smtp et les tests ont réussi.

    Si quelqu’un a une solution à me proposer et une explication dans la langue de Molière, cela me permettra peut-être de résoudre le problème.

    Je précise que je suis allée sur le forum de l’extension et j’ai remarqué que je ne suis pas la seule à observer ce problème…Peut-être n’ai-je qu’à attendre pour que tout rentre dans l’ordre comme c’était le cas il y a 2 mois (et oui, je n’envoie pas des newsletters tous les 4 matins mais il semble que cela soit un problème récent).

    D’avance merci pour l’aide que vous m’apporterez.

    Bonne journée

    Alexina

Affichage de 1 message (sur 1 au total)
  • Vous devez être connecté pour répondre à ce sujet.