Exécuter du code php dans une page déjà publiée (Créer un compte)

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #495529
    manu4330
    Membre
    Initié WordPress
    12 contributions

    Bonjour,

    Problème(s) rencontré(s) :

    Salut à tous.

    Voilà, j’ai fait l’erreur d’enregistrer des pages sur lesquelles il y avait du PHP avant d’installer le plugin Exec-PHP. Maitenant qu’il est installé, mon code PHP ne s’exécute plus sur les pages crées. Par contre, lorsque je crée de nouvelles pages et que j’y insère du PHP, ça marche nickel.

    Y aurait-il une solution à mon problème ou comme le dit l’avertissement de WordPress, mon code est “inutilisable de façon permanente” ?

    Merci à toute âme charitable qui pourrait m’éclairer 😉

    #772820
    WPnoob
    Membre
    Initié WordPress
    44 contributions

    Normalement lorsque tu mets du php sans avoir de plugin pour l’exécuter, il me semble que wordpress met des chevrons genre “<–" devant ton code php. Regarde dans le mode édition de tes pages, va dans la partie html et regarde si il n'a pas rajouté ces symboles là. Si oui supprime les et ton code devrait s’exécuter.

    #772821
    manu4330
    Membre
    Initié WordPress
    12 contributions

    Merci beaucoup pour la rapidité de ta réponse WPnoob. J’ai regardé, aucune trace de “<–". Ce qui me fait un peu peur, c'est cet avertissement :

    Exec-PHP WYSIWYG Conversion Warning. Saving this article will render all contained PHP code permanently unuseful. Even if you are saving this article through the Code editor. You can turn off this warning in your user profile. Ignore this warning in case this article does not contain PHP code. Read the Exec-PHP documentation if you are unsure what to do next.

    J’ai bien l’impression que c’est mort…

    #772822
    WPnoob
    Membre
    Initié WordPress
    44 contributions

    Pour enlever ce message, va dans ton profil et coche la dernière case tout en bas :
    “Disable WYSIWYG Conversion Warning”

    Ensuite dis moi si ça marche.

    #772823
    WPnoob
    Membre
    Initié WordPress
    44 contributions

    Deuxième chose, as-tu bien mis les balises php suivantes : “” ?

    Parce que “” ne fonctionne pas avec exec-php.

    #772824
    manu4330
    Membre
    Initié WordPress
    12 contributions

    Ok, c’est fait. Mais ça ne marche toujours pas. Je me trompe peut être, mais le fait de décocher cette case sert juste à ne pas afficher l’avertissement non ?
    Et j’ai bien mis les balises telles que tu le dis.

    #772825
    WPnoob
    Membre
    Initié WordPress
    44 contributions

    Oui il me semble. Ce que je comprend pas c’est que je viens de tester en enregistrant des pages sans le plugin puis en mettant le plugin par la suite et les “” apparaissent bien. Une fois enlevés le code marche. Si tu vas dans visuel et qu’ensuite tu retournes dans html, elles n’apparaissent toujours pas ?

    #772819
    WPnoob
    Membre
    Initié WordPress
    44 contributions

    Sinon c’est que tu as peut-être une erreur dans code php.

    #772826
    manu4330
    Membre
    Initié WordPress
    12 contributions

    Bon, je crois avoir identifié le problème. En fait, j’ai importé mon site web, vers un serveur local en utilisant Wamp.
    Et maintenant, le code php ne s’affiche plus du tout lorsque je visualise mes pages, c’est bizarre. A mon avis, c’est Wamp qui a un problème. Pour le résoudre, il doit falloir trafiquer un .htacess (j’en ai un sur mon site web hébergé chez 1&1). Bon tant pis, ça ma soulé lol, je vais renoncer pour le moment et je vais faire mes modifications directement sur mon site web.
    Merci beaucoup à toi en tout cas.

    #772827
    Lumiere de Lune
    Participant
    Maître WordPress
    19377 contributions

    Non. Exec php fonctionne très bien avec wamp.

    Il faut
    1. désactiver l’éditeur visuel (et pas seulement le message, autrement dit la case du haut, pas celle du bas)
    2. retourner dans chacun des posts, et réécrire et sauvegarder

    Simplement parce qu’il y a des filtres à l’enregistrement de messages qui transforment les caractères <?php en html entities

    Tu ne dois donc plus avoir le choix d’avoir l’éditeur visuel

10 sujets de 1 à 10 (sur un total de 10)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.