Event Calendar/Scheduler a changé l’index du blog (Créer un compte)

  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #475935
    jipi
    Membre
    Initié WordPress
    7 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : WordPress 2.8.6.
    – Thème utilisé : Fusion
    – Extensions en place :
    – Nom de l’hebergeur : 1&1
    – Adresse du site : http://jipiblog.jipiz.fr/

    Problème(s) rencontré(s) :

    Après l’installation de Event Calendar/Scheduler, ce dernier a créé une page et à l’ouverture le blog s’y connecte directement au lieu de la page d’index.
    J’ai désinstallé Event Calendar/Scheduler, effacé la page, mais le blog s’obstine à vouloir ouvrir cette page qui n’existe plus.
    Cela ne se produit que pour la page d’accueil. En pointant vers un billet ou une autre page tout fonctionne normalement.
    Quelqu’un a t-il rencontré un problème similaire ?

    #699997
    Dric
    Participant
    Maître WordPress
    757 contributions

    Dans l’admin de WordPress, dans Réglages/Lecture, c’est bien « la page d’accueil affiche » « les derniers articles » qui est coché ?

    #699998
    jipi
    Membre
    Initié WordPress
    7 contributions

    Merci de la réponse
    Oui c’est bien l’adresse http://jipiblog.jipiz.fr qui est précisée dans adresse web du blog et adresse web de wordpress de la page réglage général et sur la page options de lecture le bouton « la page d’accueil affiche les derniers billets » est cochée.
    Je pense que c’est un réglage du plug in Event Calendar/Scheduler qui est conservé quelque part, sans doute dans la base de données. J’ai cherché mais je n’ai rien trouvé. Y a t-il un endroit perticulier ou sont stockées les réglages des plugins.
    J’ai fait une réinstallation de Event Calendar/Scheduler et ce dernier avait conservé les réglages de la première installation. Ils doivent être conservés quelque part, mais où ?
    J’ai écrit aux concepteurs du plugin. Peut être aurais-je une réponse. Si je trouve la solution je la mettrai ici.

    #700001
    jipi
    Membre
    Initié WordPress
    7 contributions

    Je continue
    J’ai contacté DHTMLX les développeurs du plugin (fort aimables au demeurant) qui m’ont proposé de lancer le script ci dessous sur la base de données pour effacer la page qui pose problème de la table post

    DELETE FROM `posts` WHERE `post_title`=’scheduler-calendar’;

    Mais le script n’a rien trouvé à supprimer dans la base.
    L’idée était bonne mais le problème n’est pas là… Je les ai recontacté.
    Si quelqu’un a une autre piste.

    #700002
    Dric
    Participant
    Maître WordPress
    757 contributions

    Tu n’as rien dans le .htaccess qui pourrait faire une redirection ? Ou dans le header.php de ton thème ?

    #699999
    jipi
    Membre
    Initié WordPress
    7 contributions

    Dans le .htaccess je n’ai que le passage en php5 et le module rewrite de wordpress. J’ai essayé de supprimer ce dernier, mais cela ne change rien.
    J’ai aussi essayé de rediriger « http://jipiblog.jipiz.fr/scheduler-calendar/ » vers « http://jipiblog.jipiz.fr » en faisant une 301 qui s’est traduit par une belle erreur 500.
    Pour la redirection dans le header du thème je n’ai rien trouvé, (mais je ne connais pas grand chose au php, de plus je trouverai surprenant qu’un plugin écrive dans le header) j’ai tenté le thème par défaut mais cela ne change rien non plus.
    J’ai continué à chercher dans la base de données (je pense que cela ne peut venir que de là), mais je n’ai rien trouvé.

    Là je dois avouer que je ne comprends pas trop ce qui a pu se passer.

    #700000
    Dric
    Participant
    Maître WordPress
    757 contributions

    Je ne connais pas Event Calendar, mais certains plugins proposent une option pour se désinstaller et effacer tous leurs réglages. Il faudrait que tu le réactives et que tu regardes si une telle option existe.

    #700003
    jipi
    Membre
    Initié WordPress
    7 contributions

    J’ai bien sûr essayé cette solution après avoir désinstallé ce plugin.
    Comme par miracle à la réinstallation Event Calendar/Scheduler a retrouvé les réglages que j’avais effectué la première fois et c’est pour cela que je pense que des redirections trainent encore quelque part, mais je n’arrive pas à trouver ou.

    #700004
    jipi
    Membre
    Initié WordPress
    7 contributions

    J’ai trouvé la solution. On peut mettre le sujet en [résolu]

    Le problème venait d’un conflit entre Event Calendar/Scheduler et le plug in Redirections d’Urbangirafe qui avait inscrit tout seul des redirections dans sa base de données. Je les ai supprimées et tout est ok.

    Merci Dric pour ton intervention.

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.