Esperluette (signe ‘&’) dans les grands nombres avec WP 3.8 et 3.9 (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 28)
  • Auteur
    Messages
  • #536670
    imported_Xavier
    Membre
    Initié WordPress
    24 contributions

    Bonjour,

    Dans certaines situations, WordPress peut afficher vos grands nombres (1 234, 357 156, etc.) avec un & plutôt qu’avec une espace insécable ( ) : 1&234, 357&156, etc. C’est lié à la traduction française, mais cela ne devrait pas arriver (ce n’était pas un problème avec la 3.8.0).

    Typiquement, ce problème est visible dans la section “D’un coup d’oeil” du tableau de bord, avec les chiffres des articles et commentaires :
    – “1&003 articles”
    – “9&141 commentaires”
    – “Akismet a déjà protégé votre site de 1&381 commentaires indésirables.”

    Si vous rencontrez ce problème, veuillez nous indiquer votre configuration :

    – Version de WordPress :
    – Version de PHP/MySQL :

    N’hésitez pas à ajouter une capture d’écran dans votre message (vous pouvez glisser l’image sur http://imgur.com pour l’héberger facilement).

    Nous sommes aussi intéressés si vous n’avez PAS ce problème avec la 3.9 (grands nombre qui s’affichent correctement) ! Indiquez-nous votre version de PHP !

    Merci beaucoup !

    #948342
    Lorand
    Membre
    Padawan WordPress
    64 contributions

    Bonjour Xavier,

    Je rencontre ce problème.

    Version WordPress : 3.9
    Version PHP : 5.3.3-7
    Version MySQL : 5.1.73-1

    wp1.jpg

    wp2.jpg

    wp3.jpg

    wp4.jpg

    #948343
    Lorand
    Membre
    Padawan WordPress
    64 contributions

    Je précise que le problème était déjà présent sur WordPress 3.8.3 🙂

    #948344
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Merci Lorand !

    Nous sommes aussi intéressés si vous n’avez PAS ce problème avec la 3.9 (grands nombre qui s’affichent correctement) ! Indiquez-nous votre version de PHP !

    #948345
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    En ce qui me concerne, sur mon site hébergé chez 1&1, ça fonctionne bien. Ma config est la suivante :

    WordPress 3.9
    PHP : 5.4.27
    MySQL : 5.1.73

    #948346
    k-ny
    Membre
    Chevalier WordPress
    128 contributions

    J’ai ce problème ! (Je ne l’avais pas avant le passage en 3.9)

    Wordpress 3.9
    PHP : 5.2.13
    SQL : 5.0.44

    #948347
    Anonyme
    Invité
    Maître WordPress
    34102 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #948348
    luciole135
    Participant
    Maître WordPress
    13743 contributions

    Lorsque Guy fréquentait encore ce forum (où es tu Guy ? Tu nous manques), il avait déjà remarqué le même phénomène pour un autre bug lié lui aussi à la traduction et qui ne se posait que pour des versions de PHP inférieure à 5.4.

    Je ne me rappelle plus de quel problème il s’agissait, peut-être que quelqu’un d’autre se souviendra ?

    #948349
    Lorand
    Membre
    Padawan WordPress
    64 contributions

    Sur un autre hébergement en mutualisé cette fois (mon premier post concernait un serveur dédié).

    Version WordPress : 3.9
    Version PHP : 5.2.13
    Version MySQL : 5.0.44

    wp4.jpg

    wp5.jpg

    wp6.jpg

    #948350
    jeepi
    Membre
    Initié WordPress
    2 contributions

    Bonsoir
    J’ai aussi le même problème
    Version WordPress : 3.9
    Version PHP: 5.2.17
    Version MySQL: 5.1.73
    BdW7EAb.jpg

    #948351
    Anonyme
    Invité
    Maître WordPress
    34102 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #948352
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Si vous voulez tester mais que vous n’avez pas assez d’articles, commentaires, médias ou indésirables, une astuce : faites un recherche d’extension avec le mot-clé “widget”, et regardez le nombre de résultats :
    /wp-admin/plugin-install.php?tab=search&type=tag&s=widget

    Pour ma part (chez alwaysdata), j’ai le problème avec PHP 5.3.10. J’ai fait une demande pour passer l’environnement PHP à PHP 5.4.16, je suis en attente…
    J’ai testé sur d’autres sites dont j’ai la charge :
    * problème avec WP 3.8 et PHP 5.3.10-1ubuntu3.7 — mais pas de problème en passant en v3.9 !
    * pas de problème avec WP 3.9 et PHP PHP/5.2.6-1+lenny16 !

    Bon, statistiques pour le moment :

    N’ont pas le problème :
    * PHP 5.2.6-1+lenny16
    * PHP 5.3.10-1ubuntu3.7
    * PHP 5.4
    * PHP 5.4.27

    Ont le problème :
    * PHP 5.2.7
    * PHP 5.2.13
    * PHP 5.2.13
    * PHP 5.3.3-7
    * PHP 5.3.10
    * PHP 5.3.10-1ubuntu3.7

    Jusqu’à mes tests sur les sites sont j’ai la charge, je pensais clairement que le problème était lié à PHP 5.2/5.3, mais là je ne suis plus sûr…

    #948353
    Anonyme
    Invité
    Maître WordPress
    34102 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #948354
    Lorand
    Membre
    Padawan WordPress
    64 contributions

    Je viens de faire un peu de nettoyage dans ma base de données et j’ai redémarré mon serveur. Résultat, je n’ai plus ce problème d’affichage.

    Je suis toujours sur ces versions, aucun changement effectué :

    Version WordPress : 3.9
    Version PHP : 5.3.3-7
    Version MySQL : 5.1.73-1

    C’est à ne rien y comprendre 🙂

    #948355
    luciole135
    Participant
    Maître WordPress
    13743 contributions

    J’ai retrouvé la discussion où il y avait eu exactement le même problème, ici : Support WordPress Francophone / Problème d’affichage avec “&” pour les chiffres en milliers
    http://www.wordpress-fr.net/support/viewtopic.php?id=84078
    Guy avait alors remarqué que “Il s’agit de la version de PHP , la 5.4 et + gère correctement les espaces insécables dans la fonction number_format (prise en compte multibyte dans le séparateur) mais pas les versions inférieures”

    Mais, ici, j’ai fait l’essai, même en remplaçant l’espace insécable par une espace ordinaire, le problème persiste !

15 sujets de 1 à 15 (sur un total de 28)
  • Vous devez être connecté pour répondre à ce sujet.