[Résolu] Espace variable au début de page

  • WordPress :5.2
  • Statut : résolu
  • Ce sujet contient 9 réponses, 3 participants et a été mis à jour pour la dernière fois par Matevoun, le il y a 2 semaines.
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2286485
    Matevoun
    Participant
    Chevalier WordPress
    131 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.2 / MYSQL 5.5
    • Thème utilisé : OceanWP
    • Extensions en place : Hide Page And Post Title
    • Nom de l’hébergeur : 1and1
    • Adresse du site : http://saint-antonin.net

    Problème(s) rencontré(s) :

    Salutations,

     

    Est-il normal que l’espace au début de chaque page soit si conséquent chez moi ?

    J’ai essayé de le réduire avec l’extension “Hide Page And Post Title”, mais cela est toujours énorme et surtout aléatoire (certaines pages ont un espace supplémentaire, et pourtant tous les réglages sont semblables).

    Merci de votre aide …

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2286491
    momofr@free.fr
    Modérateur
    Maître WordPress
    2807 contributions

    Salut, tu utilises le thème OceanWP qui te permet avec les réglages de page/publication de masquer le titre facilement. Pas besoin d’extension supplémentaire.

    #2286493
    Matevoun
    Participant
    Chevalier WordPress
    131 contributions

    Merci.

    Mais cela est déjà désactivé par ce biais, et cette extension me parait être le seul moyen de récupérer cet espace.

    Ceci étant, je serais ravi de me débarrasser d’une extension.

    Je ne comprends pas …

    • Cette réponse a été modifiée le il y a 2 semaines et 5 jours par Matevoun.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2286496
    ferman
    Participant
    Maître WordPress
    1531 contributions

    Bonjour,

    Sur les pages avec un grand espace, vous avez en fait deux fois le titre (en h1 puis en h3 voir pièces jointes).  Sur le site, le texte est transparent et on ne le voit pas mais l’espace demeure (image 1). Si on change la couleur du texte en rouge on obtient l’image 2. Il faut donc enlever ce titre en h1

    • Cette réponse a été modifiée le il y a 2 semaines et 5 jours par ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2286500
    Matevoun
    Participant
    Chevalier WordPress
    131 contributions

    C’est ça, le titre en H1 y est encore … 🙁

    Et du coup, je ne sais pas comment le virer.

    L’option OceanWP est désactivée ET l’extension Hide Page Title est en place et activée.

    Difficile de faire mieux… 🙁

    #2286501
    ferman
    Participant
    Maître WordPress
    1531 contributions

    S’il n’y a pas d’autre solution, il reste toujours les css:

    h1.page-header-title.clr{display:none;}

    #2286502
    Matevoun
    Participant
    Chevalier WordPress
    131 contributions

    C’est quand même bien brouillon WP … 🙁

    Tu installes un thèmes, l’encart est la alors que tu vires l’option.

    Tu installes une extension complémentaire censée t’aider à la faire partir; il reste quand même sur certaines pages.

    La seule solution (alors que donc il y a des tonnes de garbage dans le code), c’est de dire au serveur “une fois que tu as bien déclarées toutes les variables, tu es gentil, ne les affichent pas …” 🙁

    Je claque ce CSS à un endroit précis du template ?

    #2286503
    momofr@free.fr
    Modérateur
    Maître WordPress
    2807 contributions

    Salut, si tu ne veux pas de titre il faut simplement aller dans Apparence -> Options générales -> Titre de la page -> Style -> Masqué.

    Je ne sais ce que tu as fait mais là c’est un élément qui provient de Gutenberg et qui est masqué au niveau du h1 et non du conteneur, d’où l’espace présent actuellement.

    #2286504
    Matevoun
    Participant
    Chevalier WordPress
    131 contributions

    YES !

    Alors, on a beau le désactiver 2 lignes au dessus dans les options générales, on doit aussi le masquer (?!?).

    Bref, ça à l’air de fonctionner.

    Je vais pouvoir trasher l’extension pour tester.

    Je vous tiens informés.

    Merci 😉

    #2287177
    Matevoun
    Participant
    Chevalier WordPress
    131 contributions

    Oki, nickel.

    Merci. Je passe en résolu. 🙂

    • Cette réponse a été modifiée le il y a 2 semaines par Matevoun.
10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.