Error 404 – Not found – PERMALIEN (Créer un compte)

  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #486172
    agu1970
    Participant
    Initié WordPress
    44 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress 3.0.1:
    – Version de PHP/MySQL :
    – Thème utilisé MassiveNews :
    – Extensions en place :
    – Nom de l’hebergeur 1AND1.fr:
    – Adresse du site http://www.obtenir.fr:

    Problème(s) rencontré(s) :
    Bonjour à tous,
    Après de vaines recherches, je n’arrive pas à solutionner mon problème.
    J’ai voulu modifier la structure de mes permaliens, je vais dans AdminPermalien, je passe en personnalisé et je mets /%postname%/, je valide et tombe sur une erreur 505 . C’est mon .htaccess qui a été modifié, je remets donc l’ancienne version, cele foncionne à nouveau, sauf que mes modifications n’ont pas été prises en compte. Je vais sur la table wp_options et force le champ permalink_structure à /%postname%/.
    Le lien URL de mes articles est correct (http://www.obtenir.fr/postname), par contre quand je clique dessus j’ai une erreur 404 – Not Found.

    Je ne sais plus quoi faire, merci de vos réponses.

    #739330
    agu1970
    Participant
    Initié WordPress
    44 contributions

    up

    #739331
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    1/ Assure-toi que le mod_rewrite est bien actif (avec un phpinfo() par exemple)
    2/ Voici le code de mon .htaccess pour une structure de permaliens “/%postname%” pour t’aider.

    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    #739333
    agu1970
    Participant
    Initié WordPress
    44 contributions

    Merci pour les infos
    Mon .htaccess est sous cette forme :

    # BEGIN WordPress
    AddType x-mapp-php5 .php
    # END WordPress

    Si je le modifie comme tu me l’indiques (et c’est ce que j’ai déja fait), je tombe en erreur 505.

    #739334
    Polygones
    Membre
    Padawan WordPress
    75 contributions

    Si tu as créé ton thème toi-même, ou modifié un thème existant pour y insérer des liens spécifiques à certains endroits, cela peut venir du fait que dans tes fichiers, les différents liens renvoyant à certaines zones, par exemple si tu as mis des instructions type

    <a href="”>

    ne correspondent donc plus à la nouvelle structure des permaliens.

    Afin de supprimer les risque dès le départ, il vaut mieux indiquer dans les fichiers du thème des liens type

    <a href="”>

    Ainsi, même avec un changement de structure des permaliens, WP trouvera toujours la page demandée car elle est indiquée avec son ID numérique et non pas avec un certain type de permaliens.

    Ceci est adapter pour les articles, la fonction d’appel n’étant pas la même.

    Après, peut-être que cette info ne te servira pas si tu n’as pas modifié les fichiers de ton thème, mais je te la donne quand même au ca où, ne sachant pas comment est constitué ton WP à la base 😉

    Bonne journée 🙂

    #739335
    agu1970
    Participant
    Initié WordPress
    44 contributions

    Merci à toi, mais je n’ai effectivement pas modifié les fichiers de mon thème

    #739332
    agu1970
    Participant
    Initié WordPress
    44 contributions

    Personne n’a une idée?

    #739336
    agu1970
    Participant
    Initié WordPress
    44 contributions

    Up

    #739337
    agu1970
    Participant
    Initié WordPress
    44 contributions

    Toujours personne, ca devient urgent.
    Merci

    #739338
    agu1970
    Participant
    Initié WordPress
    44 contributions

    [resolu]
    J’ai du modifier mon .htaccess comme ceci chez 1and1

    # BEGIN WordPress
    AddType x-mapp-php5 .php

    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    #739339
    gelcin
    Participant
    Initié WordPress
    31 contributions

    Comme je viens de galérer un peu et que cette page semble être mieux référencer que celle-ci :

    C’est une page pour installer wordpress en local et faire ne sorte que les permaliens marchent sous wamp (en local).

    Tiens c’est comme facebook : lorsque l’on écrit WordPress dans ce forum, cela apparait comme une faute (mot souligné) !

    ++ nico.

    #739340
    peche74
    Membre
    Initié WordPress
    26 contributions

    Salut,

    J’ai le même problème, sauf que je ne comprends vraiment pas tout ce qui est raconté ici dans le forum… Désolé !!
    Ce qui est sûr, c’est que quand je passe sur “Permaliens > Nom de l’article”, j’ai une erreur 404
    Sinon, tout baigne…
    A noter qu’avec “Nom de l’article”, en haut s’affiche: “Vous devirez mettre à jour votre fichier .htaccess maintenant”

    OK, je veux bien, mais je mets quoi dedans ??? Help….
    Vu que j’ai vu plusieurs propositions ici, je ne sais trop que faire…

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.