erreurs multiples sur free

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #457916
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.3.3
    – Thème utilisé : green-bug
    – Plugins en place : All in One SEO Pack, Easy Gravatars, Flexi Pages Widget, GD Pages Navigator, Google XML Sitemaps, PageNav, Simple Tags
    – Nom de l’hebergeur : free
    – Adresse du site :http://lesamisduvieuxbiran.free.fr/blog/

    Problème(s) rencontré(s) :
    Wordpress me pose beaucoup de problemes sur free. Malgré tout ce que j’ai lu ici, je me suis dite qu’il fallait quand meme l’essayer.
    Comme indiqué souvent, j’ai enlevé le fichier .htaccess, pour stopper les erreurs 500. Mais j’ai dû aussi enlever le fichier à la racine du site parce que sur wordpress, il se refaisait tout seul….
    Résultat, je ne peux plus rien modifier, je me retrouve tout le temps avec une erreur 404 sur free.

    J’ai lu que peut-être le fait de repasser de 10go d’espace à 1go, ça pouvait calmer les choses, mais je ne vois pas où modifier cette donnée.
    Là, le site est totalement bloqué.

    Quelqu’un peut m’aider?
    ps : j’ai un autre site, mais avec nom de domaine chez sivit et là, ça se passe normalement. Donc le probleme vient essentiellement de Free

    Merci d’avance de vos reponses

    #624331
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    Je suppose que tu as lu la faq sur les permaliens chez free ?

    #624332
    dlo
    Participant
    Maître WordPress
    1852 contributions

    Quelle est la structure des permaliens sur ce blog ?
    La structure par défaut qui donne des URL du type http://mondomaine/monblog/?p=53 ou une structure personnalisée du style http://mondomaine/monblog/les-nouvelles-du-front/le-vieux-biran-n-est-pas-mort ?

    Si c’est le cas n°2, il n’est pas étonnant d’avoir autant d’erreurs avec Free car ce type de permalien n’est pas admis chez cet hébergeur.
    Dans ce cas, il faut absolument que les URL personnalisées soient de la forme : http://mondomaine/monblog/index.php/les-nouvelles-du-front/le-vieux-biran-n-est-pas-mort donc de créer un permalien personnalisé de la forme : /index.php/%category%/%postname%/, par exemple…

    Ensuite, tout devrait aller mieux ! 😉

    Cordialement

    #624333
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Merci!!!
    Si j’avais lu ce permalien… Mais je ne voyais pas du tout où placer le index.php
    Là, c’est clair
    Mais heu, je n’arrive meme plus à mon administration de wordpress, je ne tombe que sur des erreurs 500 de free.
    Mis a part via ftp, je n’ai plus rien du tout

    En tous cas, merci de vos reponses rapides
    Mais je crois que mes problemes ne sont pas finis

    Il faut peut-etre que j’y aille par la base de données…..

    #624334
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    J’ai tenté :
    http://lesamisduvieuxbiran.free.fr/blog/index.php

    dans la base de données, j’ai mis :
    siteurl http://lesamisduvieuxbiran.free.fr/blog/index.php
    permalink_structure index.php/%year%/%monthnum%/%day%/%postname%/
    home http://lesamisduvieuxbiran.free.fr/blog/index.php

    Rien n’y fait
    Mais je ne dois pas faire ce qu’il faut.
    Heu, bien évidemment, je n’ai toujours pas placé de fichier .htaccess

    Heu voilà
    Merci beaucoup en tous les cas.

    #624335
    dlo
    Participant
    Maître WordPress
    1852 contributions

    Effectivement, il faut aller “bidouiller” dans la base de données pour se tirer d’affaire…

    Il faut modifier la table wp_options et remettre à blanc l’option ‘permalink_structure’ soit via PHPMyAdmin soit avec SQL et la requête suivante:

    update wp_options set option_value = ” where option_name = ‘permalink_structure’

    Puis, supprimer le .htaccess qui se trouve à la racine du blog. Ce qui devrait redonner accès au blog.
    Ensuite, il faut remettre le permalien en suivant les indications données ci-dessus.

    Cordialement

    #624336
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    J’ai placé ça dans la case….. Heu j’y vais à tatons, parce que en 6 ans, ça fait 1 semaine que je vais sur la base de données, pour wordpress.
    Je suis novice. J’avais des sites statiques sur Frontpage depuis 2ans et je vous épargne ce que j’avais avant….
    Donc, je fais tous les essais possibles :

    J’ai placé ça dans la case

    ” where option_name = ‘permalink_structure’

    Toujours erreur 500.
    Je sais que je ne fais pas ce qu’il faut. Mais mon ignorance dépasse mes compétences.

    Pardon pour le temps pris. D’un autre coté, ça peut en aider d’autres qui comme moi pataugent

    Donc, merci de votre aide

    #624337
    dlo
    Participant
    Maître WordPress
    1852 contributions

    Je crois qu’on ne se comprend pas bien. 😉 mais ce n’est pas très facile par moment… Donc courage !

    Comment faites-vous vos modifications dans la base ? Avec PHPMyAdmin ?

    #624338
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Je crois que c’est depuis sql free

    Voilà ce qui est indiqué dans la barre de navigation
    sql.free.fr/phpMyAdmin/

    J’ai vraiment l’impression de faire n’importe quoi
    Donc, merci de votre patience.

    #624339
    dlo
    Participant
    Maître WordPress
    1852 contributions

    OK, c’est bien PHPMyAdmin…
    Voici la marche à suivre:
    1) Dans PHPMyAdmin, il faut cliquer sur le nom de la table ‘wp_options’ situé dans la partie gauche de l’écran.
    2) Puis afficher le contenu de cette table, en cliquant sur l’onglet ‘Afficher’.
    3) Défiler les enregistrements pour trouver celui qui contient ‘permalink_structure’ dans la colonne ‘option_name’.
    4) Cliquer sur le crayon situé devant cet enregistrement pour entrer en modification.
    5) Effacer le contenu du champ ‘option_value’ pour le remettre à blanc.
    6) Cliquer sur le bouton ‘Exécuter’ pour sauver la modification
    7) Sortir de PHPMyAdmin
    8) Supprimer le fichier .htaccess à la racine du blog (s’il existe)
    9) L’accès au blog devrait être à nouveau possible
    10) Modifier la structure des permaliens via l’administration de WordPress en suivant les instructions données plus haut. ATTENTION: la structure doit s’écrire /index.php/%….%/%…..%/. Ne pas oublier les / au début et à la fin.

    Cordialement

    #624340
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Ben j’ai tout bien suivi et c’est erreur 500
    Je pense désinstaller wp le reinstaller en re-suivant toute votre procédure.
    Je vous tiens au courant

    Merci de tous vos détails
    Je sais que ça va aussi en aider d’autres.
    Que c’est compliqué sur free……….

    Merci de votre patience

    #624341
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    J’ai tout refais…
    Pour écrire une page, je suis obligée de l’écrire, de la publier et seulement après, de la modifier….. Sinon, c’est erreur free.
    J’ai tout le temps peur d’avoir des bugs.
    En tous les cas, suivez scrupuleusement ce qui est indiqué sur les messages ci-dessus, il n’y a pas d’autres possibilités.

    Free est problématique parce que gratuit, enfin j’imagine

    Le blog que j’essaie de faire sur le village

    J’en arrive à penser que tout est fait pour les noms de domaine et pas vraiment pour les gratuits
    Bien évidemment je reviendrai dès que nécessaire

    pffffffffffffffffffffff
    Merci de la patience

    #624342
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Juste pour dire que les tags aboutissent à des erreurs 404………..!!!!!!
    Epuisant free

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.