[Résolu] Erreur sur le site : “Warning: preg_match(): Compilation failed:….” (Créer un compte)

  • WordPress :5.3
  • Statut : résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2336660
    lavince
    Participant
    Initié WordPress
    11 contributions

    Bonjour à tous,

    J’utilise la version 5.4 et pas 5.3, mais elle n’est pas encore dans le menu.

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Divi 4.4.2
    • Extensions en place : bookly 17.8, Custom sidebars 3.2.3, formidable Forms 4.04.01, MC4WP 4.7.5, imagify 1.9.9, really simple ssl 3.3
      worpress https 3.4.0, wordpress importer 0.7, Wp emember 10.1.8, WP super Cache 1.7.1
    • Nom de l’hébergeur : infomaniak
    • Adresse du site : http://www.etre-soi.ch

    Problème(s) rencontré(s) :

    Depuis la mise à jour de Divi il y a trois ou 4 jours, j’ai un problème à l’affichage du site (sauf la page d’accueil). J’ai, sur toutes les pages, un message :

    <b>Warning</b>: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 1 in <b>/home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web/wp-includes/class-wp.php</b> on line <b>223</b>

    <b>Warning</b>: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 1 in <b>/home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web/wp-includes/class-wp.php</b> on line <b>224</b>

    Devant ce problème, j’ai d’abord depuis mon hébergeur recharger une sauvegarde de la veille de la mise à jour et tout est rentré dans l’ordre, exepté le fait que je ne pouvais plus mettre à jour Divi, ce qui n’est pas une solution à long terme.

    Hier, il y avait la mise à jour wordpress 5.4. J’ai donc effectué cette mise à jour et même problème. Puis j’ai également fait la mise à jour de Divi sans que cela ne change rien, toujours le problème.

    Je ne sais pas quoi faire, revenir à une sauvegarde et ne pas pouvoir mettre à jour ne me semble pas indiqué et si je mets à jour, il  y a ce problème.

    Je vous remercie pour votre aide et belle journée à tous.

    Vincent

     

     

    #2336895
    Kler
    Participant
    Initié WordPress
    29 contributions

    Bonjour,

    Cela provient probablement d’un conflit avec un plugin ou votre thème. Avez-vous essayé de désactiver les plugins ou de changer de thème pour voir si le problème persiste ? Vous pouvez installer Health Check. Dans l’onglet de dépannage, le plugin permet de désactiver tous les plug-ins et de changer le thème par défaut, sans affecter l’affichage pour les visiteurs du site.

    #2337766
    lavince
    Participant
    Initié WordPress
    11 contributions

    Bonjour et merci pour la réponse.

    J’ai installé health chek et mis le mode dépannage. Si je comprend bien tous les plugin sont désactivés et le thème de base est utilisé.

    Le site ne ressemble à plus rien (heureusement pour le public il garde l’affichage standard) et toujours le problème…

    Que puis-je faire d’autre, car si je comprend bien cela veut dire que ça ne vient pas des plugin…

    En résumé :

    Le problème est apparu après une mise à jour divi quand j’étais encore en version wordpress 5.3. J’ai remis une sauvegarde de la veille depuis mon hébergeur, tout est rentré dans l’ordre, mais je n’avais plus la dernière version divi. La mise à jour wordpress 5.4 est arrivée, ja’i fait la mise à jour et le problème est réapparu, j’ai remis une sauvegarde antérieure.

    J’ai attendu plusieurs jours, car il semblait y avoir quelques problèmes avec WP 5.4. Je refais une mise à jour aujourd’hui et le problème revient.

    J’ai vu sur un autre post le même problème résolu par une sauvegarde également. Une solution proposée était rechargez les fichiers du dossier wp-includes. Ce qui dans mon cas a été fait par la mise à jour de WP 5.4.

    J’ai installé health chek et mis le mode dépannage selon le conseil reçu ci-dessus. Si je comprend bien tous les plugins sont désactivés et le thème de base est utilisé et le problème persiste.

    Je ne peux pas ne pas faire les mises à jour des différents modules pour raison de sécurité.

    Merci pour votre aide, car je ne sais vraiment pas quoi faire…

    • Cette réponse a été modifiée le il y a 11 mois et 2 semaines par lavince.
    • Cette réponse a été modifiée le il y a 11 mois et 2 semaines par lavince.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2337774
    lavince
    Participant
    Initié WordPress
    11 contributions

    Voici un copié-collé du résultat health chek avec tous les plugin désactivé et le problème toujours présent.

    Merci pour votre aide, je n’y comprends rien.

    Et belle journée à vous.

    ### wp-core ###

    version: 5.4
    site_language: fr_FR
    user_language: fr_FR
    timezone: Europe/Zurich
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 2
    dotorg_communication: true

    ### wp-paths-sizes ###

    wordpress_path: /home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web
    wordpress_size: 68,53 MB (71862610 bytes)
    uploads_path: /home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web/wp-content/uploads
    uploads_size: 139,50 MB (146274137 bytes)
    themes_path: /home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web/wp-content/themes
    themes_size: 35,81 MB (37549649 bytes)
    plugins_path: /home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web/wp-content/plugins
    plugins_size: 84,97 MB (89094391 bytes)
    database_size: 27,96 MB (29322635 bytes)
    total_size: 356,77 MB (374103422 bytes)

    ### wp-dropins (1) ###

    advanced-cache.php: true

    ### wp-active-theme ###

    name: Divi (Divi)
    version: 4.4.2
    author: Elegant Themes
    author_website: http://www.elegantthemes.com
    parent_theme: none
    theme_features: custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, editor-style, widgets
    theme_path: /home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web/wp-content/themes/Divi

    ### wp-themes-inactive (1) ###

    Twenty Twenty: version: 1.2, author: L’équipe WordPress

    ### wp-mu-plugins (2) ###

    ET Support Center :: Must-Use Plugins Autoloader: author: Elegant Themes, version: (undefined)
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.1

    ### wp-plugins-inactive (22) ###

    Asgaros Forum: version: 1.15.4, author: Thomas Belser
    Bookly: version: 17.9, author: Bookly
    Bookly Pro (Add-on): version: 2.4, author: Bookly
    Count Per Day: version: 3.6.1, author: EasyPlugin (Jon Highham)
    Custom Sidebars: version: 3.2.3, author: WPMU DEV
    Divi Builder: version: 4.4.2, author: Elegant Themes
    Elegant Themes Updater: version: 1.1, author: Elegant Themes & Mon Site Facile
    eStore Order Management Addon: version: 2.7, author: Tips and Tricks HQ
    Formidable Forms: version: 4.04.02, author: Strategy11
    Gutenberg: version: 7.8.1, author: Gutenberg Team
    Health Check & Troubleshooting: version: 1.4.4, author: The WordPress.org community
    Imagify: version: 1.9.9, author: WP Media
    MC4WP: Mailchimp for WordPress: version: 4.7.5, author: ibericode
    Really Simple SSL: version: 3.3, author: Rogier Lankhorst, Mark Wolters
    SI Captcha Anti-Spam: version: 3.0.3, author: fastsecure
    VOD Infomaniak: version: 1.4.2, author: Infomaniak Staff
    WordPress HTTPS: version: 3.4.0, author: Mike Ems
    WordPress Importer: version: 0.7, author: wordpressdotorg
    WP eMember: version: v10.1.8, author: Tips and Tricks HQ
    WP eStore: version: 8.0.7, author: Tips and Tricks HQ, Ruhul Amin
    WP Super Cache: version: 1.7.1, author: Automattic
    YOP Poll: version: 6.1.4, author: yourownprogrammer

    ### wp-media ###

    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-12-29 http://www.imagemagick.org
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 188 GB
    imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    imagick::RESOURCETYPE_FILE: 6144
    imagick::RESOURCETYPE_MAP: 188 GB
    imagick::RESOURCETYPE_MEMORY: 94 GB
    imagick::RESOURCETYPE_THREAD: 16
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: unknown

    ### wp-server ###

    server_architecture: Linux 4.9.0-0.bpo.12-amd64 x86_64
    httpd_software: Apache
    php_version: 7.3.16 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 0
    upload_max_size: 300M
    php_post_max_size: 300M
    curl_version: 7.52.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true

    ### wp-database ###

    extension: mysqli
    server_version: 5.6.45-log
    client_version: mysqlnd 5.0.12-dev – 20150407 – $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $

    ### wp-constants ###

    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web/wp-content
    WP_PLUGIN_DIR: /home/clients/902b57ff2acbd7b6cf2d5a56eeecfede/web/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined

    ### wp-filesystem ###

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    `

    #2337775
    lavince
    Participant
    Initié WordPress
    11 contributions

    J’ai essayé de mettre à jour la version php, j’ai mis 7.4, pas de changement.

    #2337792
    ferman
    Participant
    Maître WordPress
    3787 contributions

    Bonjour,

    Le problème semble récurrent (vous aviez posé à peu près la même question en juillet dernier)

    Avez-vous essayé de réinitialiser les permaliens? Votre erreur est à la ligne 223 de class-wp.php. Cette partie du fichier a à voir avec les permaliens. Presque le même cas ICI. Si vous essayez, regardez bien la solution donnée. Il faut que tous les plugins soient désactivés (confirmé ICI).

    Quand on essaie d’aller sur votre site, on tombe sur un avertissement. Votre certificat ssl est mal configuré. Actuellement il s’applique à <span class=”info”>*.preview.infomaniak.website</span>. Je ne sais pas si c’est normal et si ça peut être en rapport avec votre problème mais en tout cas vous avez un problème de certificat qu’il faut résoudre. Vérifiez avec votre hébergeur.

    Une autre “solution”, sans connaitre la cause du problème et si votre site fonctionne correctement est de supprimer les avertissements.

    • Cette réponse a été modifiée le il y a 11 mois et 2 semaines par ferman.
    • Cette réponse a été modifiée le il y a 11 mois et 2 semaines par ferman.
    #2337797
    lavince
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Je vous remercie pour votre réponse.

    Je viens d’essayer de réinitialiser les permaliens, pas de changement.

    Concernant le certificat, je n’ai pas de problème chez moi, j’ai testé sur https://www.httpcs.com/fr/tester-certificat-ssl et tout semble ok.  Mais je vais demandé à mon hébergeur, car vous êtes le 2ème qui me signale cela, merci encore 🙂

    Je vais essayer de régler le problème plutôt que de supprimer les avertissements.

    Oui, cela m’était arrivé déjà et résolu avec une restauration, mais pas cette fois et j’aimerais résoudre ce problème définitivement.

     

     

    #2337824
    lavince
    Participant
    Initié WordPress
    11 contributions

    Le problème <b>Warning</b>: preg_match(): Compilation failed..

    semble résolu.

    J’avais dans un premier temps désactiver les plugins avec health chek et fait la  manip des permaliens. Je l’ai refait en désactivant helth check et tous les plugins manuellement et il sembe que ça refonctionne normalement.

    Merci bien pour l’aide.

    Reste le certificat, à moins que cela aie également résolu le problème. Je n’arrive pas à voir si mon certificat et ok, j’ai testé sur https://www.httpcs.com/fr/tester-certificat-ssl et tout semble ok, même quand ferman mentionnait un soucis. J’aimerais être sûr que c’est bien ok.

    Bonne journée à tous.

    #2337828
    ferman
    Participant
    Maître WordPress
    3787 contributions

    Le problème <b>Warning</b>: preg_match(): Compilation failed..

    semble résolu.

    Tant mieux. L’origine de ce genre d’erreur peut-être difficile à déterminer (health check est lui même un plugin donc à désactiver.

    Reste le certificat, à moins que cela aie également résolu le problème.

    Non. En pièce-jointe ce que les visiteurs (en tout cas certains) voient. Cela décourage le visiteur. C’est à voir avec Infomaniak en leur communiquant le message en bas de la pj. Il doit falloir transférer le certificat Comodo et ça seul l’hébergeur peut le faire.

    Les certificats Comodo ne s’appliquent qu’à un nom de domaine. Les certificats Let’s Encrypt, gratuits, s’appliquen à tout un hébergement.

    Si vous pouviez passer le sujet en “résolu” ce serait parfait. Merci d’avance.

     

     

    • Cette réponse a été modifiée le il y a 11 mois et 2 semaines par ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2337839
    lavince
    Participant
    Initié WordPress
    11 contributions

    Ok parfait,

    Je vais regarder avec eux et transmettre le fichier que vous avez joint.

    Je mets le sujet en résolu.

    Merci beaucoup et bonne journée.

     

    #2338044
    lavince
    Participant
    Initié WordPress
    11 contributions

    Je remets le sujet en non résolu, car j’ai eu une réponse de mon hébergeur que j’ai suivie et je souhaiterais savoir si tout est ok pour la partie SSL.

    J’ai suivi ce qu’il m’ont demandé de faire, mais comme tout est ok depuis chez moi depuis le début, j’aimerais m’assurer que c’est le cas pour tous…

    Je vous remercie pour votre aide.

    • Cette réponse a été modifiée le il y a 11 mois et 2 semaines par lavince.
    #2338053
    ferman
    Participant
    Maître WordPress
    3787 contributions

    Bonjour,

    C’est bon. Il n’y a plus d’avertissement quand on essaie d’accéder au site.  Comment avez vous résolu le problème?

    #2338054
    lavince
    Participant
    Initié WordPress
    11 contributions

    Oh merci 🙂

    Je n’ai pas tout compris les explications de mon hébergeur, mais il y avait un sous-domaine qui n’était pas pris en compte . Il semble que c’était http://www.etre-soi.ch (pour moi le même site).

    Je suis content que tout soit rentré dans l’ordre et je vous remercie beaucoup “ferman” pour les nombreuses réponses et aide que vous m’avez apportées.

    Je repasse en résolu et merci encore pour le temps que vous avez passé à m’aider.

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.