[Résolu] Erreur importation site wordpress sur un nouvel hébergeur

  • WordPress :4.9.9
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 19)
  • Auteur
    Messages
  • #2223064
    e-ssentiel
    Participant
    Initié WordPress
    27 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : native
    • Extensions en place :
    • Nom de l’hébergeur : 1&1
    • Adresse du site : agencewitty.com

    Problème(s) rencontré(s) : Bonjour, je suis confronté à un problème technique qui demande de connaître le code de wordpress à priori. J’ai exporté un site wordpress depuis un hébergement et je veux l’importer sur un nouvel hébergeur. J’ai intégré tous les fichiers dans le ftp puis ma base donnée que j’avais exportés, je me retrouve désormais bloqué sur la page de login du wordpress sans pouvoir ni accéder au tableau d’administration ni afficher le site. Avant ça j’ai eu ce message d’erreur : <b>Fatal error</b>: require_once(): Failed opening required ‘/homepages/7/d758114895/htdocs/wp-load.php’ (include_path=’.:/usr/lib/php7.2′) in <b>/homepages/7/d758114895/htdocs/agencewitty/admin.php</b> on line <b>31</b>

    J’ai donc changé des infos sur cette ligne 31 dans le fichier admin.php et je me retrouve donc coincé sur cette page login ou avec ce message d’erreur.

    Qui sait faire ? Un grand merci d’avance.

    #2223140
    Li-An
    Modérateur
    Maître WordPress
    20393 contributions

    Bonjour, il ne faut jamais modifier un fichier du core de WP. Quel tuto avez-vous suivi pour le déménagement ? Changement de nom de domaine ? Même version de php ? Les extensions étaient désactivées quand vous avez récupéré la base de données et un thème par défaut ?

    #2223187
    e-ssentiel
    Participant
    Initié WordPress
    27 contributions

    Bonsoir,
    <div>Merci pour la réponse. J’ai simplement suivi les indications du service client de l’hébergeur (1&1), je n’ai rien touché de particulier. Pas de changement de nom de domaine. Pour la version php je ne pense pas que ce soit la même, pas sûr non plus. Et les extensions étaient activées lors de la récupération de la base de données. Ce n’est pas un thème par défaut de wordpress, c’est un thème payé : native.<br clear= »all » />

    • Cette réponse a été modifiée le il y a 1 week et 5 days par  Li-An.
    #2223193
    Li-An
    Modérateur
    Maître WordPress
    20393 contributions

    Vous pouvez nous donner le lien avec les indications ? Allez par FTP au niveau du répertoire wp-content/plugins et changez son nom en pluginsxxx pour désactiver toutes les extensions. Même chose pour le thème dans wp-content/themes/nom-du-theme. Et réessayez.
    Pour retrouver les extensions et le thème, il suffira de remettre les noms par défaut des répertoires.

    #2223967
    e-ssentiel
    Participant
    Initié WordPress
    27 contributions

    Bonjour,

    De quel lien avec les indications avez-vous besoin ?

    C’est bien noté pour pluginsxxx dans le FTP, mais pour le thème je ne suis pas sûr. Il s’appelle « native » du coup dans le FTP j’écris : wp-content/themes/nativexxx ?

    Merci.

    #2224019
    Li-An
    Modérateur
    Maître WordPress
    20393 contributions

    Les indications données pur 1&1. C’est ce qu’il faut faire pour le thème en effet.

    #2224045
    e-ssentiel
    Participant
    Initié WordPress
    27 contributions

    Voici les indications de 1&1 :

    • accéder au ftp et créer un dossier (agencewitty)
    • glisser tous les fichiers téléchargés de l’ancien FTP dans ce nouveau dossier
    • se rendre à l’espace client 1&1 et créer une base de données (agencewitty)
    • une fois créée, importer la base de données du site qui a été exportée au préalable (.zip)
    • depuis l’espace client, dans la partie « espace de stockage web », cliquer sur le dossier « agencewitty » et ouvrir le fichier wp-config
    • modifier les informations de Mysql : nom de la base de données, username, password
    #2224253
    Li-An
    Modérateur
    Maître WordPress
    20393 contributions

    Qui héberge le domaine ?

    #2224256
    e-ssentiel
    Participant
    Initié WordPress
    27 contributions

    c’est 1&1

    #2224281
    Li-An
    Modérateur
    Maître WordPress
    20393 contributions

    Passez le php en 7+ si ce n’est pas déjà fait.

    En regardant votre erreur, il y a un gros problème. Le fichier admin.php devrait se trouver dans le répertoire wp-admin ce qui donnerait

    /homepages/7/d758114895/htdocs/agencewitty/wp-admin/admin.php

    et non pas /homepages/7/d758114895/htdocs/agencewitty/admin.php

    Il se peut que vous n’ayiez pas copié correctement les fichiers de WP.

    #2224298
    e-ssentiel
    Participant
    Initié WordPress
    27 contributions

    vous parlez des fichiers dans le ftp ? est-ce qu’il faut mettre le fichier admin dans le répertoire wp-content dans ce cas ? si ça se fait.

    #2224317
    Li-An
    Modérateur
    Maître WordPress
    20393 contributions

    Non, il faut copier tous les fichiers et les répertoires de WP tels qu’ils apparaissent après dézippage en respectant la structure.

    #2224469
    e-ssentiel
    Participant
    Initié WordPress
    27 contributions

    Ok, j’imagine que le mieux et de recommencer l’importation des fichiers dans le FTP en respectant bien l’ordre ?

    #2224495
    Li-An
    Modérateur
    Maître WordPress
    20393 contributions

    Il me semble en effet.

    #2224937
    e-ssentiel
    Participant
    Initié WordPress
    27 contributions

    Bonjour,

    Merci beaucoup pour votre aide jusque là. Il y a du mieux dans l’importation du site mais il reste un soucis : seule la page d’accueil s’affiche et je peux accéder à l’administration, par contre toutes les autres pages du menu affichent une erreur 404. Une idée ?

15 sujets de 1 à 15 (sur un total de 19)
  • Vous devez être connecté pour répondre à ce sujet.