Erreur en supprimant le multisite

  • WordPress :4.9.9
  • Statut : non résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #2226968
    halloy
    Participant
    Initié WordPress
    41 contributions

    Bonjour,

    Je me trouve devant un site sous WP 4.9.8 en multisite. Je souhaite le passer en simple site car il n’y a qu’un site et je trouve que le mlti complique les choses. J’ai suivi des tutos pour modifier wp-config et .htaccess mais cela me donne une erreur 500 ou une internal error.
    Dans la bdd, il n’y a que les tables du site.

     

    Voici le conde du wp-config

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', false );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );
    /* Multisite */
    define( ‘WP_ALLOW_MULTISITE’, true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'nomdusite');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    
    define( 'SUNRISE', 'on' );
    require_once(ABSPATH . 'wp-settings.php');
    define( 'WP_ALLOW_MULTISITE', true );
    define ('FS_METHOD', 'direct');
    define( 'AI1WM_MAX_FILE_SIZE', 536870912 * 8 );
    ?>

    Et le code du .htaccess après une série de Redirect 301

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://nomdusite/$1 [R,L]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    D’après vous, qu’est-ce que je dois absolument laisser ? Dans les modifs tentées, je remplaçais par le code de base de WP.

    Merci d’avance pour vos lumières.

    • Ce sujet a été modifié le il y a 3 weeks et 6 days par  C_Lucien. Raison: Sujet déplacé vers le forum WordPress multisite
    #2227074
    halloy
    Participant
    Initié WordPress
    41 contributions

    En espérant avoir une réponse, je précise que j’ai renommé le .htaccess en htaccess.txt et que le site fonctionne. Donc l’erreur vient du wp-config mais quoi ??

    Voici la dernière version du fichier que j’ai tentée, toujours avec une erreur 500. J’ai remarqué que dans le wp-config d’origine le fichier se termine par ?> et pas dans le configsample. Je l’ai donc aussi supprimé pour voitr mais sans succès

    <?php
    
    
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    //echo realpath(__FILE__);die; 
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'wordpresstest');
    
    /** MySQL database username */
    define('DB_USER', 'wordpresstest');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'PASSWORD');
    
    /** MySQL hostname */
    define('DB_HOST', 'nom_du_serveur');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'eoN7N0j1pUfO0ib7Ymw1QuqV3C&GIpejHEB5Vh#GTH9xn1xgINQZmVY%IZ76v#qC');
    define('SECURE_AUTH_KEY',  'ThZdmlAz3(N*hdn^r7uI9VaB^bZN&bbXLhlLN)3s^2CYSEo1ufU&cgUAiD#2OkvR');
    define('LOGGED_IN_KEY',    '@eJL2^S0eh&WlM1fTcdx2BBq6Omv1jz%p31a1IHW0^8umhhP38Dz7N7CXdKyK6Tj');
    define('NONCE_KEY',        'Xr6%zBoGUk@30X8Zf4hPu2mG0BCn(8kQ2XT&TEyuk*EGn8ie6ixOJIx9@TwVq4FM');
    define('AUTH_SALT',        'vpSDP&xKn^*ciCaKqjQfO*Z%W&mH7iPEuJWnUNRqFD)VJEfgRpIRFy7z)&V8s#dD');
    define('SECURE_AUTH_SALT', 'QjNcD6r2fwGl%1hk^6w)Tg)loPu2d32AvUxVqwj@j7o&c7bNPPGfkWH79(L0Dr6Z');
    define('LOGGED_IN_SALT',   'ULX1OU3bcGmXLV1PbjIADJY15LqdB^Q6HBk!NZKdfZEx4(Ag#e#Dor!x*Pn3An8i');
    define('NONCE_SALT',       'c@ux!vCHhXOaqvjfOG4@JwenSi5rU1O@0Xj6L%t!VAAoHXeONiCAYTtS9I4^ivGV');
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = '1GNdM16_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    
    
    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );
    /* Multisite */
    
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    
    
    require_once(ABSPATH . 'wp-settings.php');

    Dans le wp-config il y avait aussi un appel à sunrise.pho, je l’ai retiré et supprimé le fichier correspodant du dossier wp-content.

    J’ai également retiré les tables correspondant au multisite.

    J’ai vraiment besoin d’un ptit coup de main !!

     

    merci d’avance

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.