Erreur dans le répertoire du blog

  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #446942
    polonius
    Membre
    Initié WordPress
    11 contributions

    Bonjour…
    Je me permet de solliciter votre aide pour un probleme rencontré sur le répertoire de mon blog.

    Je dispose d’une page perso free (merci pour le tutorial d’installation, d’ailleurs 🙂), et j’ai créé un répertoire ‘blog’ pour y placer mon wordpress. A la suite d’une manipulation sur le changement de mode d’archivage dans l’url (c’est à dire choisir si l’on veut que les archives apparaissent dans l’url sous forme ?pageid=x, x étant un nombre, ou bien year/month/day etc.), l’index du blog ne s’affiche plus.

    A la place, apparaît le message d’erreur suivant :

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Apache/ProXad [Feb 19 2006 23:30:25] Server at welcometoneverland.free.fr Port 80

    Pouvez vous me donner quelques pistes pour résoudre le probleme ?
    Merci par avance…

    #569497
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Désactive les permaliens, efface ton fichier .htaccess (dans le cas ou celui ci a été crée 🙂 )
    Free ne gère pas tout les parametre rewrite sauf erreur de ma part 😉

    Faudrait demander aux experts Free 🙂

    #569498
    polonius
    Membre
    Initié WordPress
    11 contributions

    J’ai effacé le fichier htaccess, l’index s’affiche maintenant.

    En revanche, je ne sais pas où effacer mes permalinks.

    Et les rubriques du blog ne s’affichent toujours pas

    #569499
    AmO
    Participant
    Maître WordPress
    4452 contributions

    En fait le permalien permette d’obtenir des urls (adresses) plus jolis, et qui facilite le référencement

    Le htaccess permet de faire ses modifications…
    Malheureusement Free ne propose pas un support entier de cette fonction… ce qui pose des probleme…

    Mais il doit etre posssible d’adapter le htaccess…
    Mais comment? je sais pas, chui pas sur free 😉

    #569500
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Pour que les rubriques s’affichent il faut écrire des articles dedans… sinon très réussi ton thème 🙂

    #569501
    AmO
    Participant
    Maître WordPress
    4452 contributions
    polonius wrote:
    J’ai effacé le fichier htaccess, l’index s’affiche maintenant.

    En revanche, je ne sais pas où effacer mes permalinks.

    Et les rubriques du blog ne s’affichent toujours pas

    désactive également les permaliens dans les options, ton blog bug tjs 😕

    #569502
    polonius
    Membre
    Initié WordPress
    11 contributions

    le problème est que je ne sais pas où les désactiver, j’arrive sur la page des permaliens, et y’a pas d’option pour désactiver. si je change quoi que ce soit, tout foire.

    ______________________________________________

    edit : je crois que j’ai réussi à solutionner le problème.

    et merci, pour le theme, j’ai modifié le theme ‘blix’ déjà existant, dans la CSS etc. je me suis bien amusé. l’image d’en tête est une photo à moi. c’est pas très dur à faire.

    merci de ton aide en tous cas, c’est vraiment très sympa.

    #569503
    AmO
    Participant
    Maître WordPress
    4452 contributions

    en fait faut remettre la première option dans permalien

    Valeur par défaut
    » http://tonsite.net/?p=123

    Je connais pour les thèmes 😉 mais c’est original, ca suit bien la logique graphik du site 😉

    #569504
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Comme tu aurais pu le trouver en faisant une recherche sur le forum… il suffit de mettre devant ta structure de permaliens : /index.php/…. En ayant vérifié avant toute modif que ton htaccess a bien été supprimé.
    Et ça fonctionne très bien !

    #569505
    polonius
    Membre
    Initié WordPress
    11 contributions

    J’ai justement fait une recherche, et je n’ai pas trouvé. Je suis habitué des forums, je sais bien comment ça marche. Si ce topic est génant, ferme le, voire supprime le. Et merci encore de m’avoir aidé.

    #569506
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Une recherche avec “Permaliens” te donne une kyrielle de discussion où ce problème a déjà été traité. Quelques exemples parmi d’autres :

    http://www.wordpress-fr.net/support/viewtopic.php?id=525

    http://www.wordpress-fr.net/support/viewtopic.php?id=22

    http://www.wordpress-fr.net/support/viewtopic.php?id=624

    Donc tu supprimes ton htaccess
    tu remets la structure par défaut
    tu valides
    tu mets ta structure de la forme /index.php/month/day…
    tu valides

    et ca roule !

    😉

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.