[Résolu] erreur critique sur le site (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2388764
    FORMET
    Participant
    Initié WordPress
    45 contributions

    Bonjour,

    • Ma configuration WP actuelle :
      – Version de WordPress : 5.8.2
      – Version de PHP/MySQL : 8.0.11 / 5.6.50
      – Thème utilisé : Twenty Eleven
      – Thème URI : https://wordpress.org/themes/twentyeleven/
      – Extensions en place : Contact Form 7 (5.5.2), Duplicate Page (4.4.5), Forum_wordpress_fr (4.2), Responsive Menu (4.1.4), WP Super Cache (1.7.4), Yoast SEO (17.5)
      – Adresse du site : https://philippeformet.com
      – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    Bonjour,

    Je ne peux plus aller sur mon site, lorsque que je l’appelle j’ai le message suivant:

    il y a une  erreur critique sur le site

    je ne sais pas  comment trouver la cause de ce problème. En plus le site fonctionnait bien juste avant.

    Il se peut que le problème vient d’un plugin multilangue

     

    Merci d’avance

    #2388772
    stephan_b
    Participant
    Padawan WordPress
    52 contributions

    Bonjour,

    Via FTP, rajoutez dans le fichier wp-config.php (au début, mais c’est pas important)

    define( 'WP_DEBUG', true ); 
    define( 'WP_DEBUG_DISPLAY', true );

    Ensuite lorsque vous allez sur votre site, vous devriez avoir plus d’infos sur l’erreur

    #2388775
    FORMET
    Participant
    Initié WordPress
    45 contributions

    merci,

    mais comment je fais pour aller sur FTP.

    Je suis novice dans ce domaine.

    Mon hebergeur est OVH, je dois passer par lui?

    #2388777
    stephan_b
    Participant
    Padawan WordPress
    52 contributions

    Oui, il vous faut créer un compte FTP.

    Je pense que cette documentation vous aidera:

    https://docs.ovh.com/fr/hosting/connexion-espace-stockage-ftp-hebergement-web/

    #2388803
    FORMET
    Participant
    Initié WordPress
    45 contributions

    Merci j’ai réussi à me connecter sur mon site via Filezillla grâce aux indications que vous m’avez donné, mais je ne sais pas comment avoir accès pour modifier le dossier.

    Par contre lorsque je suis sur mon compte OVH  j’ai vu qu’il y avait un explorer FTP (fichier 0.jpg)

    j’y suis allé et j’ai modifié le fichier wp-config.php (fichier 1.jpg). je pense que c’est comme cela que je devais faire.

    Lorsque j’appelle mon site j’ai comme réponse que le site est en version PHP 5.4.45 (fichier 3.jpg)

    Alors que sur le tableau de bord d’OVH dans la colonne CONFIGURATION ma version PHP est 8.0 (fichier 4.jpg)

    Je ne comprends pas. Que dois-je faire

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2388809
    stephan_b
    Participant
    Padawan WordPress
    52 contributions

    Je pense que les 2 lignes “define(…” n’ont rien à faire dans le fichier .ovhconfig et je regarderai pourquoi OVH mets un “!” à côté du PHP version 8.0 dans l’écran 4.

    Pas besoin d’aller en version 8, la version 7.4 suffit pour l’instant

    On progresse!

    #2388854
    FORMET
    Participant
    Initié WordPress
    45 contributions

    Voilà ça refonctionne.

    J’ai changé la version de PHP, mais avant ça fonctionnait bien mais peut-être que c’était incompatible avec un plugin que j’ai installé.

     

    Merci

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.