Erreur critique Elementor (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2398558
    evachan
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : désolée je ne sais pas quoi écrire ?
    • Thème utilisé : Storefront
    • Extensions en place : Elementor/ Elementor Pro / Jetpack / Woocommerce + les extensions de paiement etc qui vont avec
    • Nom de l’hébergeur : 02switch
    • Adresse du site : http://www.thon-mayo.com

    Problème(s) rencontré(s) :

    Bonjour tout le monde !
    J’utilise Elementor Pro avec le thème Storefront, tout se passait bien jusqu’à ce que j’arrive à vouloir concevoir la page single product et qu’en voyant la disposition pas très jolie proposée par Storefront (et l’impossibilité de changer par exemple la disposition des photos produits en dessous de la photo d’article), je décide de voir si je peux modifier ça directement sur Storefront. Je clique donc sur Storefront dans le tableau de bord, là on me demande si je veux en faire ma page d’accueil et bêtement je dis oui. Ca me supprime tout ce que j’avais fait sur la homepage (qui reste dispo sur Elementor mais qui ne s’affiche plus en home). J’installe un nouveau thème (Astra) et quand j’essaie de modifier la page produit avec Elementor j’ai ceci qui s’affiche :

    Une erreur critique est survenue sur ce site. Veuillez consulter la boite de réception de l’e-mail d’administration de votre site pour plus d’informations.

    En apprendre plus sur le débogage de WordPress.

    D’après le mail que j’ai reçu, le pb viendrait d’Elementor mais je ne sais pas vraiment quoi faire ? Impossible d’activer le mode sans échec car je n’ai pas de bouton « enregistrer » sous ce panneau de réglage (bizarre).
    Je m’arrache les cheveux donc tout conseil sera bienvenu !
    Merci 1000 fois 🙂

    #2398560
    momofr@free.fr
    Modérateur
    Maître WordPress
    5241 contributions

    Salut, tout d’abord regarde dans Outils -> Santé du site -> Informations -> Serveur pour nous indiquer quelle version PHP est utilisée sur ton hébergement.

    Sachant que tu es chez o2Switch tu peux activer PHP8 ou 8.1, tu dois aussi passer ton site en HTTPs (indispensable avec WooCommerce).

    Il nous faut toute la liste de extensions pour savoir ce que tu utilises, un conflit est possible.

    A priori Astra fonctionne bien avec Elementor mais tu à fait la dernière mise à jour qui change un peut le comportement d’Elementor, il est d’usage d’attendre un peu lorsque une mise à jour majeure arrive avec ce constructeur de page.

    Essaye aussi de désactiver JetPack pour voir.

    #2398571
    evachan
    Participant
    Initié WordPress
    2 contributions

    Hello !
    Merci à toi d’avoir pris le temps de me répondre 🙂

    Voici les infos que j’ai dans l’onglet Serveur (en PJ)

    Pour mes extensions, j’ai Jetpack (désactivé mais rien n’a changé, le theme builder ne s’ouvre toujours pas), WooCommerce, Paiement WooCommerce, WooCommerce Shipping and taxes, Elementor et Elementor Pro, rien de plus.

    Tu saurais comment je peux faire ce que tu dis avec le PHP et passer en https ? Il me semblait l’avoir fait pour https quand j’ai installé WordPress via O2switch mais j’ai peut-être mal fait.

    Ah oui et mon problème se précise : Elementor fonctionne pour modifier par exemple un header, ou apporter des modifs sur une page (ex : une page produit bien spécifique, si je clique sur Ouvrir avec Elementor ça va fonctionner) mais c’est bien le Theme Builder qui pose problème et qui m’affiche le message d’erreur. Au cas où ça pourrait aiguiller 🙂

    Merci encore !

    • Cette réponse a été modifiée le il y a 8 mois et 1 semaine par evachan.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2398577
    borispollet
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

     

    J’ai également un problème similaire.

    Voir photo Pr critique.

    Tout allait bien jusqu’à l’annonce d’une màj. Elementor.

    VOICI LE MAIL REÇU :

    Bonjour ! Des extensions ont été mises à jour automatiquement vers leurs dernières versions sur votre site à l’adresse https://borispollet.com. Vous n’avez rien de plus à faire.

    Ces extensions sont maintenant à jour :

    Ces extensions sont maintenant à jour :
    – Yoast SEO (de la version 18.3 à 18.4)

    – Yoast SEO (de la version 18.4 à 18.4.1)

     

    Cela a-t-il une incidence ?

     

    Merci pour tt aide mon développeur ne répond pas depuis 10j.

    J’ai bcp travaillé depuis un mois, c’est un passage important ds ma vie d’artiste

    il faut absolument que je retrouve le site, il doit y avoir un truc.

     

    Merci pour tt aide à venir

    Boris Pollet

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2398603
    momofr@free.fr
    Modérateur
    Maître WordPress
    5241 contributions

    Salut @evachan, dans ton cPanel O2Switch tu peux regarder si tu as bien déployé un certificat SSL (Let’s Encrypt) gratuit sur ton domaine.

    Si c’est fait tu peux modifier les URL du site dans les réglages généraux de WordPress pour mettre https:// ou lieu de http://.

    Tu as un outil de gestion WordPress très pratique dans le cPanel : WP Tiger, sert-en pour améliorer la sécurité de ton site et faire une sauvegarde pour chez toi.

    Tant que tu es sur ton cPanel tu vas augmenter la mémoire PHP de ton hébergement en modifiant ta configuration PHP à 512 Mo minimum.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.