[Résolu] ERREUR cookies bloqués, retour inattendu… j’ai tout essayé

  • WordPress :4.9.4
  • Statut : résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2133817
    briisme
    Participant
    Initié WordPress
    3 contributions

    Bonjour à tous,

    Ma configuration WP actuelle

    Problème(s) rencontré(s) :

    Il s’agit d’un problème déjà posté à plusieurs reprises sur ce forum, mais en ce qui me concerne, bizarrement, j’ai un site fonctionnel et un autre inaccessible, je ne trouve pas de solution. Le pire, c’est que je suis sensé m’y connaître !

    J’ai déjà un site vitrine (A) fonctionnel, sous wordpress (mis à jour automatiquement), pour un client.

    Je souhaite créer un nouveau site (B) en utilisant la même base de donnée avec un nouveau préfixe.
    J’ai téléchargé la dernière version (avril 2018) de wordpress : wordpress-4.9.5-fr_FR.zip.
    J’ai modifié wp-config.php via Dreamweaver CC.
    Toutes les infos sont similaire au fichier du site A, sauf les clés uniques d’authentification et le préfixe de bdd pour les tables de WordPress.

    Problème : Je peux me connecter au wordpress du site A mais pas à celui du site B.

    J’ai un message d’erreur sur la page wp-login.php du site B (avant même de renseigner les champs) :
    « ERREUR : les cookies sont bloqués en raison d’un retour inattendu. Pour obtenir de l’aide, veuillez lire cette documentation ou essayez les forums d’entraide. »

    Ce message n’apparaît pas sur la page wp-login.php du site A. Je peux m’y connecter sans souci !

    Pour le site B, j’ai essayé tout ce que j’ai pu trouver sur google : Supprimer WordPress (B) du serveur FTP et recommencer, renommer les dossiers « themes » et « plugins », rajouter un bout de code à la fin des functions.php de chaque thème, modifier l’utf8, éditer depuis TextEdit (je suis sur Mac OS Sierra 10.12.5) … bref, rien n’y fait.

    Je n’ai pas encore créé le contenu du nouveau site, je suis ouvert à toute les solutions, je ne comprends pas d’où ça peut venir…
    Tout semble OK dans PhpMyAdmin, sur OVH le quota de la bdd MYSQL v.5.5 n’est pas dépassé.
    Le site A fonctionne très bien, le site B est inaccessible.
    Je n’ai jamais eu accès à ce site (B) sachant que je suis parti de zéro !

    Si vous avez ne serait-ce qu’une petite idée je suis preneur !

    Merci et dans l’attente d’une solution.
    Cordialement

    • Ce sujet a été modifié le il y a 5 months et 1 week par  briisme.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2134284
    briisme
    Participant
    Initié WordPress
    3 contributions

    Avec le mode deboguage activé, j’obtiens :

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/poinfre/www/wpoinfre/wp-config.php:1) in <b>/home/poinfre/www/wpoinfre/wp-content/themes/twentyseventeen/functions.php</b> on line <b>588</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/poinfre/www/wpoinfre/wp-config.php:1) in <b>/home/poinfre/www/wpoinfre/wp-login.php</b> on line <b>421</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/poinfre/www/wpoinfre/wp-config.php:1) in <b>/home/poinfre/www/wpoinfre/wp-login.php</b> on line <b>434</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/poinfre/www/wpoinfre/wp-config.php:1) in <b>/home/poinfre/www/wpoinfre/wp-includes/pluggable.php</b> on line <b>920</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/poinfre/www/wpoinfre/wp-config.php:1) in <b>/home/poinfre/www/wpoinfre/wp-includes/pluggable.php</b> on line <b>921</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/poinfre/www/wpoinfre/wp-config.php:1) in <b>/home/poinfre/www/wpoinfre/wp-includes/pluggable.php</b> on line <b>922</b>

     

    Je n’ai toujours pas accès à l’un des 2 wordpress installés sur mon site… 🙁

    #2134516
    briisme
    Participant
    Initié WordPress
    3 contributions

    Alors pour ceux que ça intéresse, j’ai trouvé la solution à mon problème. J’ai mis du temps à identifier le problème… il fallait le voir…

    Le problème :

    • 2 wordpress avec 2 préfixes différents sur 1 même base de donnée
    • l’un est accessible, l’autre pas
    • Un message d’erreur « Erreur cookies bloqués… » apparaît sur celui qui est inaccessible
    • Toutes les solutions trouvées sur le net n’y ont rien fait

    La solution (en ce qui me concerne) :

    • Lors de l’installation, wordpress demande de renseigner, entre autres, une adresse de messagerie
    • contrairement à la configuration de l’autre wordpress qui, lui, est accessible, j’avais cette fois-ci renseigné une adresse email en mode « catch all ». Elle est fonctionnelle, mais n’est pas une boîte créé « normalement », c’est juste une redirection (parmi toutes les autres possibilités) vers postmaster@… (pratique pour transmettre rapidement de nouvelles adresses, par exemple une adresse farfelue ou temporaire, sans avoir à passer par le manager d’OVH).
    • En renseignant une adresse email créée normallement et qui ne soit pas un « catch all », le problème de cookies a disparu.

    Incroyable que ce problème ne figure nulle part, ou alors je l’ai raté ?
    En espérant que cela puisse aider les prochains !

     

     

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.