Erreur avec index.php hors du répertoire wordpress (Créer un compte)

  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #448150
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Salut à toutes et à tous,

    Continuant mes essais de toute sortes et ayant WP dans le répertoire wordpress, j’ai voulu mettre le fichier index dans le root et changer les options dans l’admin/options/général.
    A la première des 2 lignes (Adresse de WordPress (URI)), il y a http://www.famille-deneyer.ehia.org/wordpress.
    A la seconde ligne(Adresse du blog (URI)), j’ai remplacé http://www.famille-deneyer.ehia.org/wordpress par http://www.famille-deneyer.ehia.org/index.php.

    Quand j’ouvre le site, je reçois le message :

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /var/alternc/html/j/jeanmarc/index.php on line 4

    Fatal error: require() [function.require]: Failed opening required ‘./wp-blog-header.php’ (include_path=’.:/usr/share/php’) in /var/alternc/html/j/jeanmarc/index.php on line 4

    Résultat, j’ai remis la seconde ligne comme la première, mais ça m’oblige à faire un fichier html de redirection à la racine du site pour atteindre le fichier index situé dans wordpress.

    Pourquoi ce message d’erreur et comment faire ?

    Merci de vos z’avis z’avisés,
    Jean-Marc

    #577003
    dean
    Participant
    Chevalier WordPress
    487 contributions

    à monavis tu devrais mettre un index.php dans ton root avec dedans un code de redirection…du genre

    plutôt que de déplacer le index.php original…

    #577004
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    En effet j’ai remplacé require(‘./wp-blog-header.php’); par require(‘./wordpress/wp-blog-header.php’); et cela fonctionne, mais je ne comprend pas à quoi sert l’option générale si il faut changer le fichier index.php.

    #577005
    z720
    Membre
    Maître WordPress
    579 contributions

    Parce qu’avec les mod_rewrite d’apache, tu n’as pas besoin de déplacer le fichier index.php du répertoire de WordPress…
    En changeant les paramètres tu devrais avoir le htaccess de WordPress dans le bon dossier (racine) qui pointe vers le bon index.php du dossier WordPress

    Dans ce cas tu ne devrais pas préciser index.php dans l’adresse du blog.

    NB : c’est comme cela que cela fonctionne chez moi :
    – tout WP dans un dossier
    – une bonne config qui fait pointer mes requêtes WP sur le script WP

    #577006
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Quand je change les options il ne se passe rien dans ma racine. Pas de htaccess qui apparaisse, alors que si je change mon permalien (avec lequel j’ai aussi des pbl, mais ceci sera le sujet d’un autre post), il se crée (ou se transforme) un htaccess dans le répertoire wordpress.

    Je note que dans l’adresse du blog, je remplace /wordpress par /index.php.

    NB : c’est comme cela que cela fonctionne chez moi :
    – tout WP dans un dossier
    – une bonne config qui fait pointer mes requêtes WP sur le script WP

    C’est quoi la bonne config qui pointe les requêtes sur le script ?

    Actuellement j’ai remis l’index (sans la modif décrite dans mon post ci-dessus) dans wordpress et fait une redirection en html mais je n’aime pas ça.
    Si je fais un redirectpermanent en htacces, ça foire aussi et j’ai une page introuvable.

    Comment je fais pour avoir un WP propre dans le répertoire WP ?
    Je m’y perd un peu, là …

    Merci de vos z’avis z’avisés,
    Jean-Marc

    #577007
    z720
    Membre
    Maître WordPress
    579 contributions

    si je ne m’abuse, il faut dans tes options :
    adresse wp : http://www.example.com/wordpress/
    adresse blog : http://www.example.com/

    Ensuite il faut aller dans les options des permaliens pour regénérer le htaccess en faisant “mise à jour des permaliens”

    Normalement c’est tout.

    Pour avoir un wp propre, il faut que tous les fichiers de wordpress soit dans le répertoire wordpress (par exemple) et à leur place d’origine (sous-dossiers, etc…).

    #577008
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    En effet le htaccess se met bien dans la racine, mais quand je démarre mon site, j’ai une page “index of /” avec tous les fichiers et répertoires cliquables, un peu comme un file manager.

    Comment fait-on pour ne pas avoir ça mais une erreur 404 si il n’y a pas d’index à la racine, par exemple ?

    #577009
    z720
    Membre
    Maître WordPress
    579 contributions

    C’est bizarre mais tu peux le corriger avec ceci :

    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^/?$ /wordpress/index.php [QSA,L]

    en le plaçant avant ce que WordPress a ajouté à ton fichier htaccess

    #577010
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Il me veut toujours rien savoir.
    Lorsque je modifie mon htaccess selon ton code, il ne veut pas plus rediriger l’ouverture du site vers wordpress.
    Je ne comprend vraiment pas pourquoi je ne peux pas me passer d’un fichier html de redirection :(

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.