[Résolu] erreur API REST après migration (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
  • Ce sujet contient 4 réponses, 2 participants et a été mis à jour pour la dernière fois par veg@, le il y a 6 mois.
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2362949
    veg@
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : mariadb-10.3.27  php7.4.13
    • Thème utilisé : pen
    • Extensions en place : Broken Link Checker,Cookie Notice,Elementor,FileBird Lite,Redirection,SecuPress Free,UpdraftPlus,WP Crontrol,WP-f2b,wp-fasted-cache,WP User Avatar,WP-PageNavi,WPS Hide Login,wp-scan
    • Nom de l’hébergeur : local
    • Adresse du site :

    Problème(s) rencontré(s) : Bonjour, aprés déplacement du site d’un serveur à un autre, une erreure avec l’API REST est survenue.

    Erreur : cURL error 28: Connection timed out after 10000 milliseconds (http_request_failed)

    aprés plusieurs recherches, beaucoup ont eu cette erreur et l’ont résolue avec des modification au niveau du php.ini. J’ai donc modifier les config php, mais sans succès.  Par la suite une analyse de kern.log montrait une ip bloqué rejeter et cette ip est celle de l’API wordpress. De là, désactivation du firewall, mais l’erreur etait toujours là.

    Ensuite désactivation et suppression de toutes les extensions et du théme, désactivé le firewall du demarrage auto, et redémarrage du serveur. Retour sur l’admin du site et l’état de santé, erreur API toujours présente.

    Ensuite lancement du parfeu sans restriction, juste la journalisation pour verif dans kern.log, et toujours l’adresse ip de l’API qui est rejetté. De là je décide de repartir de zéro, ré-installation du serveur et wordpress seulement, import de la DB et du site et là surprise 😉 toujours le même probleme, et ce  sans extension et avec theme par default. Une màj vers la version 5.6 n’a rien changer non plus

    Sur site je decouvre query monitor un plugin qui pour ce genre d’erreur.  Ce dernier m’indique un probleme avec le certificats letsencrypt. Je pense comprendre l’erreur mais ne sais pas comment la résoudre. Sachant que le serveur sur lequel ce trouve le site avant migration fonctionne parfaitement avec la même configuration.

    je joint des captures des erreurs

    Débutant sur WP, avais envie d’un site pour des tutos/mémo que je compte publié quand tout seras fonctionnelles et terminés. sa fais 3-4 mois que j’ai commencé en autodidacte avec des tutos.

     

     

    • Ce sujet a été modifié le il y a 6 mois par veg@.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2363003
    veg@
    Participant
    Initié WordPress
    4 contributions

    Alors après avoir changé le nom de domaine par un domaine local, tout fonctionne normalement.

    j’avais fait un domaine gratuit duckdns pour avoir un certificat letsencrypt.(besoin d’apprendre a crée des certificats).

    Les certificats ont été révoqué, désactiver  le vhost WP et activer le default-ssl.conf seulement. Avec un domaine local sa fonctionne toujours, mais avec duckdns.org l’erreur revient.

     

    #2363006
    veg@
    Participant
    Initié WordPress
    4 contributions

    Trouvé une solution, je ne sais pas si c’est une solution ou un contournement, mais en ajoutant le domaine duckdns.org dans /etc/hosts du serveur, tout rentre dans l’ordre. Mais la ou je ne comprend pas, c’est que j’avais aussi un site nextcloud avec certificats letsencrypt, et aucun probleme.

    Je passe en résolue sans être sur à 100% que c’est la bonne solution

    #2363010
    C_Lucien
    Modérateur
    Maître WordPress
    4534 contributions

    Bonjour,

    vos problèmes semblent liés à la configuration côté serveur. Ce forum, consacré à WordPress, n’est pas le meilleur endroit pour y chercher des conseils.

    #2363021
    veg@
    Participant
    Initié WordPress
    4 contributions

    Salut,

    merci de l’info, voyant pas mal de topic je pensais être au bon endroit. fin sa à l’air de fonctionner pour le moment, je verrais aprés avoir installé extension,themes et fais de nouveau certificats.

    merci

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.