[Résolu] Erreur 550 cette page ne fonctionne pas (Créer un compte)

  • WordPress :6.4
  • Statut : résolu
  • Ce sujet contient 16 réponses, 3 participants et a été mis à jour pour la dernière fois par Tricotfils, le il y a 1 mois.
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #2470876
    Tricotfils
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4
    • Thème utilisé : ?
    • Extensions en place : woocommerce, stripe et quelques autres dont je ne me souviens plus car cela fait ans que je l’ai dévellopée
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.tricotfils.com

    Problème(s) rencontré(s) : J’ai tenté de lancer la mise à jours vers 6.5 comme suggéré vendredi mais cette dernière a échouée. Bon qu’a cela ne tienne, comme cette mise à jour apparassait toujours dans ma BO dimanche je l’ai relancée et elle a aussi échouée ! bon je n’insiste pas et retourne sur ma BO. Hier matin, je vais pour me connecter et là : une page blanche qui me dit que cette page ne fonctionne pas en erreur http 550 ! Pour mon site en ligne c’est pareille et pourtant, je n’ai rien fait !!

    Je suis allez sur mon ftp OVH pour faire une restauration de ma sauvegarde du samedi mais rien n’a changé ! Je ne suis pas allez modifié quoique se soit sur mon Filezilla donc normalement mon fichier .haccess doit être au bon endroit ! c’est la galère, je ne peux plus rien faire !

    Installée en province, les clientes se réfèrent au site internet pour venir en magasin et suivre les nouveautés, il leur sert de vitrines donc là c’est pas cool, dans leur tête plus de site donc plus de magasin physique ! Je suis commerce et me dépatouille seule avec ma boutique, si l’un de vous peut m’aiguiller ce serait avec plaisir.

    Merci par avance pour votre aide

    #2470888
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    Bonjour,

    La mise a jour a échoué et a fait planter le site. Bizarre que la restauration soit sans effet, mais tout dépend où se situe l’erreur. (ou les erreurs)

    Il faut refaire la mise à jour manuellement., en suivant ces étapes

    • sauvegardez votre base de données par phpMyAdmin (tuto : https://fr.wordpress.org/support/article/backing-up-your-database/#sauvegarder-a-laide-de-phpmyadmin)
    • sauvegardez par FTP (tuto Filezilla : https://fr.wordpress.org/support/article/using-filezilla/) votre dossier wp-content + les fichiers wp-config.php et .htaccess (et robots.txt si vous avez)
    • Comme vous n’avez plus accès au site, accédez à votre installation par FTP, allez dans wp-content, et renommez le dossier /plugins avec -X à la fin, cela permet de désactiver les extensions
    • téléchargez sur l’accueil du forum la dernière version de WordPress (6.5) et dézippez-la sur votre ordi
    • par FTP, supprimez côté droit (sur votre installation) les 2 dossiers wp-admin et wp-includes + les 15 fichiers situés à la racine sauf wp-config.php et htaccess (IMPORTANT)
    • reprenez les mêmes dossiers et fichiers à partir du côté gauche (WP 6.5 dézippé sur votre ordi) pour les copier côté droit à la place de ceux que vous venez de supprimer
    • ensuite, il faudra renommer le dossier wp-content/plugins normalement. Puis accédez à l’admin du site, et mettez à jour les extensions qui ont besoin de l’être. Puis réactivez les extensions une par une, en commençant par les plus importantes. Il faudra vérifier si aucune ne fait planter le site.
    #2470985
    Tricotfils
    Participant
    Initié WordPress
    12 contributions

    Merci beaucoup pour cette réponse détaillée. J’espère seulement que mon wp-content n’a pas été écrasé pas une mauvaise manip de ma part après avoir détecté l’erreur ! Semaine chargée et il me faut du  temps pour procéder alors je m’en occupe la semaine prochaine et revient vers vous. Merci beaucoup d’avoir pris le temps de me détailléer la procédure.

    bonne journé

    #2471025
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    OK, on attend des nouvelles. 🙂

    #2471264
    Tricotfils
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Alors j’ai tout suivi étape par étape sauf que lorsque je veux me connecter à ma BO c’est la source de mes fichiers qui s’affiche et en FO la page n’existe toujours pas ! une aide possible en attendant je charge tout dans un fichier sur mon fixe afin de supprimer l’affichage en ligne trop dangereux. C’est certainement une bidouille de rien du tout !

    Merci de votre aide

    #2471324
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    Bonjour,

    Pour éviter ce problème d’affichage de contenu des répertoires de votre installation (directory listing en anglais), il faut ajouter une ligne de code dans votre fichier .htaccess qui est situé à la racine de l’installation, là où il y a les 3 dossiers wp-admin / wp-content / wp-includes

    Donc, par FTP ou par le gestionnaire de fichiers de votre hébergeurs, accédez au fichier .htaccess, et ajoutez cette simple ligne à la suite de ce qui se trouve déjà dans le fichier :

    Options -Indexes

     

    #2471378
    Tricotfils
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    J’ai testé ecrit comme suit :

    Options <span class= »token operator »>-</span>Indexes

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    et comme cela

    # BEGIN WordPress
    <IfModule mod_rewrite.c>

    Options <span class= »token operator »>-</span>Indexes
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Mais ce ne doit pas être bon, mes sources ne s’affichent plus au grand jour mais toujours pas d’accès, j’ai le message suivant :
    <h1><span>Pas mis en œuvre</span></h1>
    <span>GET n’est pas pris en charge pour l’URL actuelle.</span>

    <span>De plus, une erreur 501 Not Implemented s’est produite lors de la tentative d’utilisation d’un ErrorDocument pour gérer la demande.</span>

    Merci beaucoup pour l’aide que vous m’apportez.

    #2471447
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    Déjà, il ne faut RIEN écrire entre # BEGIN WordPresset # END WordPress

    D’autre part, si vous avez mis les balises <span class= »token operator »> ça doit perturber.

    Il faut donc mettre juste Options -Indexes à la fin, donc après # END WordPress

    #2471524
    Tricotfils
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Après maintes bidouilles ce matin, réinstallation de wordpress dernière version, plugins-x, j’ai contaté que lorsque je réimplantait wp-admin sauvegardé cela plantait donc j’ai laissé le wp-admin de la nouvelle version de wordpress avec mon fichier wp-content et les 15 autres fichiers de la nouvelles version. Résultat, j’ai retrouvé ma BO avec l’accès à la base de données mais la page d’accueil de de woocommerce ne fonctionnait pas. un petit tour dans la BO de woocommerce pour lui repréciser qu’elle était ma page d’accueil et top tout refonctionne a-priori. Tout les plugins ont été réactivés même mondial relay au travers de boxtal fonctionne.

    Un très grand merci pour ton aide qui m’a été très très précieuse. Merci à votre solidarité avec nous petit commerçant qui n’avons pas les moyens de faire appel a des pro mais dont la visibilité en ligne est essentielle.

    Si vous voulez visitez mon petit monde et me faire remonter éventuellement des défauts http://www.tricotfils.com

    Bon dimanche

    #2471526
    Tricotfils
    Participant
    Initié WordPress
    12 contributions

    Encore une question et je ne vous embête plus promis. Lorsque l’on se mets sur une page de la boutique avec un clic droit, afficher la source, on voit tout le code de la page. Est-il possible de le rendre innaccessible avec une manip pas trop compliqué ?

    Merci

    #2471532
    ferman
    Participant
    Maître WordPress
    6997 contributions

    Bonjour,

    Lorsque l’on se mets sur une page de la boutique avec un clic droit, afficher la source, on voit tout le code de la page. Est-il possible de le rendre innaccessible avec une manip pas trop compliqué ?

    Il y a plusieurs extensions permettant d’inactiver le clic droit. Par exemple celle-ci. Il faut savoir qu’il est toujours possible à un visiteur sachant un tant soit peu utiliser les outils du navigateur d’avoir accès au code source. On ne peut pas l’éviter et ce n’est pas gênant.

    #2471554
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    je réimplantait wp-admin sauvegardé cela plantait donc j’ai laissé le wp-admin de la nouvelle version de wordpress avec mon fichier wp-content et les 15 autres fichiers de la nouvelles version.

    Il ne fallait pas remettre le dossier wp-admin d’une ancienne version (il n’y avait d’ailleurs pas besoin de le sauvegarder)
    Le seul dossier à sauvegarder, c’est wp-content et les fichiers wp-config.php et .htaccess (à conserver, en cas de fausse manip’ ou de plantage du site)

    Pour installer la nouvelle version, il faut télécharger les dossiers wp-admin et wp-includes (et les 15 fichiers de base) de la nouvelle version dézippée.

    Concernant le clic droit, il est déconseillé de la désactiver si vous avez une boutique, ou si vous utilisez les commentaires.
    Si vous ne voulez pas qu’on voie votre code-source, ou + exactement pour le rendre difficile à lire, vous pouvez minifier le contenu de vos pages (en plus, ça accélèrera le chargement) => utilisez l’extension Autoptimize, ou une extension de cache.

    #2471568
    Tricotfils
    Participant
    Initié WordPress
    12 contributions

    Merci beaucoup pour tout.

    #2471659
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    De rien 🙂

    Du coup, je passe le sujet en « résolu »

    #2471667
    Tricotfils
    Participant
    Initié WordPress
    12 contributions

    Oui merci, je voulais le faire mais je savais pas comment. Bonne journée

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.