[Résolu] Erreur 500 réinstallation impossible (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2366856
    philippe @ ki-learning.fr
    Participant
    Padawan WordPress
    65 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP 7.2
    • Thème utilisé : twentytwentyone
    • Extensions en place : aucunes /desactivée
    • Nom de l’hébergeur : scaleway / online
    • Adresse du site : https//www.ki-learning.fr/web2.0/

    Problème(s) rencontré(s) :

    Bonjour à tous,
    Cela fait très longtemps que je n’ai pas posté ici, j’ai mon blog depuis plus de 10 ans, j’ai profité de l’automatisation des mises à jours. Je n’avais jamais passé mon site en ssl , les problèmes ont commencé là. J’ai installé le plugin really simple ssl et en voulant mettre à jour le contenu du fichier .htacess de mon site, je l’ai planté, il y a trois semaines maintenant.

    Pour faire court, craignant que des fichiers soient corrompus, j’ai réinstallé la version wordpress-5.6-fr_FR, j’ai supprimé les plugins, en renommant le répertoire, j’ai fait tester ma base mysql par mon fournisseur d’accès tout fonctionne de leur coté, le mot de passe est juste….Pourtant , je garde une erreur 500 sur https://www.ki-learning.fr/web2.0/ Pas de process d’installation : erreur 500 🙁 grr!!
    J’ai ensuite créé une nouvelle base mysql de test vierge , je rentre les nouveaux identifiants, nom de base, adresse du serveur de bdd et mot de passe, je crée des clefs uniques pour le fichier wp-config et là encore erreur 500
    Pourtant avec ce fichier test, j’ai accès à mon premier compte de bdd https://www.ki-learning.fr/connexion.php , ( la table est déja créé)
    Voici le code de connexion.php que j’utilise :

    <?php
    $server= “kilearningfr.sql-pro.online.net”; /* Nom d’hôte de la base de données */
    $user= “kilearningfr”; /* Nom d’utilisateur de la base de données */
    $password= “monmotdepasse”; /* Mot de passe */
    $database= “kilearningfr”; /* Nom de la base de données */
    $table= “testautre”; /* Nom de la table, au choix */

    /* Accès au serveur SQL et création de la table */
    if ((!$link = mysqli_connect($server, $user, $password, $database)))
    die(printf(“<H3>Serveur de la base de données non accessible: [%d] %s</H3>”, mysqli_connect_errno(), mysqli_connect_error()));

    if (!mysqli_query($link, “CREATE TABLE ” . $table . “(name varchar(25),email varchar(25),id int(11))”))
    die(printf(“<H3>La table ne peut pas être créée: [%d] %s</H3>”, mysqli_connect_errno(), mysqli_connect_error()));

    mysqli_close($link);
    ?>

    Je ne sais plus du tout dans quelle direction chercher !! :-((
    Je vous remercie de vos suggestions et aides éventuelles
    Philippe

    #2366859
    mathieu42
    Participant
    Chevalier WordPress
    427 contributions

    renommer le fichier .htaccess (et gardez le) du répertoire “web2.0” et si cela à changé quelque chose, allez dans l’espace d’administration -> Réglages -> Permaliens et enregistrer la page sans rien modifier ça devrait recréer le fichier .htaccess.

    et si tout à l’air de fonctionner comparez le contenu du nouveau fichier avec l’ancien.

    #2366865
    philippe @ ki-learning.fr
    Participant
    Padawan WordPress
    65 contributions

    Merci Matthieu,

    Je n’ai plus de fichier .htaccess propre, mais quand je mets celui sur j’ai , la j’obtiens une erreur serveur ..ça change !

    Cordialement

    #2366932
    philippe @ ki-learning.fr
    Participant
    Padawan WordPress
    65 contributions

    Je voudrais compléter mon observation, lors de mon second essai, j’ai créé une nouvelle base mysql vierge et j’ai renseigné mon fichier config.php avec cette nouvelle base, cela devra lancer la procédure d’installation non ? Or je reçois erreur 500, je n’ai pas besoin de fichier .htaccess pour cela en principe, n’est pas ce pas ?

    #2367776
    philippe @ ki-learning.fr
    Participant
    Padawan WordPress
    65 contributions

    J’ai résolu mon souci d’installation en générant une nouvelle installation de mon WordPress  en modifiant le préfixe wp_ par un autre dans la même base de données, de nouvelles tables sont alors générées dans ma base mysql à coté de la base historique. Une fois mon nouveau blog mis en place, j’ai pu récupérer pratiquement toutes les tables précédentes en particulier wp_post qui contient mes articles et wp_postmeta…les catégories.., je me suis débarassé de la vielle table wp_option que je suspectais d’être corrompue.

    Dans phpmyadmin , je vais dans le menu opération, puis je fais “Copier la base de données vers” et je ne copie que les données vers ma nouvelle base.

    J’ai renoncé à mon thème personnalisé que je voulais refaire depuis longtemps.

    Voila résolu !

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.