[Résolu] Erreur 500 insoluble pour un noob du domaine :’) – Merci de votre aide (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
15 sujets de 16 à 30 (sur un total de 52)
  • Auteur
    Messages
  • #2364532
    Flobogo
    Modérateur
    Maître WordPress
    16956 contributions

    @Ederweld :

    J’ai identifié un dossier config dans statistiques et l’ai fait remonter dans htdocs (voir screen 1)

    Il n’a jamais été question de déplacer un “dossier config” mais bien le “fichier wp-config.php” : un dossier contient des fichiers, ce n’est donc pas la même chose (c’est comme confondre un classeur et une feuille). Et même si le nom se ressemble, ce n’est pas le même.

    Vous avez donc déplacé un dossier config à un endroit où il n’a rien à faire, ce qui va empirer votre situation au lieu de l’améliorer !

    Je vous conseille :

    • de sauvegarder tout le contenu de htdocs sur votre ordinateur, par exemple sur le bureau (c’est indispensable, sinon vous risquez de perdre toutes vos images, fichiers, thèmes et extensions installés)
    • puis de supprimer le contenu de htdocs (vider tout)
    • ensuite, comme le dit @Li-an, vous renvoyez une installation “neuve” de la version de WordPress que vous aviez, à retrouver   : vous aviez sans doute la version 5.4.2
    • pour finir, vous renverrez dans le dossier wp-content les éléments de votre sauvegarde, à savoir wp-content/themes (et tout son contenu), idem pour wp-content/plugins et wp-content/uploads
    • et enfin, vous renvoyez le fichier wp-config.php là où il aurait dû être, c’est à dire à la racine, à la suite des 3 dossiers wp-admin / wp-content / wp-includes

    Le contenu de votre fichier wp-config.php est normal, vu ce que vous avez copié ci-dessus. Le problème, c’est donc de remettre tous les dossiers et fichiers à la bonne place, en procédant comme je viens de vous l’écrire.

     

    #2370162
    Ederweld
    Participant
    Initié WordPress
    25 contributions

    Bonjour et merci pour vos réponses. Le tutoriel de @flobogo est très clair et vous voir converger vers la même solution est rassurant.

    Je retrouve ces jours-ci le temps et l’énergie pour me réatteler à ce problème. J’ai bien téléchargé htdocs sur plusieurs supports différents et m’apprète à réinstaller wordpress. En cliquant sur votre lien, on me propose plusieurs versions différentes sha1, md5 en zip ou tar.gz. Ne connaissant pas l’extension tar.gz, je pensais opter pour zip. Mais en cliquant sur les liens ça ne télécharge rien :/. Cela m’affiche juste une suite de numéro et lettres sur une page web blanche. Dans l’éventualité où je parviendrai à télécharger le fichier, pourriez-vous me préciser l’étape ”

    1. Créez une base de données pour WordPress sur votre serveur Web,” du tutoriel d’installation manuelle de wordpress svp, ça ne me parle pas du tout :/. J’ai aucune idée de comment m’y prendre et où la crer dans l’arborescence. Merci à vous.
    #2370163
    Flobogo
    Modérateur
    Maître WordPress
    16956 contributions

    Bonjour,

    Vous n’êtes pas pressé de retrouver votre site. 😉

    Pour télécharger WordPress, cliquez simplement sur le lien zip de la version que vous aviez. Ne vous occupez pas de md5 ou sha1
    Une fois téléchargé sur votre ordinateur, dézippez le dossier. Il contient 3 sous-dossiers wp-admin / wp-content / wp-includes et une quinzaine de fichiers.
    Vous devrez envoyer (“téléverser”) en passant par le FTP les dossiers wp-admin et wp-includes et une quinzaine de fichiers. (mais pas wp-content) dans le dossier htdocs chez l’hébergeur.

    Suivez bien mes explications ci-dessus (du 30 décembre). Vous n’avez pas besoin de créer une base de données, ça a déjà été fait lors de la 1ère installation de votre site.

     

    #2370189
    Ederweld
    Participant
    Initié WordPress
    25 contributions

    Bonjour,

    Le site est inactif depuis 2017, je le conserve au titre d’une archive. Mais ça reste 7 ans de boulot que j’ai à coeur de maintenir en ligne. Le timing des projets en cours à sortir et la peur de faire une fausse manip, freinent le process.

    J’ai procédé comme indiqué (merci pour votre pas à pas précieux). J’ai sauvegardé les docs, vidé htdocs, remis les fichiers wp indiqués, remis un wp-content avec les éléments décrits et remis wp-config.php dans htdocs, comme évoqué (il n’apparaît pas mais est remis à sa place). Le problème persiste, j’avoue sécher. J’ai sans doute loupé un truc. :/

    • Cette réponse a été modifiée le il y a 2 semaines par Ederweld.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2370283
    mathieu42
    Participant
    Chevalier WordPress
    434 contributions

    montrez nous les dernières lignes du fichier “wp-content/debug.log”

    #2370291
    Flobogo
    Modérateur
    Maître WordPress
    16956 contributions

    Sur la capture, on voit bien les 3 dossiers wp-admin/wp-content/wp-includes, et le contenu de base pour wp-content est OK.
    Mais est-ce qu’il y a bien les 15 fichiers nécessaires à la suite ?

     

    #2370313
    Ederweld
    Participant
    Initié WordPress
    25 contributions

    Bonjour. @flobogo : Effectivement, j’ai remis les 15 fichiers dans htdocs comme indiqué.


    @mathieu42
    , je m’étais borné à remettre dans content que les dossiers indiqués plus haut, debug n’y était pas, j’ai donc remis dans content, tout ce qui y était précédemment. Voilà les dernières lignes du fichier debug (il y a beaucoup de lignes) :

    020-12-28 21:22:23
    <b>ewww_image_optimizer_init()</b>
    checking active plugins
    Nextgen version: 3.3.6
    loading nextgen 3 support for nextgen-gallery/nggallery.php
    <b>EWWW_Nextgen::__construct()</b>
    background mode enabled for nextgen
    2020-12-28 21:22:24
    <b>ewww_image_optimizer_init()</b>
    checking active plugins
    Nextgen version: 3.3.6
    loading nextgen 3 support for nextgen-gallery/nggallery.php
    <b>EWWW_Nextgen::__construct()</b>
    background mode enabled for nextgen

    #2370321
    Flobogo
    Modérateur
    Maître WordPress
    16956 contributions

    OK. Ça devrait pourtant fonctionner, car tout est opérationnel. Pourriez-vous mettre des captures écran (si besoin, en message privé) avec le contenu de vos différents répertoires (hors htdocs), pour voir si il n’y a pas des fichiers de votre précédente installation qui traînent quelque part.

    #2370323
    Ederweld
    Participant
    Initié WordPress
    25 contributions

    Bonsoir et merci pour votre réactivité. Je ne sais pas si cela répond pleinement à votre remarque mais vous trouverez le cheminement complet dans la première pièce jointe.

     

    Par ailleurs, en remettant le fichier debug dans wpcontent plus tôt dans la soirée, j’ai aussi remis tout l’ancien wpcontent. Je constate qu’il y a du theme et du plugin dans un dossier “language”, ça ne semble pas très réglementaire. Je le vide ? Merci à vous.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2370379
    Flobogo
    Modérateur
    Maître WordPress
    16956 contributions

    j’ai aussi remis tout l’ancien wp-content. Je constate qu’il y a du theme et du plugin dans un dossier “language”, ça ne semble pas très réglementaire. Je le vide ?

    Non, c’est normal, ce sont les fichiers de langue pour les différents thèmes et pour les différents plugins.

    Par contre, vous avez des dossiers d’extensions qui se “promènent” en dehors du dossier wp-content/plugins, et ça ce n’est pas normal.

    Je vous joins 2 captures écran, qui reprennent les vôtres, avec des questions et des indications.

    Concernant l’arborescence complète, je me questionne sur l’emplacement du dossier “htdocs” (qui doit se trouver sous “ederweld”, ça c’est OK), lui-même dans “vhost”. Mais il y a 2 dossiers “vhost” dans votre arborescence : que contient l’autre ?

    Et enfin, je ne vois pas les 15 fichiers qui doivent aussi se trouver dans “htdocs” : pouvez-vous les afficher en capture écran ?

    On va déjà essayer avec tout ça. (voir mes captures écran + questions ci-dessus)

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2370607
    Ederweld
    Participant
    Initié WordPress
    25 contributions

    Bonjour et merci pour votre retour.

    J’ai remis les éléments en violet à la place indiquée (dans plugin) et supprimé les deux qui devaient l’être (db et tmp).

    J’ai cliqué sur le deuxième Vhost, ça me redirige sur le premier comme s’il s’agissait d’un “raccourci”. Bizarre.

    Ps : même effet pour snapchot et pour “private” du deuxième embranchement, c’est moins direct mais ça boucle aussi :/

    Les 15 éléments sont en capture d’écran comme demandé.

    • Cette réponse a été modifiée le il y a 1 semaine et 3 jours par Ederweld.
    • Cette réponse a été modifiée le il y a 1 semaine et 3 jours par Ederweld.
    • Cette réponse a été modifiée le il y a 1 semaine et 3 jours par Ederweld.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2370715
    Flobogo
    Modérateur
    Maître WordPress
    16956 contributions

    Bon, les fichiers à la racine sont OK.

    Encore quelques petits points à régler, mais vous auriez dû récupérer l’accaès :

    • pour les dossiers fléchés rouge, en fait, c’était une accolade (que je ne sais pas faire), il faut donc supprimer également le sous-dossier “object” présent dans le dossier “cache”. Vous pouvez vider complètement le dossier “cache”
    • juste au-dessus, dans l’arborescence, vous avez un dossier “backup-f8385” : téléchargez-le (copiez-le) sur votre ordinateur, puis supprimez-le côté hébergement.

    Ensuite, refaites-moi 3 captures écran pour le contenu complet de wp-admin / de wp-content / et de wp-includes

    #2370731
    Ederweld
    Participant
    Initié WordPress
    25 contributions

    Bonjour,

    Je n’ai malheureusement pas la main sur mon panneau d’admin et l’aspect extérieur reste une page blanche avec message d’erreur.

    Je vous confirme avoir vidé le cache, sauvegardé puis supprimer backup. Vous trouverez les 3 copies d’écran en pièce jointe. J’en ai préparé de + détaillées si besoin 🙂 !

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2370758
    Flobogo
    Modérateur
    Maître WordPress
    16956 contributions

    Ok, mais le contenu des dossiers est incomplet puisqu’il n’y a pas les fichiers sur vos captures écran. dans wp-admin, il doit y avoir 96 éléments, donc 7 dossiers (OK) et 89 fichiers, avez-vous ce nombre ?
    Pareil pour wp-includes, qui doit contenir en tout 221 éléments (pour les sous-dossiers, c’est OK)

    Dans wp-content, vous avez google-maps-bank qui n’est pas au bon endroit : ce dossier doit être dans plugins

    Sauvegardez ensuite sur votre ordi les dossiers “cache”, “cusri”, “modules” et “upgrade”, (je ne sais pas à quoi sert “cusri” ?) puis supprimez-les.
    Votre dossier wp-content ne devra contenir que “languages” / “plugins” / “themes” et “uploads”.
    Y a t-il des fichiers dans wp-content, à la suite des dossiers ?

    #2370774
    Ederweld
    Participant
    Initié WordPress
    25 contributions

    Vous trouverez le contenu de WP admin et Wp content (je vous ai mis ce que j’avais avec la copie d’écran précédente) dans les copies d’écran en pièce jointe. Je vous envoie celles sur Wp includes dans le message suivant.

    google-maps a été rangé dans plugins.

    J’ai bien retiré cache, cusri (dont je ne sais pas non plus l’usage) et upgrade.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
15 sujets de 16 à 30 (sur un total de 52)
  • Vous devez être connecté pour répondre à ce sujet.