Erreur 500 chez Online.net (Créer un compte)

  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #455984
    Caribou
    Participant
    Initié WordPress
    33 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.3.1
    – Thème utilisé : Talian 1.0
    – Plugins en place : WP-Print
    – Nom de l’hebergeur : Online.net
    – Adresse du site :

    Problème(s) rencontré(s) : Erreur 500…

    J’ai voulu modifier la structure par défaut des permaliens et depuis, erreur 500… Je n’ai plus accès à aucune page du blog, même pas l’admin. J’ai suivi le conseil suivant trouvé sur ce forum :

    1. Allez dans PhpMyAdmin, ouvrez votre base de données puis afficher la table “wp_options”.
    2. Ensuite cherchez l’option “permalink_structure”. Elle se trouve à la ligne 34. Selon le nombre de lignes affichées par page elle peut se trouver vers la fin de la première page ou en début de la deuxième page.
    3. Ensuite cliquez sur “Modifier” et effacez ce qu’il y a d’inscrit. Quand vous avez l’option “structure des permaliens par défault” cochée dans la console admin de WP, cette case est vide.
    4. Enfin faites “Exécuter”.

    Mais rien n’y fait…

    Pour info, je n’ai aucun fichier .htaccess et je transfère avec FileZilla (option d’affichage des fichiers cachés cochée). What can I do ?

    #617067
    Caribou
    Participant
    Initié WordPress
    33 contributions

    Bon, j’ai trouvé tout seul… Si ça peut aider d’autres : j’ai tout bonnement créé un fichier .htaccess (vide) que j’ai uploadé à la racine dans mon dossier WP. J’imagine que l’opération effectuée au préalable dans PhpMyAdmin a été nécessaire. Je retenterais bien le diable, mais j’hésite…

    Mon blog.

    #617068
    Caribou
    Participant
    Initié WordPress
    33 contributions

    Comme je tenais à changer ma structure des permaliens, j’ai chipoté (mon serveur ne me laisse pas faire des chmods au-dessus de 644), essayé diverses choses, mais à chaque fois nouvelle erreur 500. Alors j’ai détruit mon .htaccess (pourtant vide) et ça marche enfin.

    J’ai choisi une structure personnalisée sous la forme : /archive/%postname%/

    Ça roule, Raoul !

    #617069
    Caribou
    Participant
    Initié WordPress
    33 contributions

    La structure /archive/%postname%/ ne marche plus dès lors que l’on quitte l’index pour lire l’article entier. Je suis donc passé sous une structure PATHINFO : /index.php/%postname%/. Et ça, ça marche. Sous Online donc, hormis la configuration par défaut de WordPress, seules fonctionnent les structures avec un PATHINFO (/index.php/), vu qu’Online ne permet pas de chmoder au-dessus de 644.

    Donc si on désire des liens parlants, on aura une adresse minimale du type :

    http://www.site.com/monblog/index.php/nom-de-larticle

    Toute autre structure est permise pourvu qu’elle soit précédée du PATHINFO /index.php/

    J’espère que mon expérience sera utile à d’autres.

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.