Erreur 404 pour mon flux RSS depuis mise à jour WP 2.5 (Créer un compte)

  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #459246
    MatthieuM
    Membre
    Initié WordPress
    16 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.5.1
    – Thème utilisé : Revolution Blog
    – Plugins en place :
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.cecidit.com

    Problème(s) rencontré(s) :

    Bonjour, je viens de m’aperçevoir via feedburner que mon flux (http://www.cecidit.com/wp-rss2.php) utilisé depuis toujours, était subitement invalide et me donnait une belle erreur 404 (et une erreur feedburner). J’ai changé de thème et mis à jour WP au même moment, je mettrais plutôt ça sur le compte de wordpress étant donné qu’en remettant mon ancien thème, cela ne résoud rien…

    Je ne parviens pas à savoir qu’elle peut être la nouvelle adresse de mon flux, aucune info n’est donnée à ce sujet dans mon admin wp et les différentes adresses que j’ai essayé (/feed/rss et ?feed=rss) n’ont rien donné d’autre qu’une erreur 404.

    Que puis-je faire ?

    Merci vraiment de votre aide..

    #629065
    wolforg
    Participant
    Chevalier WordPress
    248 contributions

    Salut MatthieuM,
    Je viens de quitter un site qui parle de ce souci : http://www.etanonline.powa.fr/2008/wordpress-251-flux-rss-vide/, voici ce qu’il y est dit :

    Si comme moi vous avez eu des problèmes de “flux vide” (RSS) après le passage à WordPress 2.51, voici comment corriger ça:

    Il s’agit en fait d’un problème de lien. En effet pointer sur le fichier wp-commentsrss2.php ou wp-rss2.php ne retournera aucun résultat. Il faut utiliser les permaliens.

    Donc pour ceux d’entre vous qui pointent avec FeedBurner ou autre sur ces fichiers, ça ne fonctionnera pas. Il faut donc modifier vos liens en utilisant les adresses suivantes:

    Pour les articles:
    http://www.monsite.fr/feed/rss2/

    Pour les commentaires:
    http://www.monsite.fr/comments/feed/

    C’est tout ! Pensez donc à vérifier vos RSS et à mettre à jour vos liens FeedBurner …

    Voili voilà :wp:

    #629066
    MatthieuM
    Membre
    Initié WordPress
    16 contributions

    Merci pour ta réponse wolforg. J’ai mis à jour Feedburner en remplacant l’ancienne adresse par celle en /feed/rss2/, j’ai resynchronisé, j’ai aussi mis à jour Feedlocation. Après un certain temps d’attente (le temps que tout se resynchronise je pense), ça remarche comme avant 🙂 Merci beaucoup pour ton aide ! 🙂

    #629067
    wolforg
    Participant
    Chevalier WordPress
    248 contributions

    Pas de souci MatthieuM, à charge de revanche

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.