[Résolu] Erreur 403 Sélective

  • WordPress :4.7
  • Statut : résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #1877645

    homerc
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle 4.8.1

    • Version de PHP/MySQL : 7.0/5.5
    • Thème utilisé : Fashionista-hild
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site :

    Problème(s) rencontré(s) : erreurs 403 pour certains utilisateurs
    Depuis vendredi et sans raison (pas de MAJ extension ou WP) des utilisateurs et lecteurs sont en erreurs 403.

    J’ai vidé les cache du CDN et demandé aux personnes impacté de vider les chaches et les cookies pour le site. Aucun changement.

    J’ai demandé de l’assistance à OVH qui m’a répondu que j’avais un problème avec WP de redirection.

    Mon site est en place chez eux depuis mai et ma seul modification a été la mise en place mutualisé d’un site de staging afin de faire mes tests de montée de version en juillet.

    Les erreurs se produisent sur des configurations diverses, PC et MAC, navigateur Chrome, FIrefox et Safari.

    Sur mobile également j’ai eu un cas sous 4G erreur 403 passage en WI-FI plus d’erreur.

    J’ai donc ajouté dans le .htacces les lignes suivantes :

    <code class=" code-embed-code language-apacheconf"><span class="token comment" spellcheck="true"># Redirection du site avec www vers la version sans www</span>
    <span class="token directive-inline property">RewriteEngine</span> on
    <span class="token directive-inline property">RewriteCond</span> <span class="token variable">%{HTTP_HOST}</span> <span class="token regex">^www.monsite.com </span><span class="token directive-flags keyword">[NC]</span>
    <span class="token directive-inline property">RewriteRule</span><span class="token regex"> ^(.*)$</span> http://monsite.com/<span class="token variable">$1</span> [L,R=301]
    Ceci semble avoir résolue la plupart des problèmes.
    
    Mais j'ai encore 2 cas signalé: 
    Le premier sous MAC avec Chrome et FIREFOX erreur 403, safari pas d'erreur mais firefox met un avertissement pour site non sécurisée.
    Le second sous PC avec Chrome et Firefox erreur 403, IE fonctionne.
    
    Je leur ai refait vider les caches et cookies mais pas de changement.
    
    Si vous avez une idée, ou encore mieux une solution n'hésitez pas!
    PS : Si ce n'est pas clair et que vous avez besoin de précision n'hésitez pas non plus, ça fait 2 fois que je tape la demande d'aide et qu'elle n'apparaît pas.

    Merci

    #1877856

    Li-An
    Modérateur
    Maître WordPress
    18762 contributions

    Bonjour, vous avez oublié le plus important, les extensions.

    #1878028

    homerc
    Participant
    Initié WordPress
    4 contributions

    Bonsoir Li-An :

    Voilà la liste :

    • Advanced post slider
    • Akismet Anti-Spam
    • AMP
    • Bad Behavior
    • BuddyPress
    • BuddyPress Activity Comment Notifier
    • BuddyPress Activity Plus
    • Category Posts Widget
    • Co-Authors Plus
    • Code Snippets
    • Content Warning v2 – Maintenance Hold
    • Google Analytics pour WordPress par MonsterInsights
    • Jetpack par WordPress.com
    • Menu Social Icons
    • Most and Least Read Posts Widget
    • OneSignal Push Notifications
    • Rocket Lazy Load
    • WP Gfycat
    • WP Smush
    • Yoast SEO

    Voilà la liste

    Le message 403 fait référence à Bad Behavior quand tu demandes de l’aide pour résoudre toi même l’erreur de ton navigateur.

    Merci de ton aide.

     

    #1879886

    Li-An
    Modérateur
    Maître WordPress
    18762 contributions

    Je n’ai pas trop compris la dernière phrase mais  désactivez les extensions, mettez un thème par défaut et testez pour voir.  On n’a pas l’URL du site et c’est bien dommage parce que ça pourrait venir éventuellement d’un problème lié au certificat de sécurité.

    #1879906

    homerc
    Participant
    Initié WordPress
    4 contributions

    Bonjour merci de ton aide.

    J’ai commencé à désactiver les extensions une par une. J’ai commencé par Bad Behavior car comme j’ai essayé d’expliquer, un lien de résolution m’amener sur une page d’aide de cette extension.
    Et là il semble que tout le monde ait de nouveau accès au site.
    Le site est http://www.horsjeu.net
    Je n’avais pas mis l’URL pour ne pas faire de pub ou enfreindre les règles.

    Je reste surpris car la dernière MAJ remonte à plus de 15 jours.
    Encore Merci je vais clore le sujet et essayer de contacter l’auteur de l’extension.

    #1879947

    Li-An
    Modérateur
    Maître WordPress
    18762 contributions

    Il aurait fallut dire alors pourquoi vous ne mettiez pas l’URL 🙂 Il suffisait de faire un message « privé » pour qu’il soit caché au public. Il y a peut-être une interaction de Bad Behaviour avec une autre extension – je l’utilise moi-même sur un site mais il n’est pas assez fréquenté pour avoir des retours.

    #1880421

    homerc
    Participant
    Initié WordPress
    4 contributions

    merci du retour,

    J’ai regardé le support il y a une erreur comme la mienne il y a un an mais toujours en cours car l’auteur de l’extension ne reproduit pas le cas.

    Je vais remonter mon staging pour faire des tests, si mes navigateurs ont l’erreur (ce qui n’est pas le cas actuellement).

    Et chercher une alternative à Bad Behavior.
    J’essaierai d’être meilleur la prochaine fois pour créer la demande.

    Bonne journée

    #1880614

    Li-An
    Modérateur
    Maître WordPress
    18762 contributions

    Vous pouvez tester les extensions pare-feu qui feront mieux que BadBehaviour – Ninja Firewall, Wordfence.

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.