Erreur 403 -_-

  • WordPress :4.9.9
  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2210697
    virtazp
    Participant
    Padawan WordPress
    58 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : OcéanWp
    • Extensions en place :
    • Nom de l’hébergeur : Serveur local
    • Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour,

    Suite aux recommandations SEO, j’ai voulu changer l’adresse url du site : http://srv-atoll.test.groupe-isia.com:8080/wordpress/ comme cela : http://srv-atoll.test.groupe-isia.com:8080/ .

    Je suis allé dans général et j’ai modifier les 2 lignes. Et bim, gros choc, plus rien fonctionnait.

    Du coup j’ai remodif dans la bdd les 2 lignes. Mais maintenant hormis la page d’acceuil , j’ai une erreur 403 sur mes pages !

    Une idée?

    Merci d’avance!

     

    #2210896
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Bonjour,
    Merci de bien remplir le questionnaire entièrement.
    Changer d’url pour un site en local.
    Avez-vous renommer le fichier .htaccess en .htacess.txt, pour voir si l’erreur est toujours présente ?

    #2210978
    virtazp
    Participant
    Padawan WordPress
    58 contributions

    Bonjour et merci pour votre commentaire !

    En faite, c’est serveur web local de mon entreprise, c’est un IIS 7 sous win serveur. Le changement d’url est suite aux recommandation SEO faite par une entreprise externe spécialisé là dedans, mais comme des idiots, on a pas réfléchit, et on a voulut essayer ^^

    Tout à commencer comme expliqué en haut, et à ce jour la solution n’a pas été trouvé. En attendant, j’ai changer le réglage des permaliens sur “simplifier”. De plus, j’ai migrer le site wordpress sur un serveur  test 1&1 sous linux, et ça fonctionne avec /%Postname%/.

    C’est pas une erreur commune, car l’erreur 403.14 nous dit que nous n’avons pas les droits sur la page.  Et on a suivit les tutos pour les différentes solutions proposées mais sans succès, nos compétence sont plus sur le dèv que sur ça :p

    Ha et pour le htaccess, oui c’est le premier fichier que j’ai regardé mais à ce niveau là, et au niveau du fichier web.config qui est à la racine du fichier wordpress, tout est bon !

    Voilà, si de passage sur le forum, quelqu’un a une soluce 🙂 Sinon si ma DSI trouve la soluce, je la posterai. Bisous les gens 🙂

    #2211043
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Bonjour,
    Un serveur web local, désolé, je n’ai pas de connaissance, là dessus, j’ai toujours pris des offres mutualisés.
    Le fichier racine de WordPress est wp-config.php, non web.config.

    Sur FTP, les dossiers ont les permissions 755 ? Et les fichiers ont les permissions 644 ?

    Vous avez testé ces solutions ?
    https://support.microsoft.com/fr-fr/help/942062/http-error-403-14-forbidden-error-when-you-open-an-iis-7-0-webpage

    #2211206
    Flobogo
    Modérateur
    Maître WordPress
    15856 contributions

    Bonjour,

    Peu importe que le changement d’URL soit en local ou pas, il faut suivre ces conseils : https://wpchannel.com/wordpress/tutoriels-wordpress/corriger-changement-accidentel-url-wordpress

     

    #2211253
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Bonjour,
    Pardon, mais dans les commentaires, on lit
    “bonjour, j’ai essayé la méthode en éditant le php, mais rien n’a changé.
    Alors j’ai été dans ma base mysql et j’ai changé l’adresse dans siteurl et home pour remettre la bonne adresse. (il y avait bien l’adresse que j’ai modifié dans mon admin wordpress et que je n’aurais jamais du toucher)
    et puis ba rien n’a changé non plus. je ne peux toujours pas avoir acces à mon admin wordpress.”

    Pour migrer ou changer l’url, je préfère utiliser le script Search&Replace
    WordPress :: Migrer son site avec le script d’Interconnectit

     

    #2211373
    Flobogo
    Modérateur
    Maître WordPress
    15856 contributions

    Euh, vous parlez de quel commentaire ?

    Le conseil donné sur le site wpchannel est tout à fait correct (Son auteur, Aurélien Denis, est suffisamment connu dans la communauté WP pour qu’on puisse faire confiance aux conseils sur son site 🙂 ). La solution du script Search and Replace, c’est pour modifier les adresses sur le site complet, si les permaliens ont mis à jour après une migration et/ou un changement de NDD.

    Pour l’instant, les permaliens n’ont pas été mis à jour, c’est pour ça qu’il obtient une erreur “hormis la page d’accueil” comme il le dit. Il suffit donc de modifier l’URL principale dans la base de données (PhpMyAdmin), comme indiqué sur le site de WP Channel., ou bien dans le fichier wp-config.php

    #2211380
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Bonjour @flobogo ,

    Dans les commentaires du lien que vous donnez, oui, je clique sur les liens, je lis tout même les commentaires.
    Je connais le site WP Channel, depuis des années, sa réputation n’est plus à faire, une grande valeur dans la communauté de WP.
    J’ai souvent mis un lien vers son site pour aider les personnes sur le forum.

    Je n’ai pas remis en question votre solution, je dis juste, comme pour le commentaire sur le site de WP Channel, si cela ne suffit pas, il y a, peut-être, le script Search&Replace, pour migrer et changer l’url, qui peut aider.

    Bonne continuation

    #2211382
    virtazp
    Participant
    Padawan WordPress
    58 contributions

    Re,

    dans mon fichier racine, j’ai bien un fichier web.config au lieu du .htaccess car j’utilise un serveur windows.

    et le soucis vient du web.config aux dernières nouvelles m’a confié ma DSI, mais c’est à confirmer.

    Sinon merci pour le lien de wp-channel, il est très utile : )

    Edit: oui nous avons suivit les divers tutos pour l’erreur 403.14, mais cela n’a rien changé. Pour les droits des fichiers, nous ne passons pas par un FTP car cela reste un serveur web local, donc nous sommes admin sur toute la machine, et nous avons accès aux fichiers directement via notre réseau.

    • Cette réponse a été modifiée le il y a 1 année et 1 mois par  virtazp.
    #2211999
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Bonjour,

    Désolé, je n’ai pas compris le lien vers WP Channel (à conserver, surtout).
    Flobogo me dit “Il suffit donc de modifier l’URL principale dans la base de données (PhpMyAdmin)“, dès votre premier message, vous disiez l’avoir fait “j’ai remodif dans la bdd les 2 lignes”.
    Par erreur, j’ai cru que vous parliez de la même chose, modifier les deux lignes siteurl et home dans la table wp-options, j’ai mal compris.

    Si la DSI vous dit que le problème vient du web.config, il faut voir le code à l’intérieur, non ?
    sur un article de 2015, je vois ce code
    https://solutions.hostmysite.com/index.php?/Knowledgebase/Article/View/8793/0/wordpress-webconfig-file-for-windows

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <rewrite>
    <rules>
    <rule name="Main Rule" stopProcessing="true">
    <match url=".*" />
    <conditions logicalGrouping="MatchAll">
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
    </conditions>
    <action type="Rewrite" url="index.php" />
    </rule>
    </rules>
    </rewrite>
    </system.webServer>
    </configuration>

    Bon courage.

     

    #2212708
    Flobogo
    Modérateur
    Maître WordPress
    15856 contributions

    Finalement, le fait que ce soit une install’ sur serveur local modifie peut-être certaines choses. D’ailleurs, vous auriez eu une erreur 404, pas 403. Et pour ma part, je ne sais pas ce qu’est le fichier web.config.
    Je crois qu’il vaut mieux vous tourner vers un professionnel, et c’est le boulot de votre DSI.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.