Enlever le “noindex” de mon site (Créer un compte)

  • WordPress :5.0.3
  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #2254130
    HugoApproved
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7
    • Thème utilisé : Sun by Osetin
    • Extensions en place : Yoast, Smush, AMP, SiteOrigin widgets, All in One WP Sécurité
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://hugoapproved.com/

    Problème(s) rencontré(s) :

    Bonjour,

    Quand je recherche mon site sur le Web, les moteurs de recherche refusent d’afficher mes balises meta et titre. Après avoir cherché un peu, il semblerait que des attributs “noindex” soient présents sur mon site, mais impossible de les trouver (j’ai déjà consulté les autres sujets relatifs à ce thème). Impossible de les trouver dans le header, et je n’ai aucune idée d’où ça pourrait venir (je n’ai pas activé les robots.txt)

    Comment pourrais-je voir d’où vient l’erreur et la corriger ?

    Merci beaucoup 🙂

    • Ce sujet a été modifié le il y a 1 année et 5 mois par HugoApproved.
    #2254189
    Perspika
    Participant
    Padawan WordPress
    52 contributions

    Bonsoir,

    Dans ton administration, as-tu vérifié dans Réglages -> Lecture ?
    Tout en bas, il faut décocher la case « Demander aux moteurs de recherche de ne pas indexer ce site. »

    C’est peut-être simplement ça…

    #2254220
    HugoApproved
    Participant
    Initié WordPress
    13 contributions

    Hello Perspika,

    Il me semble que cette case concerne les robots.txt et non le noindex si je ne dis pas de bêtises ? Dans tous les cas elle est décochée, donc non ça ne peut pas être ça :/

    #2254325
    Flobogo
    Modérateur
    Maître WordPress
    16256 contributions

    Bonjour,


    @perspika
    : non, ce n’est pas cette case, mais l’explication est dans le même coin


    @hugoapproved
    : dans Réglages généraux, voir adresse URL du site et adresse où WordPress est installé. (quelque chose comme ça)
    Vous êtes chez OVH, et vous avez sans doute pris l’installation en un clic. Ça donne souvent ce résultat.

    #2254401
    HugoApproved
    Participant
    Initié WordPress
    13 contributions

    @flobogo C’est effectivement le cas pour l’installation en 1 clic, cependant dans ce menu il y a bien les paramètres que vous avez mentionnés, mais ils sont remplis correctement et l’adresse web du site correspond à l’adresse web de WordPress, qui eux 2 correspondent à mon site.

    Que dois-je modifier pour corriger ça svp ? Je n’ai toujours pas trouvé la moindre trace de noindex dans une quelconque page… Et pourtant à chaque recherche Web de mon site il est indiqué que ce dernier n’autorise pas l’indexation :/

    #2254593
    Flobogo
    Modérateur
    Maître WordPress
    16256 contributions

    Oups, désolée, je suis partie sur une erreur au départ : j’avais lu trop vite, et j’ai cru que vous aviez /index/ dans vos URL. (problème fréquent dans les install’ en un clic chez OVH)

    Désactivez votre extension All in One WP Sécurité, il y a peut-être un mauvais réglages. Et vérifiez également les réglages dans Yoast.

    Si ça ne change rien d’ici 8 à 15 jours (il faut du temps), il faudra poster dans un forum spécialisé SEO.

    #2255087
    HugoApproved
    Participant
    Initié WordPress
    13 contributions

    Hello Flobogo,

    Effectivement après 2-3 manips sur Yoast j’ai trouvé la raison : des cases demandant de ne pas indexer les auteurs ! Curieusement cela n’indexait pas aussi les pages…

    Merci beaucoup pour votre aide 🙂

    #2255175
    HugoApproved
    Participant
    Initié WordPress
    13 contributions

    Hello,

    Je relance le sujet car malgré tout il reste du noindex après avoir checké entièrement tous les paramètres et plugins de mon site…

    Quand je teste via la search console, ce message d’erreur s’affiche : noindex détecté dans l’en-tête HTTP X-Robots-Tag

    Je n’ai aucune idée de ce que peut être ceci…

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2255178
    ferman
    Participant
    Maître WordPress
    2790 contributions

    Bonjour,

    J’ai le même plugin sécurité (AIOWPS), qui fonctionne très bien. Cependant, dedans il y a une option parefeu>bots internet: “bloquer les faux googlebots”.  Je ne sais pas si elle est activée chez vous mais elle a été reportée comme pouvant poser problème .    (bloquant aussi les vrais googlebots).

    Regardez aussi ici et là. Peut être aussi une mauvaise interaction entre YOAST et AIOWPS. Je n’utilise pas YOAST mais il me semble que le paramétrage peut être assez compliqué et sujet à erreurs . Il y a des “advanced meta robots settings” voir  ici.

    • Cette réponse a été modifiée le il y a 1 année et 5 mois par ferman.
    • Cette réponse a été modifiée le il y a 1 année et 5 mois par ferman. Raison: Complément d'information
    • Cette réponse a été modifiée le il y a 1 année et 5 mois par ferman.
    #2255220
    HugoApproved
    Participant
    Initié WordPress
    13 contributions

    Merci de votre réponse, ça aurait pu être la raison mais à mon arrivée la case était déjà décochée, concernant Yoast j’ai dû repasser sur toutes les options au moins 10 fois ^^ Tout ce qui pourrait être sujet au noindex est enlevé, malgré tout il semblerait que sur certaines pages (pas toutes) il y en ait encore pour une raison inconnue…

    #2255342
    Flobogo
    Modérateur
    Maître WordPress
    16256 contributions

    Comme je vous l’ai dit, il faut aussi du temps pour que tout le site soit ré-indexé. Il n’y a qu’un jour ou deux que vous avez modifié les réglages, donc maintenant, un peu de patience 😉

    #2255449
    HugoApproved
    Participant
    Initié WordPress
    13 contributions

    Je vais être patient, les pages où il reste du noindex doivent être des pages de fonctionnement, sinon j’ai fait un tour sur le code ça a l’air d’être ok 😉 Merci à tous pour votre aide 🙂

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.