Enlever le “category/”

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 22)
  • Auteur
    Messages
  • #456479
    carlito
    Participant
    Initié WordPress
    32 contributions

    Bonjour et bonne année à tous!

    C’est mon premier post!

    Passons à la questions!

    Je viens d’installer WP, tout est jolis magnifique….
    Par contre je n’aime pas du tout le fait que mes catégories subissent le rajout d’un sous dossier : category/

    Y a t’il une solution pour y rémédier?
    Merci d’avance à tous!

    #618668
    Charlie_WA
    Participant
    Initié WordPress
    34 contributions

    oui il y a un plugin pour ca

    de mémoire il s’appelle less je crois

    #618669
    bertimus
    Participant
    Initié WordPress
    19 contributions

    Hello,

    Ecoute Charlie, j’ai bien peur que ta mémoire flanche :D : ce n’est pas Less mais Top Level Categories 😉

    Sinon, de mon côté, j’ai appliqué une solution toute simple et la voici :

    Tu vas dans wp-includes/category-template.php

    Tu ajoutes $catlink=str_replace(“category/”,””,$catlink); avant
    $catlink = str_replace(‘%category%’,$category_nicename, $catlink);

    Et voilà, le tour est joué, enjoy 🍺

    Bertrand

    #618670
    Rod
    Membre
    Maître WordPress
    744 contributions
    bertimus wrote:
    Hello,

    Ecoute Charlie, j’ai bien peur que ta mémoire flanche :D : ce n’est pas Less mais Top Level Categories 😉

    Sinon, de mon côté, j’ai appliqué une solution toute simple et la voici :

    Tu vas dans wp-includes/category-template.php

    Tu ajoutes $catlink=str_replace(“category/”,””,$catlink); avant
    $catlink = str_replace(‘%category%’,$category_nicename, $catlink);

    Et voilà, le tour est joué, enjoy 🍺

    Bertrand

    hum ? c’est sur à 100% ton truc la ? 🙂

    #618671
    bertimus
    Participant
    Initié WordPress
    19 contributions

    Ben essaie-le, tu verras bien :D [La réponse est “Oui”]

    Au pire, t’auras juste une ligne à retirer, ou encore un simple clic sur “Précédent” 😉

    #618672
    tampons encreurs
    Membre
    Initié WordPress
    47 contributions

    Une autre solution serait d’utiliser le plugin générique Redirection et de le configurer convenablement pour redirriger les pages web des catégories. Mais les solutions suscitées sont problablement meilleures, car plus faciles à mettre en oeuvre, et probablement moins problématiques à l’usage. Attention tout de même aux homonymes, à savoir quand une catégorie et un article ou une page ont la même URL…

    #618673
    damino
    Participant
    Maître WordPress
    1243 contributions

    Mauvais forum … je déplace :fouet:

    #618675
    Rflx
    Membre
    Chevalier WordPress
    208 contributions
    bertimus wrote:
    Hello,

    Ecoute Charlie, j’ai bien peur que ta mémoire flanche :D : ce n’est pas Less mais Top Level Categories 😉

    Sinon, de mon côté, j’ai appliqué une solution toute simple et la voici :

    Tu vas dans wp-includes/category-template.php

    Tu ajoutes $catlink=str_replace(“category/”,””,$catlink); avant
    $catlink = str_replace(‘%category%’,$category_nicename, $catlink);

    Et voilà, le tour est joué, enjoy 🍺

    Bertrand

    Bertrand lover 🙂 !

    Merci beaucoup 🙂 !

    #618674
    bertimus
    Participant
    Initié WordPress
    19 contributions

    Mais you’re welcome 😉

    [@ Rod : et une première preuve que ça marche :D]

    #618676
    Monky
    Membre
    Padawan WordPress
    94 contributions

    Bonjour,

    Cette astuce ne semble pas convenir au thème Mimbo.. les liens sur les pages n’affichent plus le category/ mais lorsque je veux afficher cette page j’ai une erreur 404. Je ne connais pas très bien l’URL Rewriting mais y-a-t-il une règle simple à ajouter dans le .htaccess ?

    #618677
    carlito
    Participant
    Initié WordPress
    32 contributions

    HS :
    J’étais au ski ce week end!
    Donc je viens de voir vos réponses seulement maintenant.

    Merci à tous pour vos réponses c’est vraiment sympa la communauté WP!

    #618678
    carlito
    Participant
    Initié WordPress
    32 contributions
    Monky wrote:
    Bonjour,

    Cette astuce ne semble pas convenir au thème Mimbo.. les liens sur les pages n’affichent plus le category/ mais lorsque je veux afficher cette page j’ai une erreur 404. Je ne connais pas très bien l’URL Rewriting mais y-a-t-il une règle simple à ajouter dans le .htaccess ?

    J’ai le meme problème!

    #618679
    carlito
    Participant
    Initié WordPress
    32 contributions

    J’ai utilisé le plugin cité plus tot : Top Level Categories

    Le problème c’est qu’il ne peut marcher dans mon cas ( je suis en /%postname%/):

    Known Issues

    This plugin will not work if you are using a permalink structure that is only the post name (i.e. /%postname%/ in the options). This is because it creates an ambiguous situation where both categories and individual posts end up with the same URLs. To fix this (if you don’t mind switching your post URLs), switch permalink structure to one of the built-in settings (like Date and Name Based).

    #618680
    carlito
    Participant
    Initié WordPress
    32 contributions

    A priori dans la dernière version du plugin c’est sensé marché avec juste %postname% :

    Will now work correctly with the /%category%/%postname% and %postname% permalink structures (this was the top request)”

    Ce n’était tjr pas mon cas et d’apres les commentaires il fallait faire ca :

    /%category%/%postname%.html

    and change the category base to be:

    /category

    Ce que j’ai fait bien sur!
    Résultat :
    c’est parfait quand je clique sur une catégorie je n’ai plus le dossier inutile
    par contre j’ai désormais le nom de la catégorie dans chaque post!

    Donc je tourne tjr en rond!

    #618681
    Lyricis
    Membre
    Initié WordPress
    4 contributions
    bertimus wrote:
    Hello,

    Ecoute Charlie, j’ai bien peur que ta mémoire flanche :D : ce n’est pas Less mais Top Level Categories 😉

    Sinon, de mon côté, j’ai appliqué une solution toute simple et la voici :

    Tu vas dans wp-includes/category-template.php

    Tu ajoutes $catlink=str_replace(“category/”,””,$catlink); avant
    $catlink = str_replace(‘%category%’,$category_nicename, $catlink);

    Et voilà, le tour est joué, enjoy 🍺

    Bertrand

    Je viens de tomber sur cette solution qui m’as sauvé la vie, quand j’allai dans les catégories je tombé sur une erreur 404 exemple : http://www.lyricis.fr/category/cinema-dvd-serie/

    Donc avec ce code j’ai remplacé par http://www.lyricis.fr/cinema-dvd-serie/

    Donc merci !

    Par contre quelqu’un saurait me dire pourquoi j’ai une erreur 404 avec la structure des catégories par défaut ? (http://www.lyricis.fr/category/cinema-dvd-serie/)

15 sujets de 1 à 15 (sur un total de 22)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.