Editeur visuel, où est-il? (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 35)
  • Auteur
    Messages
  • #447397
    dean
    Participant
    Chevalier WordPress
    487 contributions

    Bonjour

    J’ai beau chercher sur les deux sites wp, je ne trouve pas de réponse à mon problème 😕 :

    Je n’arrive plus à voir l’éditeur visuel dans la page d’écriture, il me semblait que l’on pouvait l’activer/désactiver dans les options d’écriture ( en cochant ‘Les utilisateurs doivent utiliser l?éditeur visueli par défaut’), mais ça ne change rien pour moi.
    J’ai testé le plugin EditorMonkey, qui a l’air pas mal, mais je trouve quelques disfonctionnement…

    Je suppose que ce problème a déja été posé, mais je calle!!
    En attendant je fais du html, mais c’est pas pratique

    Merci de votre aide. 🙂

    #572628
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    L’option se trouve dans ton profil utilisateur, tout en bas à gauche… une simple case à cocher ou décocher. 😉

    #572629
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Au pire dans la base de donnée : dans la table wp_usermeta
    met true à ton utiliseur pour le champ “rich_editing true”

    #572630
    dean
    Participant
    Chevalier WordPress
    487 contributions

    Merci c’est cool !

    #572631
    dean
    Participant
    Chevalier WordPress
    487 contributions

    J’ai fais les deux test, ça ne marche toujours pas, j’ai forcé la fonction dans admin-functions.php, toujour rien, je me demande si c’est un conflit de plugin, pourtant j’ai tout désactivé pour voir, mais sans résultats.
    Quand je refais une install de wp sur un autre site, tout est ok avec l’éditeur, ça ne vient donc pas de mon navigateur…
    ça commence à m’agacer, bon je me sauve, le petit se réveille ( il a la varicelle! pas de bol…:()

    ++
    Dean

    #572632
    dean
    Participant
    Chevalier WordPress
    487 contributions

    wpbug.jpg

    #572633
    cisjoc
    Participant
    Initié WordPress
    6 contributions

    Salut Dean,
    Est-ce que t’as résolu ton problème d’éditeur, comment t’as fait finalement pour avoir cette page d’édition (copie d’écran), je n’arrive pas non plus à l’avoir.
    A+

    #572634
    dean
    Participant
    Chevalier WordPress
    487 contributions
    cisjoc wrote:
    Salut Dean,
    Est-ce que t’as résolu ton problème d’éditeur, comment t’as fait finalement pour avoir cette page d’édition (copie d’écran), je n’arrive pas non plus à l’avoir.
    A+

    Désolé, je n’ai pas avancé …, mais je vais me mettre à chercher dans le forum anglais ce soir, sinon je plongerais dans le code ( ça ne me plait pas trop, mais bon ! )
    Je te tiens au courant dés que j’y arrive

    Dean

    #572635
    aspirantemarmotte
    Participant
    Initié WordPress
    15 contributions

    Je ne sais pas si ça peut vous être utile, mais bon, avec Safari l’éditeur visuel ne fonctionne pas alors qu’il fonctionne très bien avec la dernière version de Firefox pour mac.
    En ce qui concerne les PC, je ne sais pas.
    Désolée ^^,

    #572636
    dean
    Participant
    Chevalier WordPress
    487 contributions

    Toujours pas trouvé…, je vais utiliser EditorMonkey, il est braiment bien comme editeur ( plugin ), si ça marche, je ferais une traduction française.

    Dean

    #572637
    dean
    Participant
    Chevalier WordPress
    487 contributions

    Ok, mon problème est partiellement résolu, j’ai trouvé un meilleur éditeur de texte que celui mis par défaut pour wordpress.
    Je vous le recommande car il est vraiment plus complet

    nom du plugin : editormonkey

    site:
    http://www.rajprasad.net/plugins/editormonkey
    Lien de téléchargement de la dernière version ( 2.4.1 )
    http://www.rajprasad.net/files/editormonkey-2.4.1.zip

    La barre fckeditor ne fonctionne pas pour moi
    il faut utiliser TinyMCE

    Pour que les options couleur et taille du texte fonctionne il faut activer:
    use a custom valid_elements list from Options
    et ajouter dans la liste les tags suivant:
    font[face|color|size],
    voir le sujet suivant pour des explications:
    http://forums.rajprasad.net/viewtopic.php?t=31&highlight=color+colour

    compatibles avec:
    Internet Explorer 5.5+, Mozilla/Firefox, Safari, Opera 9.0 alpha/newer

    ça marche nickel pour moi
    Je ferais une traduction plus tard
    ++
    Dean

    #572638
    codfingers
    Participant
    Maître WordPress
    541 contributions

    je viens d’installer editormonkey et lordsque je clique sur options> editormonkey j’obtiens ce message d’erreur :
    The requested URL /wordpress/wp-admin/editormonkey-compat.php was not found on this server.

    que faire ? 😉

    #572639
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Le probleme de ce plugins, ce que l’on ne peut pas remodier ces billets ensuite avec l’éditeur visuel si je me souviens bien ^^

    La barre fckeditor ne fonctionne pas pour moi
    il faut utiliser TinyMCE

    => Logique vu qu FCKeditor n’est pas installé sous WP par défaut ^^

    #572640
    dean
    Participant
    Chevalier WordPress
    487 contributions
    codfingers wrote:
    The requested URL /wordpress/wp-admin/editormonkey-compat.php was not found on this server.

    bizarre, ce fichier dervrait être dans le dossier plugin… 😕 essais d’activer l’autre editormonkey ( il y en a deux, le editormonkey-compat.php est pour ceux qui ont des problèmes de compatibilité php )

    #572641
    codfingers
    Participant
    Maître WordPress
    541 contributions

    les deux sont activés

15 sujets de 1 à 15 (sur un total de 35)
  • Vous devez être connecté pour répondre à ce sujet.