Editeur visuel ne fonctionne plus

  • Statut : non résolu
10 sujets de 16 à 25 (sur un total de 25)
  • Auteur
    Messages
  • #1041259
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Pour importer ds tables, il faut d’abord supprimer les existantes !
    N’oubliez pas de faire des sauvegardes !

    #1041260
    Sinistros
    Membre
    Initié WordPress
    17 contributions

    Oui, j’ai été bête de ne pas supprimer les tables avant -_-‘

    Je viens de faire l’import et… Ca refait le bug.
    Je pense que je vais devoir me passer d’import et refaire tout mon contenu.

    #1041261
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Essayez d’importer table par table, en terminant par wp_posts et wp-postmeta, cela permettra de cibler le problème.

    #1041262
    Sinistros
    Membre
    Initié WordPress
    17 contributions

    Bien bien bien.

    Après moulte tests, je me suis rendu compte que c’était la table wp_options qui posait problème.

    J’importe tout sauf celle là que je garde en version neuve. Ok j’ai mon contenu, ça fonctionne.

    Là je me suis rendu compte que je n’avais pas le bon Site et Home que j’avais mis auparavant sur mon ancienne version. Je fais le changement. Ca refait le bug de l’éditeur. Problème ciblé

    Par défaut le Site et le Home sont « http:/localhost/wordpress »
    Moi je voulais le faire tout en relatif pour pouvoir montrer momentanément l’avancée du site à distance via mon ip publique. Ca fonctionnait.

    Du coup en garde mon http:/localhost/wordpress mon site fonctionne mais j’aurais aimé que ce soit relatif pour plus de flexibilité. .. Mais je ne suis pas sûr que ce soit possible.
    Quand je voudrai montrer mon site j’irai modifier le localhost dans les options et j’y mettrai mon ip public en dur.

    Voilà voilà, ce fut bien rigolo comme problème (non je rigole, c’était bien chiant hein :p)

    Merci beaucoup pour l’aide 🙂

    #1041263
    luciole135
    Participant
    Maître WordPress
    13753 contributions
    Sinistros wrote:
    Là je me suis rendu compte que je n’avais pas le bon Site et Home que j’avais mis auparavant sur mon ancienne version. Je fais le changement. Ca refait le bug de l’éditeur. Problème ciblé

    Par défaut le Site et le Home sont « http:/localhost/wordpress »
    Moi je voulais le faire tout en relatif pour pouvoir montrer momentanément l’avancée du site à distance via mon ip publique. Ca fonctionnait.

    Je n’ai pas compris.

    #1041264
    Sinistros
    Membre
    Initié WordPress
    17 contributions

    Disons que voici les paramètres par défaut du site et qui fonctionnent
    2386932016013000h4652.jpg

    J’avais modifié en « /wordpress » sur les 2 champs.
    De cette façon pour accéder à mon site je faisais soit :
    lcoalhost/wordpress/index.php

    soit ippublique/wordpress/index.php en ayant modifié dans le httpd.conf de Apache l’adresse du site.

    Ca m’évitait d’avoir à modifier les 2 champs pour changer l’adresse dans la BDD à chaque fois.

    #1041265
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Dans la table wp_options, à mon avis il y a un script js qui se charge et crée ce problème.

    Avec phpMyAdmin, dans l’onglet SQL exécutez cette requête :
    SELECT * FROM wp_options WHERE option_value LIKE ‘%<script%';
    SELECT * FROM wp_options WHERE option_value LIKE ‘%<noscript%';

    #1041266
    Sinistros
    Membre
    Initié WordPress
    17 contributions

    Non, ça n’a pas l’air d’être ça.
    Mysql retourne un résultat vide dans tous les cas

    #1041267
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Vérifiez s’il ne reste pas des options de vieux plugins dont vous ne vous servez plus et supprimez-les !

    #1041268
    Sinistros
    Membre
    Initié WordPress
    17 contributions

    Non ben je n’arrive pas à faire en sorte que ça fonctionne avec l’ip publique. Heuresement il y a teamviewer pour dépanner mais ce n’est pas la solution la plus propre ^^

    Enfin bon, l’important c’est que ça fonctionne 😉

10 sujets de 16 à 25 (sur un total de 25)
  • Vous devez être connecté pour répondre à ce sujet.