[Résolu] Echec installation des nouvelles extensions (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2422572
    Freedom
    Participant
    Initié WordPress
    18 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8.1
    • Thème utilisé : OCEAN WP child
    • Extensions en place : Elementor – PAY PAL – Pixel yoursite – Yoast SEO  (extensions activés)
    • Nom de l’hébergeur : ouvaton.coop
    • Adresse du site : http://www.ammazen.com

    Problème(s) rencontré(s) :

    Bonjour,

    Impossible d’installer des nouvelles extensions

    Message d’erreur : : Une erreur critique est survenue sur ce site. Veuillez consulter la boite de réception de l’e-mail d’administration de votre site pour plus d’informations.. voir pièce jointe.

    En plus le plus étonnant  est que je ne reçois pas de e-mail d’administration.

    Merci pour ce que vous pouvez faire .

    Belle journée  à vous

    Freedom

    #2422647
    momofr@free.fr
    Modérateur
    Maître WordPress
    5265 contributions

    Salut, sujet largement débattu déjà, tu es confronté à un conflit d’extension certainement.

    Il faut suivre la procédure classique de débogage via FTP en renommant le dossier des plugins, etc.

    Tu as des explications sur cet article de Kinsta.

    Je regarderais l’extension Pixel yoursite qui doit poser problème, j’ai des pelletés de sites avec les 3 autres extensions sans rencontrer de problème.

    #2422724
    Freedom
    Participant
    Initié WordPress
    18 contributions

    Bonjour Momofr@free.fr,

    Merci de ta réponse.

    J’ai fais les manip suivantes :

    -J’ai renommé le dossier plugins,  et essayé d’installe l’extension WPforms sans succès < Echec d’installation

    -J’ai remis l’ancienne version php mysql à 7.4 je l’avais passé à 8.1 et ré-essayé d’installer l’extension > Echec d’installation

    Par ailleurs l’extension pixel yoursite est toujours désactivé, si  tu  <b><i>soupçonnes cette extension, tu penses qu’il faut la supprimer complètement ?
    </i></b><i>
    </i><i>Merci
    Freedom</i>

    #2422731
    momofr@free.fr
    Modérateur
    Maître WordPress
    5265 contributions

    Salut, quel est exactement le message d’échec ?

    Tu as bien un nouveau dossier plugins dans le dossier wp-content ?

    On désactive temporairement le dossier des extensions, je ne sais pas exactement ce que tu fais ou as fait.

    #2422736
    Freedom
    Participant
    Initié WordPress
    18 contributions

    Salut,
    le problème est résolu.
    J’ai pu installé WP Forms  quelques minutes après avoir passé php à version antérieur 7.4  sans supprimer pixel yoursite.
    Merci pour l’aide 😊

    Bon week end

    Freedom

    #2422852
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    Bonjour,

    Par contre, vous devriez passer le site en HTTPS.

    #2422891
    Freedom
    Participant
    Initié WordPress
    18 contributions

    Bonjour Flobogo,

    Merci pour le conseil de passer le site en HTTPS j’y pense toujours mais je ne sais comment le faire. pouvez-vous m’orienter SVP ?

    Merci

    Freedom

    #2422961
    momofr@free.fr
    Modérateur
    Maître WordPress
    5265 contributions

    Salut, tu as déjà ton certificat d’activé sur ton hébergement, il te suffit de changer les URL du site dans les réglages de WordPress pour : https://ammazen.com/

    #2422991
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    il te suffit de changer les URL du site dans les réglages de WordPress

    Euh non … ça ne suffit pas ! Il faut changer toutes les URL, en installant au préalable l’extension Better Search Replace pour modifier « en direct » toutes les URL, ou utiliser le script d’Interconnectit comme expliqué ici.

    #2422993
    momofr@free.fr
    Modérateur
    Maître WordPress
    5265 contributions

    Salut, @Flobogo, en général ça suffit, après si tu utilises des extensions de galerie, de diaporama, un constructeur de page comme Elementor il peut y avoir besoin de changer les URL en dur dans la base de données c’est vrai.

    Pour le site cité, j’ai mis en HTTPs et ça se passe bien.

    #2423003
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    Pour l’instant, les 2 versions HTTP et HTTPS co-existent. Mais sur la version HTTPS, il y a des images avec le lien encore en HTTP. Voir sur cette page en cliquant sur la 1ère photo dans la sidebar (formation professionnelle …)

    #2423083
    Freedom
    Participant
    Initié WordPress
    18 contributions

    Bonjour Mono et Flobogo !

    Merci pour vos contributions.

    Suite à cela j’ai été dans réglage wordpress et j’ai ajouté un « s » après http (voir pièce jointe ) est-ce que c’est que tu voulais dire momo ?

    Pour Flobogo :  j’ai ajouté aussi un « s » dans l’URL >  Voir sur cette page en cliquant sur la 1ère photo dans la sidebar (formation professionnelle …) Est-ce que le problème est résolu comme çà ou est ce que j’ai besoin  toujours d’installer  au préalable l’extension Better Search Replace pour modifier « en direct » toutes les URL, ou utiliser le script d’Interconnectit comme expliqué ici. ?

    Merci pour votre soutien

    Freedom

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2423130
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    C’est corrigé pour les photos, mais les 2 versions HTTP et HTTPS co-existent toujours, seule la page d’accueil est redirigée du HTTP vers HTTPS.
    En clair : si on tape l’adresse en HTTP du site, on arrive sur l’accueil en HTTPS, mais si on tape l’URL d’une autre page – ou si on enlève le S dans la barre adresse – , elle reste en HTTP.

    C’est donc juste une redirection à mettre en place. En passant par FTP (Filezilla) ou par le gestionnaire de fichiers de votre hébergeur, accédez au fichier .htaccess situé à la racine de l’installation (là où il y a les 3 dossiers wp-admin / wp-content / wp-includes). Téléchargez une sauvegarde de ce fichier pour l’avoir en sécurité sur votre ordi. Puis ouvrez-le fichier en direct, et ajoutez ces lignes à la suite de ce qui s’y trouve déjà :
    Attention : dans ce code, remplacez chaque monsite.com par votre URL 😉

    # Redirection vers HTTPS 
    RewriteCond %{SERVER_PORT} ^80$ [OR]
    RewriteCond %{HTTPS} =off
    RewriteRule ^(.*)$ https://www.monsite.com/$1 [R=301,L]
    
    # Redirection du non-www vers www en HTTPS
    RewriteCond %{HTTP_HOST} ^monsite.com [NC]
    RewriteRule ^(.*)$ https://www.monsite.com/$1 [R=301,L]
    redirection HTTP vers HTTPS et avec www

    (tuto source)

    Vérifiez si tout fonctionne bien : enlevez le S dans une URL autre que l’accueil, rafraichissez la page, vous verrez.
    En cas de plantage, remettez le fichier .htaccess précédent en place, c’est qu’il y a une erreur quelque part …

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.