[Résolu] E-mail non reçu côté vendeur après validation de commande par le client (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
  • Ce sujet contient 20 réponses, 5 participants et a été mis à jour pour la dernière fois par Li-An, le il y a 19 secondes.
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #2364182
    Shazalove
    Participant
    Initié WordPress
    32 contributions

    Bonjour,

    Il est de coutume en cette période de l’année de se souhaiter de… joyeuses fêtes ! Hum…

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4
    • Thème utilisé : Avada
    • Extensions en place : WooCommerce, Autoptimize, WP Optimize, Contact Form 7, Cookie Notice, MailPoet, Yoast SEO
    • Nom de l’hébergeur : Planethoster
    • Adresse du site : https://www.fermesaintyves.fr

    Problème(s) rencontré(s) : 

    Bon, depuis une semaine j’ai un petit ennui avec WooCommerce. Lorsqu’un client valide sa commande, nous recevons un e-mail de confirmation de commande, ce qui nous permet de notre côté de préparer la commande du client. Or, depuis quelques jours, nous ne recevons plus cette notification. L’hébergeur est catégorique : les e-mails sont correctements délivrés, le problème est probablement lié à WooCommerce.

    Malgré la désactivation/réactivation du plugin, ou le vidage des caches Autoptimize / WP Optimize, le problème persiste… Si l’un·e d’entre vous rencontre ce souci — ou l’a déjà rencontré et est parvenu à le solutionner —, n’hésitez pas !

    Par avance, merci bien. La situtation actuelle est déjà périlleuse pour notre activité, donc on aimerait que tout rentre dans l’ordre rapidement… pour ce qui est de notre boutique en tout cas. Pour le reste, « qui vivra verra » comme on dit 😉

    Kler

    #2364268
    momofr@free.fr
    Modérateur
    Maître WordPress
    4078 contributions

    Salut, tu ne sembles pas le seul dans ce cas. L’e-mail admin WooCommerce est-il lié au domaine de la boutique ?

    Si jamais tu as mis une adresse Gmail cela peut être un souci chez Google qui semble avoir resserré les règles d’accès à ses services SMTP.

    #2364273
    Li-An
    Modérateur
    Maître WordPress
    24867 contributions

    Bonjour, est-ce que vous recevez bien un email lorsque vous créez un utilisateur fictif ?

    #2364285
    Shazalove
    Participant
    Initié WordPress
    32 contributions

    Bonjour et merci pour vos retours !

    Pour te répondre Li-An : oui, je reçois bien un e-mail lorsque je créé un utilisateur fictif.

    Momo, ton hypothèse coïncide avec les préconisations que j’ai reçues de mon hébergeur au sujet de la redirection vers Gmail. L’e-mail admin WooCommerce est en effet lié au domaine de la boutique, mais les courriels sont redirigés vers une adresse Gmail. Nous sommes donc revenus au webmail classique, sans redirection.

    Il semble que certains messages nous parviennent désormais correctement, mais j’attends toujour de recevoir le mail indiquant qu’une commande vient d’être passée. Hélas… l’attente me semble un peu longue. Je reviens vers vous dès que j’y voie un peu plus clair.

    • Cette réponse a été modifiée le il y a 3 mois et 2 semaines par Shazalove. Raison: Contrairement à ce que nous pensions, c'est pas tout à fait résolu en fait…
    #2364342
    Rock4Temps
    Participant
    Chevalier WordPress
    298 contributions

    Bonjour,

    Même problème avec Gmail, le passage en webmail classique m’a
    encore causé des problèmes de délivrabilité parce que la fonction
    wp_mail() de PHP ne crée pas d’en tête lors d’envoi d’E-mail.
    Ainsi certains serveurs de messagerie peuvent considérer ces mails comme des Spam.

    Un peu de code dans le fichier functions.php de mon thème enfant a résolu mon problème

    /* WordPress utilise la fonction wp_mail()de PHP pour l'envoi d'E-mail sans préciser d'en tête.
       On utilise le hook 'phpmailer_init' pour que «l'expéditeur» (chemin de retour) soit le même que l'adresse «De» 
       */
    
    add_action( 'phpmailer_init', 'fix_my_email_return_path' );
     
    function fix_my_email_return_path( $phpmailer ) {
        $phpmailer->Sender = $phpmailer->From;
    }

    #2364351
    Li-An
    Modérateur
    Maître WordPress
    24867 contributions

    L’utilisation d’un service SMTP est fortement recommandé pour optimiser la réception des mails. Il y a de nombreuses extensions pour cela.

    #2364477
    Shazalove
    Participant
    Initié WordPress
    32 contributions

    Bonjour,


    @Li-An
    : en avez-vous un à me proposer en particulier ?


    @Rock4Temps
    : merci pour votre aide mais cela n’a rien changé au problème que nous rencontrons.

    Je suis étonné parce que le site est en ligne depuis deux ans et nous n’avions jamais rencontré ce problème. Selon l’historique de nos courriels, le bug semble être apparu vers le 10 décembre, ce qui correspond à-peu-près à la mise à jour de WordPress 5.6 (selon mes souvenirs).

    Bon, en attendant, les commandes apparaissent correctement dans l’interface d’administration donc nous pouvons en prendre connaissance par ce biais, mais cela implique d’y être connecté en permanence.

    #2364482
    Li-An
    Modérateur
    Maître WordPress
    24867 contributions

    Vous prenez un de ceux-là, tant qu’il est à jour et populaire https://fr.wordpress.org/plugins/search/smtp/. Le concept est le même pour tous. Il y a peu de chance que votre problème soit lié à la mise à jour parce qu’à ma connaissance il n’y a pas eu de changement au niveau des mails générés par WP.

    Il faudrait faire des tests avec les autres extensions désactivées et un thème par défaut pour voir si il n’y a pas d’interaction malheureuse (en laissant une extension de maintenance pour vos visiteurs).

    #2364483
    momofr@free.fr
    Modérateur
    Maître WordPress
    4078 contributions

    Salut, j’ai plusieurs clients qui ont une boutique sous WooCommerce et pas de problème particulier pour les notifications avec WP 5.6.

    Tout est à jour (Woo en 4.8) ?

    #2364854
    Shazalove
    Participant
    Initié WordPress
    32 contributions

    Bonjour,

    Merci pour votre aide. Tout est à jour. C’est un principe auquel je ne déroge jamais : toujours tenir à jour WordPress, les thèmes et les extensions. J’ai refait de nombreux tests, dont certains avec l’hébergeur. Eux n’ont aucune réponse pertinente à m’apporter, même si je ne suis pas persuadé que le problème ne soit pas de leur fait.

    À ce jour, toujours pas de solution, l’extension SMTP n’ayant malheureusement rien résolu.

    #2364856
    Li-An
    Modérateur
    Maître WordPress
    24867 contributions

    Vous avez donc fait les tests en désactivant tout – sauf ce qui est nécessaire aux tests ?

    #2365074
    Shazalove
    Participant
    Initié WordPress
    32 contributions

    Bonjour,

    Nous avons installé une autre extension SMTP. Nous avons reçu le test d’envoi du formulaire ! En revanche, cela n’a rien changé concernant les e-mails WooCommerce que nous ne recevons toujours pas…

    #2365098
    Li-An
    Modérateur
    Maître WordPress
    24867 contributions

    On a fait un peu le tour là (si vous avez fait le test de tout désactiver avant les tests). À moins de changer d’hébergeur, je ne sais pas trop quoi vous conseiller. Peut-être que quelqu’un aura une autre idée.

    Voilà une liste de tests à réaliser (j’ignorais que l’on pouvait désactiver manuellement l’envoi de ces mails) https://www.mailpoet.com/blog/woocommerce-email-not-sending/

    #2365107
    Shazalove
    Participant
    Initié WordPress
    32 contributions

    Ah ah ! @Li-An, vous êtes un ange ! Je ne vous fait pas la bise mais le cœur y est 😉

    Votre liste de tests à réaliser m’a permis de régler le problème ! En effet, il s’avère que MailPoet, lors de l’installation, écrase le système de délivérabilité des e-mails WordPress pour le remplacer par le sien. Or, il semble que leurs paramètrages de signature d’email SPF et DKIM entraient en conflit avec ceux de notre domaine chez l’hébergeur…

    Ça peut sembler un peu abscons dit comme ça, mais la solution que j’ai appliquée, la voici : installer WP Mail SMTP de WP-Forms, puis dans les options de MailPoet, onglet Avancés, désactiver la méthode d’envoi par défaut (MailPoet Sending Service) et préférer la méthode par défaut de WordPress. De toute façon, dans notre cas, nous n’envoyons pas des tonnes de newsletters à nos client·es.

    #2365108
    Li-An
    Modérateur
    Maître WordPress
    24867 contributions

    Merci pour l’explication. C’est bon à savoir pour PlanetHoster. Reste à ne pas l’oublier 🙂

15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.