Dysfonctionnement enregistrement page ou post WordPress multisite multilangues

  • WordPress :5.0.3
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2247706
    Dams
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP 5.4.45 et MySQL 5.5.56
    • Thème utilisé : custom
    • Extensions en place : WPBakery Page Builder, WPGlobus Plus et Yoast SEO (principalement)
    • Adresse du site : www.staphyt.com

    Problème(s) rencontré(s) :,

    J’ai récemment mis à jour le site de notre société (multisite) avec les dernières versions de WordPress ainsi que les différents plugins. Nous avons 2 langues par pages et posts (EN/FR). Cependant, il se produit un dysfonctionnement empêchant l’enregistrement des 2 langues. Lors de l’ajout ou l’édition, les 2 encarts de contenu principal EN/FR s’affichent sur une même page et lors de la sauvegarde, uniquement l’enregistrement en EN se produit. Avez-vous déjà rencontré ce problème ?

    J’ai trouvé d’autres utilisateurs ayant le problème un peu similaire, ils ont désactivé YOAST SEO et apparemment, l’enregistrement fonctionne. Cependant, je n’ose le faire de peur en le désactivant de perdre le contenu rempli..

    Cordialement,

    #2247943
    Flobogo
    Modérateur
    Maître WordPress
    15345 contributions

    Bonjour,

    Vous êtes vraiment sur une installation multisites ? C’est un fonctionnement spécifique, et si c’est le cas, il faut poster dans la rubrique adaptée.

    Sinon, vous voulez juste dire que votre site (unique) existe sous les 2 langues ? Dans ce cas, il faudrait nous dire comment est géré ce multilinguisme : sans doute une extension, mais laquelle ??

    peur en le désactivant de perdre le contenu rempli.

    Non, le contenu est dans le base de données (2 tables spécifiques pour Yoast), donc vous ne perdez rien en désactivant et réactivant ensuite. Par contre, il ne faut pas supprimer l’extension, sinon en effet, vous risquez de perdre vos paramètres, même en cas de réinstallation future.

    #2247964
    Dams
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    D’abord, merci pour votre retour et la réponse à mes questions.

    Concernant le sujet, je l’ai posté ici puisque je pense que le problème vient d’une extension ou d’un plugin .. avec toutes les possibilités, pas facile de faire un choix … !

    Pour les différentes langues, l’extension « WPGlobus » est utilisé. Pour compléter cette extension, il y a « WPGlobus for WPBakery Visual Composer » et « WPGlobus Plus » (avec une licence active) :

    • WPGlobus : plugin WordPress Globalisation / Multilingue pour les articles, pages, menus, widgets et même champs personnalisés, dans différentes langues
    • WPGlobus for WPBakery Visual Composer : pour compléter le builder WPBakery VC avec WPGlobus
    • WPGlobus Plus : enregistrer des traductions incomplètes en tant que «brouillons», traduire des URL («slugs» post / page), personnaliser la disposition du sélecteur de langue de menu, etc.

    Je vais continuer mes tests (tenter de désactiver YOAST SEO, etc), et je partagerais avec grand plaisir la résolution de ce problème si cela peut servir à d’autres !

    Damien

    • Cette réponse a été modifiée le il y a 2 mois et 3 weeks par  Dams.
    #2248084
    Flobogo
    Modérateur
    Maître WordPress
    15345 contributions

    OK,mais je n’ai pas la réponse à la question : vous êtes sur un vrai multi-sites, ou vous gérer un seul site avec 2 langues grâce à vos extensions ?

    En tous cas, vos extensions de langues / traductions sont des extensions payantes. Donc là, il va falloir vous tourner vers leur support.

    #2248412
    Dams
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Il s’agit bien d’un multi-site (le principal, 2 sous-domaines et un domaine externe) avec 2 langues grâce à l’extension WPGlobus sauf pour le domaine externe.

    Je viens de voir une mise à jour pour WPGlobus ce matin avec un message : « Error: This plugin requires a newer version of PHP. Click here to learn more about updating PHP. ».

    Je vais donc finaliser la mise à jour mon hébergeur.. Sinon, je me tournerais vers le support de l’extension!

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.