[Résolu] DUPLICATION SITE E-COMMERCE (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
  • Ce sujet contient 4 réponses, 3 participants et a été mis à jour pour la dernière fois par Alex_Vurp, le il y a 2 mois.
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2400763
    Alex_Vurp
    Participant
    Initié WordPress
    16 contributions

    Bonjour à tous !

    J’espère que vous allez bien ?

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8.0
    • Thème utilisé : Astra Pro
    • Extensions en place : Elementor/WooCommerce/SeoPress/Redirection
    • Nom de l’hébergeur : O2Switch
    • Adresse du site : https://leregardfrancais.fr

    Comme l’indique mon intitulé, j’ai besoin de vos retours de professionnels !

    Le contexte :
    Mon site internet e-commerce sur WooCommerce est en PLS. Il rame très fortement et après différentes analyses et tests, avec notamment un dev très calé (à qui je n’ai pas encore posé la question mais je vais le faire de ce pas), il apparaît évident de faire une refonte. Le problème est beaucoup plus profond, probablement à l’installation… Je suis donc en pleine rédaction du CDC.

    Le problème :
    Nous devons lancer un produit (des box) le 14 juin avec auparavant une mois et demi de récolte et de chauffe de leads, via landing pages et emails. Impossible de repousser le lancement.

    Ma question :
    Quelle est la meilleure solution selon vous et pourquoi ?

    Les solutions :

    1. Créer un sous-domaine avec une homepage, une petite page de présentation de la marque et une page e-commerce avec les box (avec un Woocommerce d’installé). De façon à ce que les clients puissent passer commande malgré tout sans avoir un site qui rame énormément.
    2. Garder notre site de base au risque d’avoir un taux de conversion en chute libre dû à la mauvaise expérience sur le site.
    3. Dupliquer mon site, le faire sur un sous-domaine avec un gros plan de redirection (459 URL) de façon à ce que ça soit « propre » le temps que la refonte se fasse et bien évidemment ajouter les box sur ce nouveau site. Et si c’est pour vous la meilleure solution, est-ce que vous pensez que c’est long ou pas ? Je ne pense pas mais j’oublie peut-être des choses. J’ai déjà dupliqué des sites pour faire des tests en interne.
      Je précise que je ne suis pas un professionnel, plutôt un passionné qui apprend tous les jours, je suis donc ouvert à toutes vos suggestions et autres propositions !

    Merci d’avance pour votre temps 😀
    Alex

    • Ce sujet a été modifié le il y a 2 mois par Alex_Vurp.
    #2400767
    Lumiere de Lune
    Participant
    Maître WordPress
    20321 contributions

    J’avoue que j’ai du mal à comprendre « problème à l’installation ».

    Quels sont les problèmes actuellement identifiés ? Pourquoi ne pas avoir mis en place un plugin de cache ? Est ce que le serveur fait la compression Gzip ? Même s’il y a des choses à améliorer, « tout refaire » ou « tout dupliquer » me semble un peu overkill (surtout que même avec des redirections, ça impacte le référencement).

    Le moins pire, en tout cas, serait le sous domaine dédié aux produits concernés

    #2400769
    Alex_Vurp
    Participant
    Initié WordPress
    16 contributions

    Merci pour ton retour Lumière de Lune !

    Je vais déjà mettre ce qui a été fait par mon dev :

    • Sauvegarde ext du site
    • Réglage de l’heure du wordpress idem heure serveur.
    • Activation sur le serveur du module LiteSpeed+ (désactivé par la suite, le site n’avançait absolument plus)
    • Activation du module « imagick » sur apache, fortement conseillé par wordpress
    • Installation du module LiteSpeed+ sur le wordpress (idem, désactivé)
    • Paramétrage et test du module
    • Traitement des 1042 images par Quic.CLOUD
    • Suppression du module en doublon (Advanced database Cleaner car déjà présent avec LiteSpeed+)
    • Nettoyage de la base de données et optimisation des tables
    • Mise en place des entêtes sécurisées, dans le .htaccess
    • Activation de la génération de fichier CSS directement sur Astra
    • Désactivation du chargement des fonts localement

    Malgré tout ça, ça n’a rien changé…
    Et j’ai eu beau tester tous les plugins de cache possible et imaginable cela ne changeait rien. Avec Litespeed, j’avais des résultats incroyable sur PageSpeed Insight et GTMetrix mais mon back office n’avançait pas mais alors pas du tout ! De plus, parfois, les pages chargeaient à la vitesse de l’éclair et d’un coup, la page mettait bien 10 bonnes secondes (voir plus) à charger…

    Je prends note de ta solution pour le sous-domaine dédié aux boxs !

    #2400913
    mathieu42
    Participant
    Maître WordPress
    1210 contributions

    si vous avez besoin de votre site pour les nouveaux clients des 2 prochains mois, je pense qu’il vaut mieux ne pas le modifier en profondeur d’ici là.

    je vous conseille de mettre le site sur un hébergement plus puissant pendant ces 2 mois. et en parallèle, vous pourrez travailler sur la nouvelle version du site et attendre le mois de juillet pour mettre cette nouvelle version en production.

    #2400918
    Alex_Vurp
    Participant
    Initié WordPress
    16 contributions

    Hello Mathieu !

    Merci pour ton retour.

    Du coup, j’ai trouvé une solution un peu similaire à ce que tu proposes, j’ai mis en place une solution de cache payante et assez puissante. Ça s’appelle NitroPack et j’avoue que je suis assez bluffé. Je suis encore en phase de « tests » puisque le site s’optimise page par page avec l’outil mais ça a l’air de faire totalement le taff, sauf le back office, mais ce n’est pas le plus important.

    Je pense que je vais clôturer le sujet, merci encore !

    Alex

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.