dotclear 2 vers wordpress 4.9 ? (Créer un compte)

  • WordPress :4.9.8
  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2230391
    damien3000
    Participant
    Initié WordPress
    15 contributions

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7
    • Thème utilisé : divi
    • Extensions en place : écosystème divi
    • Nom de l’hébergeur : ovh
    • Adresse du site : en cours

    bonjour,

    l’idée de basculer un vieux blog sous dotclear, en place depuis une dizaine d’années, toujours utilisé mais techniquement désuet, vers un wp tout neuf… mais voilà, les passerelles que je trouve (comme le plugin dotclear to wp) ne fonctionnent plus, et les bases de données ne sont pas si simple à modifier pour les rendre compatibles (d’autant que je ne suis pas technicien), je ne sais pas comment faire.

    quelqu’un a une idée ?

    merci,

    damien

     

     

    #2230433
    Li-An
    Modérateur
    Maître WordPress
    24345 contributions

    Bonjour, le plus simple c’est d’installer une version de WP compatible avec l’extension (liste ici https://fr.wordpress.org/download/releases/) et ensuite mettre à jour soit d’un seul coup soit étape par étape WP 4.2 » WP 4.2 … » WP 4.9 en envoyant les fichiers par FTP et en vérifiant que tout marche à chaque étape.

    #2230598
    damien3000
    Participant
    Initié WordPress
    15 contributions

    hello,

    merci pour la piste, c’est ce que je me disais au début – j’ai donc installé wp 4.0 (la dernière version de wp qui est censée avoir été testée avec l’extension dc > wp), mais pas mieux, impossible de faire l’import, il ne se passe rien.

    je suis bien ennuyé, il y a 1500 billets à importer, je ne me vois pas faire ça à coup de copier-coller !

    en faisant des recherches je suis tombé sur ça : https://cms2cms.com/cms/supported-cms/dotclear-to-wordpress-migration/ – ils annoncent pouvoir faire la conversion pour qq dizaines d’euros, ce qui est cher pour faire tourner un script, mais tellement de temps gagné si ça fonctionne que j’hésite… enfin j’hésite surtout parce que je ne voudrais pas que ça soit un fake.

    un avis ? (je vois qu’il y a des utilisateurs mitigés : https://www.capterra.com/p/132067/CMS2CMS/ )

    damien

     

    #2230691
    Li-An
    Modérateur
    Maître WordPress
    24345 contributions

    Il n’y a pas de raison que ça ne marche pas. Essayez de passer le php en 5.6

    #2230726
    damien3000
    Participant
    Initié WordPress
    15 contributions

    c’était une excellente idée, mais raté – j’ai essayé en 5.4 (la plus vieille autorisée) puis en 5.6, mais dans les deux cas, il y a un progrès, mais ça échoue.

    le progrès c’est que le plugin ‘répond’, contrairement à avant : avant, il donnait l’impression de lancer l’import, mais rien n’arrivait – là, quasi instantanément, il propose des étapes où dit avoir importé les catégories, puis les utilisateurs, etc., mais en fait à chaque étape il n’importe rien, 0 articles ou quoi que ce soit.

    donc pour l’instant merci, mais pas mieux.

    #2230733
    Li-An
    Modérateur
    Maître WordPress
    24345 contributions

    C’est donc bien un problème lié à la version de php.

    #2230734
    Li-An
    Modérateur
    Maître WordPress
    24345 contributions

    Vous avez regardé là https://archive.courtine.org/2010/07/05/migrer-de-dotclear-a-wordpress/ puis là http://www.digitaladventures.fr/realisations/import-export-dotclear2-wordpress2/ ?

    #2230754
    damien3000
    Participant
    Initié WordPress
    15 contributions

    digitaladventures : après installation d’un wp 2.8 (sinon pas de compatibilité), échec de l’import, que des 0 partout, comme plus haut.

    courtine : bon sang ! j’avais complètement oublié que je suis déjà passé par là pour, déjà, un passage de dc2 vers wp en 2016 ! maintenant je m’en souviens et la preuve, le dernier commentaire est de moi ! ce n’est pas beau l’absence de mémoire…

    et ça avait fonctionné à l’époque, mais là, échec, sans que je comprenne pourquoi : j’ai même réessayé en mettant un wp4.5.1, avec ou sans le petit tweak proposé par l’article, celui que je validais, mais rien, que des 0 imports.

    bizarre, à croire que c’est la base de donnée dc qui est construite autrement pour ce blog, qui pourtant doit dater à peu près de la même époque que celui de 2016.

    j’ai même regardé là : https://wpfr.net/support/sujet/import-dotclear-par-fichier-texte/ mais les liens de téléchargement de script ne fonctionnent plus.

    je sèche…

     

    • Cette réponse a été modifiée le il y a 1 année et 9 mois par damien3000.
    #2230756
    Li-An
    Modérateur
    Maître WordPress
    24345 contributions

    Je ne peux guère vous aider plus.

    #2230759
    damien3000
    Participant
    Initié WordPress
    15 contributions

    c’était déjà bien aimable, merci beaucoup.

    si je trouve une solution, je l’ajouterai ici…

    #2248761
    sweedymick
    Participant
    Initié WordPress
    2 contributions

    Bonjour, je me demandais si vous voyez des erreurs de logs PHP lorsque le script d’import plante ?

    #2248795
    damien3000
    Participant
    Initié WordPress
    15 contributions

    non, aucune erreur de ce type indiquée, il n’y a juste pas d’import – dans le cas en question, sans solution technique il a été décidé de faire la migration ‘à la main’, uniquement des billets les plus pertinents… travail de bénédictin, mais il fallait bien avancer.

    #2248840
    sweedymick
    Participant
    Initié WordPress
    2 contributions

    Peut-être que les logs n’étaient pas activés dans PHP ? (Fonction error_reporting avec le paramètre E_ALL).

    Parfois les grands changements sont aussi l’occasion de repartir de neuf, et de ne garder que l’essentiel. Vous avez donc peut-être fait le bon choix au final 🙂

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.