[Résolu] Disparition d’extensions dans le tableau de bord (Créer un compte)

  • WordPress :4.7
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #1642897
    alex83270
    Participant
    Chevalier WordPress
    200 contributions

    Bonjour,

    Ma configuration WP actuelle

    • /! VERSION WORDPRESS :  4.8
    • Version de PHP/MySQL : 5.6
    • Thème utilisé : Sydney
    • Extensions en place :
      • Contact Form 7
      • Custom Smilies
      • Event-Calendar-WD
      • Members
      • Search & Filter
      • Shortcodes-Ultimate
      • TablePress
      • Uber-Login-Logo
      • Ultimate Member
      • WP-Content-Copy-Protector & No Right Click
      • WP-Mail-Logging
      • WP-Maintenance-Mode
      • WP-Mail-SMTP

     

     

     

    Problème(s) rencontré(s) :

    Après une semaine de travail pour créer ce petit site, je pensais avoir fini mais non… il me reste plusieurs petits souci et celui qui m’embête le plus c’est que j’ai certaines extensions qui ont disparu du jour au lendemain sans prévenir et sans avoir avoir (normalement) changer les fichiers WordPress et installer de nouvelles extensions entre temps.

    Les extensions concernées sont : Members et TablePress, celui qui m’embête le plus c’est TablePress car je ne peux plus gérer mes tableaux maintenant 🙁

     

    J’ai essayé de désactiver toutes les extensions et de laisser activer que ces deux la, pensant qu’il y avait probablement un conflit, mais non.

     

    Et je n’ai pas modifier, normalement, les fichiers WordPress sauf pour le CSS de mon site, et pour ajouter l’extension “Search & Filter” dans les archives et articles.

     

    Comment faire ? Est-ce à cause de la 4.8 ?
    Si je passe en 4.7 est ce que je perds tout ce que j’ai fait ? Ou simplement les modifications manuelles que j’ai faites dans les deux lignes du dessus ?

    Cordialement,
    Alexis

    #1642916
    alex83270
    Participant
    Chevalier WordPress
    200 contributions

    Petit up
    _____________________________________

    J’ai remarqué que ma page d’accueil avait été éjecter aussi… du coup je me demande si on m’a pas piraté.

    Pourtant les membres non vérifier n’ont accès à rien du tout :/ Et j’en avais un qui avait un email et un nom un peu bizarre :

    user_login: micaelasn
    first_name: micaelasn
    last_name: micaelasn
    user_email: (édit modération pour supprimer le mail)

    #1642973
    Flobogo
    Modérateur
    Maître WordPress
    16256 contributions

    Bonjour,

    J’ai remarqué que ma page d’accueil avait été éjectée aussi

    –> C’est à dire ? Votre site est visible, alors c’est quoi le problème ?

    Pourtant les membres non vérifier n’ont accès à rien du tout

    –> dans ce cas, supprimez la possibilité de s’inscrire (dans les réglages généraux) si ça ne sert à rien sur votre site. Si c’est nécessaire par la suite, installez une extension de captcha pour empêcher les robots de s’inscrire.

    je me demande si on m’a pas piraté

    –> dans votre liste d’utilisateurs, quel rôle a ce membre-mystère (micaelasn) ? Évidemment, si il est admin’, ça pose problème !!

    –> Tout simplement, est-ce que vous ne vous seriez pas connecté avec un compte abonné ? Quand vous êtes connecté, avez-vous le rôle admin’ ?

    #1642998
    alex83270
    Participant
    Chevalier WordPress
    200 contributions

    Bonjour,

    déjà merci d’avoir pris du temps pour me répondre.

    Du coup je vais vous répondre point par point.

    J’ai remarqué que ma page d’accueil avait été éjectée aussi

    => C’est à dire ? Votre site est visible, alors c’est quoi le problème ?

    Ben, quand on se connecter sur mon site, même si il était visible, on tombait sur les archives et pour les voir il faut un rôle qui permet de voir les archives/catégories/articles.

    Pourtant les membres non vérifier n’ont accès à rien du tout

    => dans ce cas, supprimez la possibilité de s’inscrire (dans les réglages généraux) si ça ne sert à rien sur votre site. Si c’est nécessaire par la suite, installez une extension de captcha pour empêcher les robots de s’inscrire.

    En fait, comme je le disais les membres non vérifiés n’ont accès à rien du tout sauf aux commentaires pour certaines zones.
    En fait j’ai créer une communauté, sur le site tout le monde peut s’inscrire de base, et les personnes qui sont effectivement membre de la communauté voient leur grade changer. Il passe de membre à membre +, qui leur permet d’utiliser notre calendrier, de commenter plus de zones, de voir notre documentation “privée” et de créer des articles.

    je me demande si on m’a pas piraté

    => dans votre liste d’utilisateurs, quel rôle a ce membre-mystère (micaelasn) ? Évidemment, si il est admin’, ça pose problème !!

    => Tout simplement, est-ce que vous ne vous seriez pas connecté avec un compte abonné ? Quand vous êtes connecté, avez-vous le rôle admin’ ?

    Alors Mr Micaelasn est membre, après je ne m’y connais pas trop, je suis un simple utilisateur de WordPress depuis 2013 qui apprend en autodidacte ce qu’il a besoin. Après je suis un peu parano, mais une fois on m’a delete mon site en étant simple membre.

    Question pas bête, mais je n’étais pas en compte abonné. Mais effectivement, vous m’ouvrez une voie que je vais de ce pas vérifier….

    *En attente, je vous met une musique pas très jolie et stressante pendant 15min avec appel surtaxé de 15e la seconde (besoin de blé moi)*

    Alors, j’avais changé mon grade, j’étais en WTH!Creator, qui devait être l’équivalent d’administrateur car j’y avais mis tout les droits. Peut-être j’ai ajouté des extensions après l’extension “Member” et j’ai oublié de mettre à jour les grades tout simplement.

    En tout cas merci beaucoup pour votre intervention ! Grâce à vous j’ai pût trouver le problème, une erreur de grade.

    Après reste cette histoire de page d’accueil supprimé, bizarre bizarre ! Simple coïncidence probablement, mais content car j’étais en train de tester en local mon site sur la version 4.7.5, ça m’évitera de tout refaire !

    Bonne soirée !

    #1643017
    Flobogo
    Modérateur
    Maître WordPress
    16256 contributions

    Super si vous avez trouvé. J’ai pensé à ça parce que vous n’aviez plus les extensions dans l’admin’, mais j’avais quand même un doute puisque vous pouviez voir la liste d’utilisateurs.

    Quant à la page d’accueil, vous l’avez peut-être modifiée quand vous aviez l’autre statut, ou vous accès à un contenu différent selon votre rôle sur le site. Parfois, c’est utile de visiter son site sans être connecté comme admin’ 😉

     

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.