diaporama flash (Créer un compte)

  • Statut : non résolu
15 sujets de 16 à 30 (sur un total de 40)
  • Auteur
    Messages
  • #637836
    tom2
    Membre
    Padawan WordPress
    93 contributions

    J’ avais déjà fait ça au tout début et je viens d’ aller vérifier et cela ne semble pas avoir changer et malheureusement cela ne semble pas fonctionner !:(

    #637840
    Olivier
    Participant
    Maître WordPress
    1415 contributions

    Alors repasse sur le thème par défaut déjà pour voir si cela marche. Je soupçonne un pb avec ton theme…

    #637841
    tom2
    Membre
    Padawan WordPress
    93 contributions

    ben la houais ça fonctionne avec le thème par defaut, il faudrait que je change de thème ?

    #637842
    Olivier
    Participant
    Maître WordPress
    1415 contributions

    Non il faut corriger ton second theme, regarde le code de l’index.php dans ton theme par défaut et change dans ton autre theme ce qui est différent, cela doit être au niveau de la boucle de l’affichage des posts.

    #637824
    tom2
    Membre
    Padawan WordPress
    93 contributions

    le soucis c’ est que je n’ y connais rien au PHP, juste l’ html et le css et encore !:rolleyes:
    si tu pouvais me filer un coup de main pour corriger le problème se serait cool, je te laisse l’ index PHP du thème par défaut et celui que j’ utilise pour mon blog, si tu veux bien :
    index.PHP du thème par défaut :

    <div class="post" id="post-“>

    <a href="” rel=”bookmark” title=”Lien permanent vers “>

    <!– par –>

    Introuvable

    Désolé, mais vous cherchez quelque chose qui ne se trouve pas ici .

    index.PHP du theme que j’ utilise :

    <!–

    –>

    désolé je fais un peu :boulet: pour le coup !

    #637843
    Olivier
    Participant
    Maître WordPress
    1415 contributions

    Mais non tu ne fais pas boulet, nous sommes tous passés par là 😉

    Donc dans le theme que tu utilises, déjà mets en commentaires :

    <!–
    –>

    Puis tu mets à la place :

    
        
            

    Cela devrait déjà aller mieux 😉
    Dis moi ce que cela donne…

    #637844
    tom2
    Membre
    Padawan WordPress
    93 contributions

    si je comprend bien il faut mettre les commentaires

    puis en remplacant la ligne 6 dans le code de mon thème à savoir la ligne :
    par

    Mais si je fais cela je me retrouve avec :
    Parse error: syntax error, unexpected $end in /mnt/104/sda/e/b/noelnad/wp-content/themes/nouveaudesign/index.php on line 42

    #637845
    Olivier
    Participant
    Maître WordPress
    1415 contributions

    Ok my fault, j’ai oublié le

    #637846
    tom2
    Membre
    Padawan WordPress
    93 contributions

    Je mets les ligne ci-dessous mais encore une erreur (Parse error: syntax error, unexpected $end in /mnt/104/sda/e/b/noelnad/wp-content/themes/nouveaudesign/index.php on line 50)

    <!–
    –>

    #637847
    Olivier
    Participant
    Maître WordPress
    1415 contributions

    euh le endwhile, il faut le mettre après le while, si tu fermes la boucle avant de l’ouvrir, ça peut pas marcher 😉

    #637848
    Olivier
    Participant
    Maître WordPress
    1415 contributions

    euh le endwhile, il faut le mettre après le while, si tu fermes la boucle avant de l’ouvrir, ça peut pas marcher 😉

    #637849
    tom2
    Membre
    Padawan WordPress
    93 contributions

    Je ne connais pas du tout le PHP avec les boucles et compagnie, j’ suis désolé, j’ ai collé le code de cette manière :
    <!–
    –>


    mais un problème persiste : Parse error: syntax error, unexpected T_ENDWHILE in /mnt/104/sda/e/b/noelnad/wp-content/themes/nouveaudesign/index.php on line 38

    #637850
    Olivier
    Participant
    Maître WordPress
    1415 contributions

    Alors, il faut que tu colles ça entre le while et le endwhile :

    <!–

    –>

    Tu dégages le endwhile en trop :

    Et normalement, cela devrait aller mieux. La règle est d’avoir une endwhile pour un while, le endwhile fermant la boucle du while…

    #637851
    tom2
    Membre
    Padawan WordPress
    93 contributions

    bon ben j’ ai essayé de suivre le truc mais ça fonctionne toujours pas : Parse error: syntax error, unexpected T_ENDWHILE in /mnt/104/sda/e/b/noelnad/wp-content/themes/nouveaudesign/index.php on line 34

    Alors je te file l’ intégral de l’ index.php et si tu peux me faire simplement un copié collé du php qui te semble fonctionner se sera plus simple pour moi, je patauge complet !😉

    <!–
    –>

    <!–

    –>

    <!–

    –>

    #637852
    Olivier
    Participant
    Maître WordPress
    1415 contributions

    Voilà 🙂

    <!–

    –>

    Introuvable

    Désolé, mais vous cherchez quelque chose qui ne se trouve pas ici .

    Si ça marche, tu as le droit de faire un lien vers mon blog 😉

15 sujets de 16 à 30 (sur un total de 40)
  • Vous devez être connecté pour répondre à ce sujet.