Désactiver « Lire la suite » ?

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #461479
    Z@@m
    Membre
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.5
    – Thème utilisé : Cutline 3-Column Split fr 1.1
    – Plugins en place : aucun
    – Nom de l’hebergeur : ovh
    – Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour,
    j’aimerais savoir s’il existe un moyen d’afficher directement l’intégralité d’un article, sans voir apparaître « lire la suite » systématiquement.
    Merci de vos lumières. 💡

    #638915
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    Il suffit dans le fichier index.php d’afficher de remplacer the_excerpt() par the_content()

    #638916
    Z@@m
    Membre
    Initié WordPress
    5 contributions

    Merci beaucoup pour ta réponse.
    Je suis allé jeter un oeil à mon index.php, et voilà ce que j’y ai trouvé :

    C’est grave, docteur ?
    En fait, j’ai déjà le « the_content » que tu mentionnais dans ton post, non ?

    Y a-t-il donc un moyen de faire disparaître ce « Lire la suite » ?
    (Peut-être en ne gardant que « ?php the_content() » )?

    Merci encore (à toutes et tous).

    #638917
    Gzyg
    Participant
    Chevalier WordPress
    150 contributions

    Normalement tes articles ne sont séparés que si tu l’indiques explicitement en insérant la balise , non ?
    Sans cette balise, c’est l’article entier qui s’affiche… donc sans le « lire la suite ».
    C’est en tout cas le comportement par défaut sur mon WP 2.6 ainsi que sur le 2.5…

    (En même temps, je découvre WP, j’ai peut-être loupé quelque chose…)

    #638918
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    (Peut-être en ne gardant que « ?php the_content() » )?

    Tout à fait.

    #638919
    Z@@m
    Membre
    Initié WordPress
    5 contributions

    Merci à vous deux d’avoir essayé de me dépatouiller.

    @ Gzyg : en fait, « normalement » ça devrait marcher … Mais non ! :(
    @ BenKenobi : j’ai donc enlevé le ‘[Lire la suite →]’ incriminé, vidé le cache, rechargé la page, une autre, d’autres …. Rien n’y fait !

    @ tous : cela pourrait-il être dû au thème choisi (Cutline 3-Column Split fr 1.1) ?

    Pour avoir une idée :
    le site de la ville de Tourbes.

    Merci à celles et ceux qui se creusent là-dessus !

    #638920
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    En fait, le problème se pose dans les pages de catégorie, donc il faut surement remplacer the_excerpt par the_content dans le fichier archive.php

    #638921
    Z@@m
    Membre
    Initié WordPress
    5 contributions

    Merci infiniment BenKenobi, c’est déjà beaucoup mieux ainsi !

    Cependant (si je puis me permettre), le « lire la suite » reste présent en bas du billet.
    J’ai donc essayé de le sortir de :
    index.php
    page.php
    single.php

    Il s’accroche !!!!
    N’aurais-je pas suffisamment fouiné ?

    #638922
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    archives.php archive.php category.php 🙂 (et author.php pendant qu’on y est)

    #638923
    Techni
    Membre
    Initié WordPress
    8 contributions

    J’ai un peu le même problème, mais dans l’autre sens…

    Depuis WP 2.6 (je crois), si je choisis d’afficher le texte complet dans le flux RSS, il n’est plus coupé à la balise .

    Vous allez me dire de sélectionner l’extrait, mais la fonction the_excerpt() n’affiche pas en HTML, juste en texte brut.

    Je veux le texte en HTML, mais coupé à . Une idée?
    Cette fonction the_content() est assez mystérieuse pour moi! Parfois elle affiche le début, et parfois la totalité. 😕

    #638924
    Gzyg
    Participant
    Chevalier WordPress
    150 contributions

    C’est bizarre, quand même… chez moi (encore en local, j’espère mettre en ligne dans la semaine) en 2.6 ça fonctionne impeccable (pas encore testé le flux RSS).

    Une page en anglais qui explique le comportement de cette balise (je m’en suis servi pour afficher la totalité du post après avoir cliqué sur « more ») :
    http://codex.wordpress.org/Customizing_the_Read_More

    #638925
    Z@@m
    Membre
    Initié WordPress
    5 contributions

    Merci encore à toutes et tous d’avoir tenté de trouver la solution.

    Pour l’instant, je me contente du « plus » appporté par BenKenobi, en attendant de fouiller un peu plus loin pour enfin le faire disparaître définitivement (enfin, pas tout à fait, parce que j’aimerais quand même le voir apparaître si je décide d’utiliser la balise « more »).

    Well, voili !
    @ bientôt pour de nouvelles aventures !

    #2231304
    GROUT123
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    <b>Ma configuration WP actuelle : </b>
    <b>– Version de WordPress</b> : 4.9.8
    <b>– Thème utilisé</b> : Materialis
    <b>– Plugins en place</b> : Elementor
    <b>– Nom de l’hebergeur</b> : ovh

    Bonjour du coup même problème je n’arrive pas à supprimer le fameux « lire la suite » en bas de mes articles sur la page d’accueil… J’ai essayer les solutions proposer ci dessus mais impossible de trouver le fameux : the_excerpt() dans mon index….

    Help me please :'(

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.