J’ai détruit: wp-content/themes/generatepress/footer.php Comment le mettre ? (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #2393596
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    Bonjour,

    Ma configuration WP actuelle :
    – Version de WordPress : 5.7.5
    – Version de PHP/MySQL : 7.4.25 / 5.6.50
    – Thème utilisé : GeneratePress
    – Thème URI : https://generatepress.com
    – Extensions en place : Advanced Editor Tools (previously TinyMCE Advanced) (5.6.0), Akismet Anti-Spam (4.2.1), Anti-Malware Security and Brute-Force Firewall (4.20.92), AntiVirus (1.4.3), Broken Link Checker (1.11.16), Classic Editor (1.6.2), Content Aware Sidebars (3.17), Embed Plus Plugin for YouTube, with YouTube Gallery, Channel, Playlist, Live Stream, Facade (14.0.1.3), Forum_wordpress_fr (4.2), MP3-jPlayer (2.7.3), Really Simple SSL (5.2.2), WP-ShowHide (1.04)
    – Adresse du site : https://cours-particuliers-de-danse.com
    – Nom de l’hébergeur : Apache

     

    Problème(s) rencontré(s) :

    Suite au sujet précédent, j’ai téléchargé divers antivirus et réussi à trouver le virus qui se trouvait dans :

    generate press/footer.php

    Le problème semble résolu au niveau du virus, mais suite à une mauvaise manipulation j’ai détruit dans file zilla :

    footer.php

    Mon site affiche :

    <b>Deprecated</b>: Thème sans footer.php est obsolète depuis la version 3.0.0, aucune alternative n’est disponible. Veuillez inclure un modèle de footer.php à votre thème. in <b>/home/courspar/www/wp-includes/functions.php</b> on

    Je pense que c’est plus facile à résoudre que le virus.

    Merci de votre aide

     

    • Ce sujet a été modifié le il y a 4 mois par EQUANIME.
    #2393634
    PhiLyon
    Modérateur
    Maître WordPress
    28277 contributions

    Bonjour.

    Télécharges le thème, dézippes-le et par ftp renvoies le fichier footer.php.

    🙂

    #2393644
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    Merci de votre réponse…

    Mais je vais vous paraître idiot, j’ai repris le ftp d’avant le virus et j’ai essayé de « l’envoyer » à la place de l’autre par Fille Zilla mais il ne veut pas…

    Y a-t-il un moyen de le rajouter ? Ça serait génial….

    Comment je peux télécharger le thème ?

    Par avance merci.

    Cordialement.

    R. Brunaux

    #2393645
    PhiLyon
    Modérateur
    Maître WordPress
    28277 contributions
    #2393646
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    J’ai téléchargé le thème et j’ai le footer.php…et j’ai l’ancien aussi…

    #2393647
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    J’ai envoyé le footer.php du nouveau théme, il a bien voulu mais il me fait une page avec un gros carré noir et ce message :

    <b>Deprecated</b>: Required parameter $track follows optional parameter $js in <b>/home/courspar/www/wp-content/plugins/mp3-jplayer/template-functions.php</b> on line <b>62</b>

    #2393648
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    J’ai désactivé jplayer le site est normal… Mais j’ai plus jplayer…

    #2393649
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    Lorsque je réactive jplayer, j’ai à nouveau le message

    #2393651
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    J’ai repris le footer de la sauvegarde et enlever le script du virus et obtient le même message… ?

    #2393652
    PhiLyon
    Modérateur
    Maître WordPress
    28277 contributions

    Cette extension n’es plus mise à jour depuis deux ans, elle n’est compatible que jusqu’à la version 5.0.15 de WordPress https://wordpress.org/plugins/mp3-jplayer/

    Il va falloir en trouver une autre, regardes ici https://wordpress.org/plugins/search/mp3+player/

    🙂

    #2393653
    pasglop
    Participant
    Chevalier WordPress
    437 contributions

    En même temps, MP3-jplayer n’est pas été testé avec un WP > 5.0.15, et tu as la version WP 5.7.5. D’ailleurs, WP va passer en 5.9 dans très peu de temps…

    #2393659
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    Ok il faut que je change de player… Pas un ptit boulot…

    J’ai désinstallé wp-optimiz et essayé de réinstaller mais ça ne marche pas, je sais que c’est un autre sujet, mais je recevais plein de mail de WordPress me disant que mon site avait un problème.

    Connaissez-vous un autre optimiseur compatible ?

    #2393664
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    Autre problème : lorsque je vais sur une page; j’ai ce message :
    <h1>Not Found</h1>
    The requested URL was not found on this server.

    #2393665
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    Au secours pluq aucun lien ne fonctionne.

    #2393667
    EQUANIME
    Participant
    Chevalier WordPress
    230 contributions

    Tous les liens sont morts sauf la page d’accueil.

15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.