Deconnexion intempestive de la base de données (Créer un compte)

  • WordPress :5.5
  • Statut : non résolu
  • Ce sujet contient 15 réponses, 4 participants et a été mis à jour pour la dernière fois par wrey75, le il y a 2 jours.
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #2365016
    ungars
    Participant
    Chevalier WordPress
    248 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3 / 5.5.53
    • Thème utilisé : One Press
    • Extensions en place : Woocommerce, Fame Theme demo importer, Wp Form Lite
    • Nom de l’hébergeur : Online.net
    • Adresse du site : http://www.casperland.net/ventoux-1910

    Bonjour, je développe un site actuellement sur une url provisoire : http://www.casperland.net/ventoux-1910

    Je constate que par moment il y a des problèmes de connexions à la base de données comme deux fois ce soir : https://www.cjoint.com/c/KAgt7LzQvBd puis https://www.cjoint.com/c/KAgukG4eIQd (mais aussi plus tard dans la soirée) .

    Si je réactualise la page, le site s’ affiche normalement, jusqu’ à la prochaine erreur de ce type.

    Souvent, quand cela arrive, le site rame.

    Je n’ ai pas eu ce problème de la journée, ce soir cela n’ arrête pas.

    Wp config est bien renseigné, je ne pense pas que le problème vienne de la, sinon le site ne fonctionnerait pas du tout.

    J’ ai contacté mon hebergeur, qui m’ assure que le problème ne vient pas d’ eux, je veux bien les croire, j’ ai d’ autres sites chez eux qui fonctionne sans problème.

    J’ ai fait une recherche, mais je n’ ai pas trouvé de problèmes semblables au mien.

    Je vous remercie par avance pour votre aide, bonne soirée.

     

     

     

     

    #2365032
    Li-An
    Modérateur
    Maître WordPress
    24646 contributions

    Bonjour, c’est un problème relatif à votre hébergement. Contactez votre hébergeur.

    #2365132
    ungars
    Participant
    Chevalier WordPress
    248 contributions

    Bonjour, je vous remercie de votre réponse. J’ ai déjà ouvert un ticket, je vais revoir avec eux, je vous tiens au courant. Bonne soirée.

    #2365168
    ungars
    Participant
    Chevalier WordPress
    248 contributions

    Bonjour, j’ ai eu ce matin encore un problème de connexion avec ma base de données, mais le message d’ erreur est différent :https://www.cjoint.com/c/KAij3xU56dd

    Le message original : https://www.cjoint.com/c/KAgt7LzQvBd

     

    Je pense que cela dépend si je suis connecté ou non en tant qu’ admin, mais il me semble bien que dans tous les cas j’ y étais.

     

    Je vous remercie.

     

     

     

    #2365170
    wrey75
    Participant
    Initié WordPress
    28 contributions

    Bonjour,

    Il y a un gros problème: si je me connecte sur http://casperland.net/, je peux créer un nouveau site WordPress: http://casperland.net/steff/wp-admin/install.php

    Cela va poser un gros problème. Et la sécurité de votre installation semble compromise si vous n’intervenez pas rapidement (je peux créer un nouveau site WordPress et prendre la main sur “ventoux-2019”).

    Il y a soit un problème de compréhension, soit une mauvaise installation. En plus vous n’avez pas de HTTPS pour protéger votre site. Si vous connaissez mal WordPress, utilisez les services d’un hébergeur auto géré comme slithyweb.com (je conseille celui-ci car il gère tous mes sites).

    Sinon, voyez avec votre hébergeur.

    #2365190
    Li-An
    Modérateur
    Maître WordPress
    24646 contributions

    En résumé, changez rapidement d’hébergeur. C’est catastrophique…

    #2365198
    ungars
    Participant
    Chevalier WordPress
    248 contributions

    Bonjour,

    Je vous remercie de vos réponse.

    J’ avais oublié de retirer le fichier install.php, c’ est une faute de ma part, je viens de le faire. Et j’ ai regardé les sites que j’ ai créé, j’ en avais oublié un aussi. Donc merci de me l’ avoir signalé, j’ ai eu beaucoup de chance que de personnes moins honnêtes fassent ce qu’ elles veulent.

    Pour le https, c’ est une url qui me sert d’ url provisoire quand je fais des sites pour des connaissances, après je le transfert vers leur nom de domaine. Donc il est vrai que je ne l’ avais jamais mis en https, je vais le faire ce soir.

    Maintenant, ce problème de sécurité ne viendrait il pas plutôt de ma part, car j’ ai oublié de retiré ce fichier install ?

     

    Je suis toujours en contact avec online, qui me conseille de vérifier le contenu de config.php, mais s’ il était mal renseigné (adresse de la base de données, identifiant, mot de passe), mon site ne fonctionnerait pas du tout ? En plus ils me demandent de le vérifier via phpmyadmin, je le fais habituellement via mon client ftp, je ne vois pas trop ce qu’ ils veulent me faire faire…

    Il est clair que si cela continue, j’ irais me renseigner vers d’ autres hébergeur.

    Merci encore du coup de main.

     

    M

    #2365237
    Li-An
    Modérateur
    Maître WordPress
    24646 contributions

    En effet la possibilité d’installation sauvage était probablement lié à ce fichier install.php résiduel (je me demandais d’ailleurs comment c’était possible).

    Vous avez raison, c’est bien via le fichier que l’on récupère par FTP. Aucune possibilité de voir ça via phpMyAdmin ou alors il voulait peut-être dire via la console d’admin de l’hébergement, certains hébergeurs proposent des outils FTP.

    Mais la réaction n’est pas la bonne : le technicien aurait dû vous dire qu’il vérifiait si le serveur de la base de données ne rencontrait pas de problème (saturation lié à d’autres sites puisque vous êtes en mutualisé ou problème technique) puis vous proposer de migrer la base sur un autre serveur pour être tranquille. En effet, ça marche ou ça ne marche pas mais ça ne peut pas yoyoter.

    #2365295
    ungars
    Participant
    Chevalier WordPress
    248 contributions

    Je suis passé en https.

    Ce soir pas de problème de connexion à la base de données, mais par moment une lenteur…

    Le technicien avec qui je converse veut que je fasse vérifier mon site par un webmaster, mais je ne vois pas ce qui cloche, et on est d’ accord, ou cela fonctionne, ou cela ne fonctionne pas.

    Dès le début j’ avais donné le copies d’ ecran avec les heurs pour qu’ ils regardent sur leurs logs.

    Ils me disent que de leur coté il n’ y a pas de problème mais je n’ y crois plus.

    Je leur ai transmis vos réponses.

    Je vous tiens au courant.

    Merci en tout cas de m’ être venu en aide.

    #2365415
    ungars
    Participant
    Chevalier WordPress
    248 contributions

    Bonjour, quelques nouvelles.

    Mon problème est sans doute plus complexe, mais n’ a rien à voir avec WordPress. J’ ai fait plusieurs Ping sur mon nom de domaine, souvent cela fonctionne, mais parfois j’ ai une série de pings dont 25 % ne sont pas arrivés (jusqu’ à 50%) . Un ping sur google fonctionne toujours.

    Là je suis tombé sur un technicien qui a fait passer mon ticket en 2ème niveau. Je pense que l’ on ne m’ a pas pris au sérieux.

    Bon Dimanche !

    #2365419
    mathieu42
    Participant
    Chevalier WordPress
    239 contributions

    Je pense que l’ on ne m’ a pas pris au sérieux.

    c’est un souci que j’ai remarqué chez beaucoup d’hébergeurs depuis quelques années, j’ai l’impression qu’en prenant une offre en dessous de 50 euros par mois, le service technique ne fait pas d’effort pour résoudre les problèmes techniques.

    #2365422
    ungars
    Participant
    Chevalier WordPress
    248 contributions

    Ca dépend je pense sur qui tu tombes le premier coup.

    Chez Online, tu as une réponse  en quelques minutes, de jour comme de nuit. Mais pour des erreurs à la c.. comme la mienne, ils vont voir que le site fonctionne, et cela s’ arrêtera là.

    Je peux comprendre qu’ ils doivent faire le tri entre pas mal de fausses alertes, mais dans mon cas, quand j’ annonce un wpconfig bien rempli, des pings qui n’ aboutissent pas, il faut surement investiguer un peu plus loin, d’ autant plus que j’ ai donné en détail les problèmes et les heures ou cela s’ est produit.

    J’ avais déjà eu un problème de ce type, ils m’ avaient à l’ époque conseillé de passer à une offre supérieure, car il y aurait trop de trafic sur mon site, ce qui n’ était pas vrai.  J’ ai failli le faire, mais en allant sur l’ irc d’ Online, qui a disparu entre temps, j’ ai vu que d’ autres avaient mon problème. Je suis donc revenu à la charge, avec d’ autres arguments, en menaçant de partir, et le problème a été reglé.

    Après il y a pire, l’ hébergeur qui met une semaine à répondre, pour un problème venant d’ eux. Ca je l’ ai eu aussi, avec l’ hébergeur d’ une connaissance.

    Eux au moins ils répondent.

    Là mon site n’ est pas en prod, je fais juste une démo pour quelqu’ un, mais j’ imagine le site pro qui fait des siennes. Ca la fiche mal.

    #2365424
    Li-An
    Modérateur
    Maître WordPress
    24646 contributions

    Avec mon hébergeur voire le précédent, une base de données qui ne répond pas, ça propose des solutions rapidement. Vous devez fréquenter de piètres hébergeurs.

    #2365425
    ungars
    Participant
    Chevalier WordPress
    248 contributions

    Je suis allé voir votre hébergeur, ce qui m’ embête ceux sont le nombre limité de visites par jour

    #2365433
    Li-An
    Modérateur
    Maître WordPress
    24646 contributions

    Si vous avez un site très fréquenté, il vous faudra un gros hébergement. Ou un serveur privé. Mais bon, je ne sais pas quelle fréquentation vous espèrez.

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.