Déconnecté en sortant de l’admin (Créer un compte)

  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #462302
    imported_BenKenobi
    Membre
    Padawan WordPress
    93 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.6.1
    – Thème utilisé : Hemingway Ex
    – Nom de l’hebergeur : 1&1
    – Adresse du site : http://www.benoitcatherineau.info

    Problème(s) rencontré(s) :

    Depuis le passage en 2.6, dès que je quitte mon admin en passant par le lien “aller sur le site” disponible à côté du nom du blog, je suis déconnecté purement et simplement. Ainsi je ne peux pas etre côté public en étant connecté, c’est embêtant pour répondre aux commentaire par exemple… il faut alors que je ressaisisse mes info pour le poster… c’est le comble pour l’admin quand même !

    Une solution ?

    #642758
    Maitre Mo
    Participant
    Maître WordPress
    1656 contributions

    Bonsoir BenKenobi,
    Il y a évidemment une erreur dans le fait que ce soit l’un de nous qui réponde à une question venant de toi, et non pas l’inverse, et encore plus dans le fait que ce soit moi, donc excuse par avance la vacuité de ma réponse, mais est-ce que ça le fait aussi si tu utilises le même bouton mais avec le clic droit, “ouvrir dans une nouvelle page” ?
    Sinon, ce problème ressemble fort à ce qui est évoqué sur votre blog à propos de la sécurité, non ?

    #642759
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    On est avant tout une communauté… et n’étant pas le meilleur technicien WordPress, j’ai moi aussi quelques problèmes que je ne sais pas toujours résoudre seul… donc peu importe qui m’aide de l’instant qu’on m’aide :D
    Merci de ton intervention donc.

    Sinon je suis d’accord avec toi sur le fait que l’article que tu m’indiques contient surement la réponse à mon problème mais j’ai tout essayé en vain… il me faudrait donc un indice supplémentaire 🙂

    #642760
    Lumiere de Lune
    Participant
    Maître WordPress
    19378 contributions

    Ca m’arrive mais seulement de temps en temps avec la 2.3

    La solution empirique, pour moi, est de me déconnecter, puis me reconnecter, depuis l’admin. Tout rentre dans l’ordre

    #642761
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    Il semble que cette démarche ne fonctionne pas non plus pour moi…

    #642762
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    J’ai quand même tendance à penser que c’est une question de cookies (bon, perso, je n’ai pas encore migré en 2.6, oui je sais j’ai honte).
    Par acquis de conscience, peux-tu
    1/ nous donner le format d’une URL de l’admin
    2/ nous donner le format d’une URL de ton site (côté visiteur)
    3/ vérifier le code qui se trouve derrière le bouton (aller sur mon site)
    4/ Si tu as FF + WebDeveloper, jeter un œil aux cookies de session de ton site pour chercher des indices.

    (Sur la 2.4 et 2.5, ça ne m’est jamais arrivé ; le seul truc qui arrive, c’est l’expiration d’un cookie)

    #642763
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    Mon admin se trouve ici : http://www.benoitcatherineau.info/bensite/wp-admin
    Côté visiteur : http://www.benoitcatherineau.info/2008/07/30/xxxxxxxx

    Mon WP est dans un dossier “bensite”, j’ai fait la redirection du index.php pour avoir accès directement depuis http://www.benoitcatherineau.info. Je n’ai jamais eu de problème, jusqu’à présent, de ce genre.
    Le code derrière le bouton est correct.
    L’analyse des cookies ne m’apportes pas grand chose j’avoue ne pas savoir interpréter les infos données par Webdeveloper.

    Je pense effectivement que le souci vient quand même d’un cookie avec la nouvelle façon de les former et les problèmes de SSL évoqué plus haut… mais je ne vois pas quoi.

    #642764
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Essaye la méthode expliquée même si ça correspond à une autre version, et tiens nous au courant !
    Si c’est inefficace, je crains que ça ne soit au delà de mes compétences…

    #642765
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    Sauf que comme tu le demandes justement dans le post en question, j’aimerai bien avoir aussi les lignes de codes à insérer dans mon wp-config.php… :D

    #642766
    Maitre Mo
    Participant
    Maître WordPress
    1656 contributions

    N’est-ce pas ce qui est défini dans le fichier wp-settings.php, page 7 et 8 ?

    #642767
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Je ne pense pas que SSL soit en cause ; ça ne concerne que l’accès à l’administration par HTTPS ce qui n’est généralement pas le cas (parce que ça demande la mise en place d’un certificat ce qui est normalement payant).
    J’ai un peu googlé mais je n’ai pas trouvé la réponse, c’est agaçant !

    @ Maître Mô » préciser la page n’a pas vraiment de sens ; la pagination dépend de la taille et la résolution de ton écran, ainsi que ton éditeur. Mieux vaut indiquer les n° de ligne, universels.

    #642768
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    Bon j’ai résolu mon problème… en fait c’est en résolvant un autre problème et le remède à fonctionné pour les 2.

    Je suis passé de PHP 4 à PHP 5 sur mon hébergement.

    Et voilà.

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.